Z-TRM2fx device database update

Tags: #<Tag:0x00007f43393e4238>

:joy: I wrote them a long mail yesterday, listing their failures in firmware:
Three modes should have three working setpoints.
While changing temperature on device (changing eco) there is no update of any setpoint, while changing comfort setpoint (setpoint_heating) gets sometimes an update, sometimes don’t.

Child lock not supported by zwave, brightness should get channels from them.

Let’s look, what they will answer me.

With Zwave in openhab i find out that Param9 and 10 only get an update when other Parameter changed.

Setpoint furnace seems to be defined by ZWave standard by:

This mode is used to activate fans to circulate air and heating or cooling will be activated to
regulate the temperature at the Furnace (0x07) setpoint.

No idea how that fits the idea of a floor heating thermostat…

On the other hand, what do you use the setpoint cooling for?

Please provide a debug logfile - otherwise I can’t see what is happening.

This is pretty old code (ie from OH1) so I’m not really familiar with this command class (I have no thermostats).

I will wait a bit before upgrading again, hoping that the other issues are resolved. If the warning is still there we can try looking at debug logs :slight_smile:

Some floor heatings you can change mode and then cold water is send to cool the rooms. In this case, the Thermostat (mode cooling) opens if it s getting to warm.

But more important is a NO and NC change in parameters. But that’s no problem from openhab, it’s the problem of Thermofloor made a very pretty design, good physical stuff, a good menu on device and a very bad firmware for zwave.

The device only shows incl to confirm inclusion when using secure mode. Fully included the display shows error, if using insecure inclusion.
No idea how they got the certificate from zwave alliance.

Physical temperature change doesn’t send new temperature via zwave, so much bugs.

Will see what they answer.

I have updated to the latest snapshot of the Zwave binding (build 562 from Feb. 11), but still don’t see the channels, even after deleting and re-adding the thermostat (as a Thing).
I guess that I had not stressed enough that I was talking about v1 of the Thermostat, with firmware 1.92.
(I realize that the thread is about Z-TRM2fx - I tried to start a separate thread about 1.92 (Help with setup of Heatit thermostat (v. 1), firmware 1.92 on openHAB 2.4), but did not get any answer there…)

Sorry, I did not catch that. I also have some of the Multireg/TF016, but they all run either FW 1.4 or 1.8, and for my use I see no point in upgrading.

I was tempted by the ability to see the on/off status; bought a cable from AliExpress for under $2 and it worked.
The problem is that v 1.92 does not work with openHAB properly. It lacks “setpoint eco” and instead has “setpoint furnace” that at least in my installation does not correspond to anything I can see on the thermostat. This means that I cannot control the setpoint in eco modus.
I am considering downgrading, if I find the 1.8 firmware somewhere…

This Post is for Version TRM2fx with has got Firmware 3.4. But with TRM2fx I had same issue. I allready wrote thermofloor and made a list of failures and missing things in firmware. Answer: We will look for it, that had been all.

What I did to solve this (Thanxs for all made the parameters working):
I write a rule to made my own setpoints for temperature which work:

rule "TRM2fx OG-Flur"
when
    Item OG_Flur_Thermo_Soll_Temp changed
then
    var int help
    var int newTemp
    newTemp = (((OG_Flur_Thermo_Soll_Temp.state as Number).doubleValue + 2) * 10).intValue
    logInfo("Recalculate OG_Flur", "Comfort: " + newTemp.toString)
    OG_Flur_Thermo_Soll_Temp_Comf.sendCommand(newTemp)
    help = ((OG_Flur_Thermo_Soll_Temp.state as Number).doubleValue * 10).intValue
    logInfo("Recalculate OG_Flur", "Eco-Parameter: " + help.toString)
    OG_Flur_Thermo_Soll_Temp_Eco.sendCommand(help) 
end

The items for it:

//Help Item
Number:Temperature 	OG_Flur_Thermo_Soll_Temp 		"OG-Flur FB Heizung Soll [%.1f °C]"
Number 			OG_Flur_Thermo_Soll_Temp_Eco 		"OG-Flur FB Heizung Soll Eco" 		{ channel="zwave:device:smartholhome:node6:config_decimal_param10" }
Number 			OG_Flur_Thermo_Soll_Temp_Comf 		"OG-Flur FB Heizung Soll Comfort" 	{ channel="zwave:device:smartholhome:node6:config_decimal_param9" }

In the rule above I allways set Eco-Temperature by parameter with calculating parameter with my Help Item and set Comfort 2 Degrees higher. This way I can trigger my own item via Groups and the rest works.

If you ask why dont use the original Setpoint: The Setpoint don’t gets Update if Temperature is changed an Device itself. Parameter receiving Updates sometimes.

Thanks for info.
My problem is that there is no channel for" setpoint eco" for TF016 with fw 1.92.
From what I can see from other threads it should be possible to create it in the database, using parameter 11, but it is a bit beyond me…

BTW, it sounds like Z-TRM2fx still does not work correctly in OH?
(I wanted to buy a couple, but now I am not so sure anymore.)

With openhab they work, because with openhab you can write some rules to correct most things, which are broken in firmware.

Chris and the others did a good job made channels to the parameters.

I wrote a list of 10 to 12 bugs and 5 useful wishes to thermofloor. They only answered the will look for it and deleted the list from support board where I could read it and see the status.

My opinion: they don’t like feedback:/

Back to the original thread: could someone activate the switch of the device as a channel again? Found an option to activate a switch in device option. I’ll try out if I m able to activate something useful there.

Hi, I too would like to have the switch channel activated again. At first I wanted to associate the switch output to an Fibaro relay connected to som other heaters, but the association never worked.
Then I made a rule to control the relay from the switch status. This worked ( polled the state every minute).
But when the channel is removed none of this is working.

Back in:

What do we learn from this? Never remove a channel which was reported as supported from the device :sunglasses:

Thanks a lot @sihui. Lesson learned…

1 Like

Hi, not to bump an old thread but I’m having some issues adding my “Z-TRM2fx” to my system. I’m fairly new to Z-wave, openHAB and probably other parts of my issues. From what I understand from this topic the 2fx will add as a previous product, where the channels are somewhat wrong. I’ve delved in the lands of javascript, C, C++ and some other programminglanguages so I’m not completely out of it, but I can’t seem to find any useful file on my openHAB which let’s me add your work.

Could anyone point me in some useful direction? :slight_smile:

What version of the binding are you using? If you’re using the 2.5 binding, then it should be supported unless I’m missing something (since this was updated 7 months ago).

I think I’m using 2.4, it’s what the binding says in PaperUI. But then again most bindings have the same version number.

Yes - they will. If you are using the fixed version such as 2.4, then they will all be the same - 2.4 :wink:

You need to use a newer binding - at least the 2.5 milestone version.

Important: for this device there are ota firmware updates published.

Next version will have change in options because at the moment you can only set differences of +/- 5 degrees in temperature: next version will have a two byte value for higher offsets.

1 Like