Z-Wave: add device POPP 700342 (Smoke Sensor) to database

Hi Folks,

today I tried to get a couple of POPP 700342 Smoke Sensors to work. Unfortunatly they do not seem to be in the device database yet, so I created an account on www.cd-jackson.com to add a database entry from the XML like described in the Device Database Guide. After I got this working and database permissions sorted (thanks to Chris for the quick response!), I found that there is no XML for the node in /var/lib/openhab2/zwave/. So I turned on DEBUG log upon device inclusion to find the reason why the XML is not written, but I’m not able to recognize an error in the log. Please find the logfile attached. It’s about the inclusion of NODE 33.

openhab.log (427.7 KB)

Any hints on how to continue are greatly appreciated!

Many thanks,

While you are waiting, the log viewer may be of use.


From this log, I can see the device is joining the network, but there’s not much after that. Probably you need to wake up the device - normally there’s a button you need to press to do this (maybe it needs to be pressed a number of times to do the wakeup - the manual should say).

You may need to wake it up a few times to complete the initialisation.

1 Like

There is a button, but according to the manual it’s for including (3s press), excluding (press) and reset (10s press) the device. So if I press it it might be excluded?
But if I understood ZWave correctly, the device should wakeup and fetch configurations from the controller in some interval anyway, right? Is is feasible just to wait a couple of hours/days and see if the XML is appearing?

I made an assumption that this is a battery powered device - is that correct?

Well, yes, but there’s a catch. Before this works, the controller must configure the device to actually do this - by default most devices won’t do this, and even if they do, they will not normally be configured to communicate with the correct node. So the device needs to complete initialisation first.

It’s feasible, and it might work, but I give it about 5% chance. If the device has a default wakeup, and if the device is configured to broadcast the wakeups, and if the device is close to the controller, then it might work in a few days.

I found this in the manual -:

To wakeup the device please perform the following action: A double click on the Z-Wave button wakes up the device.

1 Like

Yes, it’s a battery powered device.

In which manual did you find this? The manual on http://manuals-backend.z-wave.info/make.php?lang=EN&sku=POPE009402&cert=ZC10-16015002 says the double click is used for firmware updates …
But there is also an paragraph about NIF when pressing the button, so it’s not only for exclusion.
Am I the only one finding most of these Z-Wave manuals confusing? Sometimes I have the feeling that they are written for the wrong target audience - technically correct but not very helpful for a beginner who is fiddling around with this kind of device for the first time …


Maybe I have the wrong device, but it is apparently for the 700342 although the manual you reference is for the 9402 (I’ve no idea what one you actually have, or what the difference is - the photos look the same).

A NIF will also do the same thing as a wakeup, so you can also do this.

It’s unlikely you’re the only one :wink: I would agree with you :+1:

Ups, sorry. I mixed up the browser tabs with the manuals. Actually I have both: 700342 and 9402. The 700342 is without siren function and the 9402 is with, so you can sound an alarm even without smoke detection. The 9402 is more expensive and I don’t need the siren everywhere, so I bought both.

But anyway. I will fiddle around with the button som more and hope, that the XML will appear soon. Anything else I can try?


Ok, repeatedly pressing the button a couple of times worked. Now I have an XML and will try to add the damn thing to the database. :slight_smile:


So, I added the database entry. I filled all data to my best knowlegde. This was the first time I did this, so I hope for a mild verdict. :wink:

Many thanks for your help,

1 Like

Addition: Am I right to expect the OpenHab Things to be fully operational and receiving the channels after I updated to a version of the Z-Wave that is containing the new database entry?

Only after deleting the Thing and running discovery for the Z-Wave binding


The device database still shows an error for the device:

“Endpoint 0 has no command class linked to the basic class.”


@chris do you know how to fix this? Should this information not come with the XML? Anything I can do about it?

Thanks, Roland

You can ignore this - it’s not an error - it’s an “information bulletin”. It’s a general reminder that this might be a problem - some devices require this, and some don’t. Generally alarm devices don’t need this setting, so you can safely ignore this.

Ah, good to know. Then I will give it a try and update to 2.5.7.

Many thanks, Roland