Z-Wave again

Hi there it´s me again! :slightly_smiling:

Thx for the first help in another post, but i think i need help again.

I am using a Raspi2 with RaZberry GPIO card.
I have installed Raspbian Wheezy 2015-05-05 and followed
ARM based setup on OH-Wiki. After that the Linux based installation…also Wiki.

Z-Wave-Binding is installed and port is set to: ttyAMA0
HABmin is installed, Z-Wave-Binding marked as active and HABmin
shows the green online button.

But RaZberry-Card is not recognized, nothing under network in HABmin,
no nodes, logs etc.! No lights are on on RaZberry-Card…

DialOut is set like written down in the Wiki.

Can someone help pls…any ideas?


I assuming it is a permissions issue…

Do a “ls -l /dev/ttyAMA0”

It might say “root tty” and not “root dialout”

IF so, then add openhab to the tty group, too. (same command just change dialout to tty)

Also, I add this the following line to /etc/init.d/openhab and to /usr/share/openhab/bin/openhab.sh

"-Dgnu.io.rxtx.SerialPorts=/dev/ttyAMA0 "

right after “-Dosgi.noShutdown=true”

Using the Wiki method, I believe you use start.sh to launch.

I use the apt-get method posted on the github. It is simpler (it also puts files in different places).
I suggest that approach

The Razberry uses the Pi’s GPIO pins - Rx and Tx, which by default are used to transmit the console over text. By installing Z-way first, their install makes the necessary changes on the Pi to disable the serial output and make it available for apps. You then stop and disable the Z-way service and start Openhab…

Using Wheezy I have not had to install Z-Way first, but using Jessie or whatever it is, the newer build, I absolutely had to install Z-Way first before Openhab would work with the Razberry.

Wheezy was easier for me to get things up and running… However, on to the next hurdle…

Thx for ur answer…i will try at the moment.
Better idea to switch to Z-Wave ZME_UZB1 Me USB Stick or Aeon Labs USB Stick?

Good morning!

Still the same error :confused:

No lights on the GPIO-Card, HABmin Logwiever is empty,
but HABmin says online with the green dot.

If i switch to configuration in HABmin, choose Bindings,
network is empty under the Z-Wave binding.
If i press devices and AddNode, HABmin says: error sending action to the server.

I also tried looking in the openhab logs in var/log/openhab.
openhab.log is showing the last entry 2 days old…
request.logs are up to date.

Any ideas?

New installation, now Jessie, and this time with Z-Wave ZME_UZB1 Me USB Stick
and the same old problems.

If i choose devices and include, HABmin says: error sending action to the server.

What can i do? Need help pls…

maybe this is useful:

I finally did it!

/dev/ttyACM0 was the right port.

Hi I have the exact same problem with the Razberry GPIO card with Pi 3. When I tried to include new device from HABmin it says “Error sending action to server” .
When I did this
ls -l /dev/ttyAMA0
it gave me
crw-rw---- 1 root dialout 204, 64 Feb 20 16:01 /dev/ttyAMA0

When i tried with the ACM0 , it says no such file or directory. Thanks for your help.

I Have the same setup as you, but used the OpenHabian image. There is a config tool that configures the serial port for you, and sets all of the various permissions. It’s been running for months on the various snapshot builds, and is rock solid.

I created these topic for an older version
of Openhab. I think it was v1.8.

In v2.2 you can setup the serial port
with the build-in config tool.

Please look at the setup instructions for
the raspberry. (Openhab Guide/Wiki)


Found the config tool?
Is it working now?