Z-Wave battery devices issues in general

Thanks - sorry, I missed that.

I don’t know what’s different then about your setup since I don’t think this is a universal issue :confused:.

I think you guys has direct contact with your stick (even if you think you don’t) - that’s why you don’t see this issue!? Remember even my node 14 does not work outside the direct range of the stick.

I will add a new wall controller now, to see how it acts.
This is how I add devices;
I shutdown OH2, remove the stick, include the new device using the stick, insert the stick and let the battery device stay close to stick/computer untill it is fully up. Sometimes I provoke the battery device to send things.

Nope - definitely not for me. I have battery devices outside (well, in another building about 30m from the back of the house, and the controller is at the front end of the house, so another 16m away inside).

You also see this issue that was raised where someone had a similar issue to you with some remote controls, but it was sorted once the devices were properly initialised.

I’m sure that not everyone has all devices in contact with the stick, so I think it should work, and the stick should sort this out, not the binding.

OK. But if I am reading that thread correctly (rather long), the devices never came out of init? Afaict, mine does. And they are still working when close.

Anyway, I’ll await next heal (in about half an hour) and see what happens.

The new battery node also did not report any neighbours, but it is not fully out of init yet, so hoping for a miracle.
Before adding the last one, I disconnected the Vera, since I was hoping it would be part of the problem (after reading the other thread)

OK, so the heal did not touch my battery nodes at all. It only tried to fix my dead nodes.

I have two options, the first is to take a backup of the stick and reset it, and then try with one battery node, and one powered node to see if the problem remains. If it does, I’ll have to throw away the battery devices. If it does not, I’ll have to re-learn the whole house (:sob:) or throw away the battery devices and restore the backup.
But I need more energy before doing that, since I need to find a windows computer to take/restore the stick backup. :frowning:

No - in the end everything was ok. The issue was that the wakeup was not initially set if I remember correctly (which I might not).

Note that the Heal will only work when a battery device wakes up - did you wake up the device?

Well, all my battery devices are nowadays set to wake up every 10 minutes while I’m testing.
So, no, no heal on them. (which kind of makes sense, since they are “online”).
I got the “Starting heal” message on 3 nodes, all powered off nodes.

I was working in the garden, and I came up with another solution - I’ll get a new gen5 stick, to test with and then clone the current one onto it to see if I can get it to work. Not sure the local shops has any in stock though.

Ok, as mentioned earlier, I’ve not tested the heal code in OH2 yet, so it’s possible it still doesn’t work properly. I’ll try and take a look at this over the next few days. I don’t think it will help, but it’s my last suggestion…

OK, great.

I had to order the new stick from an internet shop, so I hope I’ll receive it during next week (which is full of holidays). If you change anything in the heal, just let me know, and I’ll be onto it like a hawk. :slight_smile:

Will do…

Got my new Gen 5 stick yesterday, picked up a new Qubino dimmer as well.

Devices: Aeon Gen5 stick, Qubino gen 5 dimmer, ZME Wall Controller.
Stick is new out of box.
Qubino is new out of box.
ZME Wall Controller is reset and excluded.

I installed a clean OH2 on my desktop, added minimal item file and sitemap containing just those two devices.

Qubino included with stick button. -> node 4
ZME Wall Controller included with stick button. -> node 8

Stick put into desktop.
Stimulated node 4. After a while showed up in inbox. Added.
Stimulated node 8. After a little longer, showed up in inbox.
Stimulated node 8 a couple of times to speed up (NIF’s).
(Restarted OH2 a couple of times)
Both devices now on my desktop.

Looking into Z-wave network settings, Controller is Master, Controller is not SUC. (these are the defaults, I have not changed)

Restarted OH2 just to be sure, but end up with a familiar picture; Node 8 is as alone as it was in the house installation.

But! Moving the Qubino away, and then put the Wall Controller even further away, the WC still works! And when unplugging the Qubino, it stops working.

So, I guess, one learning experience here is that the neighbour list is not to be trusted. (which I have assumed before as well, but now it is verified)

Now I need to find out why my house installation does not act the same way.

I’m also in the process of revamping the routing code - this may impact on this issue so hopefully I’ll have something to look at for tomorrows snapshot.

Aha! Might that make a difference to my ‘real problem’ with battery nodes, or is it rather something for the ‘Network View’?

I’m considering biting the dust and redo learn the house, but I is a horrible job, especially if I reset all node to factory defaults, so I’m collecting energy to do it.
I will try to do the backup/restore routine to the new stick before doing anything else, since I would like to verify that it actually works to restore.

It’s related to this issue - not the network view. There’s one part of the heal code which might be useful, and that’s setting return routes (or actually, telling the controller to set the routes). I’ll try and do this tonight…

That sounds interesting!
In this case, I’ll wait a few days with the full house re-learn and cross my fingers there’s anything in the heal that can mend my routing troubles. Thanks!

Ehhh, not really. I eventually got completely stymied as far as battery devices wen, cleared the deck and started over with a factory reset zstick. Disassociated everything from my Vera, and then reassociated with my Z-stick. For devices that I didn’t do a factory reset on, I did have to manually go and set their association groups (OH1 never seemed to want to do that). For new devices and/or devices that were factory reset, OH1 correctly sets the association groups when they join the network.

FWIW. :wink:

Associations are a different issue, and most devices are not configured in the database to automatically set this, so yes, in most cases in OH1, you need to do this manually.

The point was that, if I remember correctly, your devices did work when outside of the range of the controller - this is associated with the WAKEUP class - not associations? Or do I remember wrongly?

Ah, now I get what you were going at. I absolutely have battery operated devices that are not in direct range of my Z-stick 5. (Some of them are two hops away if memory serves!) They [now… :wink: ] have no better and no worse reliably than battery devices that are in direct contact range of the ZS5. (Multiple vendors’ contact switches, PIRs, and smoke alarms are all represented in this comment!)

(This sounds like it sucks, but in actuality they all work great! Just every once in a long long while one of my contact sensors loses a transition. 99-99.5% correct, though, so not even worth the effort to debug.)

Further, if I change a non-direct-contact battery device’s configuration variable and then wake it up in place (without bringing it in direct range), it’s able to fetch its new config OK.

I have fibaro fgfs 101 smoke sensor and door sensor, flood sensor .
All of these device are not reporting battery level. i want periodic updates for battery level.
I have items file entries for all devices.
But i got battery level only once when battery cell were inserted.

Anybody have idea about this…?