Z-Wave binding gets uninstalled if I restart openhab service


first some information about my platform:

  • Raspi 3B
  • Openhab 2.5.0

Recently I bought a Aeotec Z-Wave 5th generation stick. I installed the Z-Wave binding using PaperUI and added manually the ‘Z-Wave serial controller’. The Z-Wave serial controller becomes online.
I also could successfully add an infrared motion detector.
But when I restart the openhab service everytime the Z-Wave binding gets uninstalled, here is what tail shows to me:

2019-12-21 20:54:03.286 [hingStatusInfoChangedEvent] - ‘zwave:device:e4109fca:node5’ changed from ONLINE to UNINITIALIZED
2019-12-21 20:54:03.427 [hingStatusInfoChangedEvent] - ‘zwave:device:e4109fca:node5’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2019-12-21 20:54:03.432 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:e4109fca’ changed from ONLINE to UNINITIALIZED
2019-12-21 20:54:06.647 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler
2019-12-21 20:54:06.665 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:e4109fca’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2019-12-21 20:54:47.796 [thome.event.ExtensionEvent] - Extension ‘binding-zwave’ has been uninstalled.
2019-12-21 20:54:57.033 [thome.event.ExtensionEvent] - Extension ‘binding-zwave’ has been uninstalled.

Does anybody here face the same issue?
What is the problem here?
Is there any solution available?

Thanks for any help!

1 Like

Looking at other topics it’s mentioned to manually create your Z-Wave serial controller in your things but it’s mentioned above that you have done this.:thinking:

Have you tried uninstalling the binding, stopping OH, cleaning the cache, restarting OH and reinstalling the binding? Have you set the binding log to DEBUG or TRACE to see if there is any additional info?

The recommendation from the developer is to use a UI such as HABmin to add the controller. In HABmin, you select the + sign, define the Thing. and then configure the serial port.

Follow the binding instructions for when things do not go as planned. Do not filter the debug logs. You can post here or check the log viewer yourself.


1 Like


thanks. As suggested I wanted to give HABmin a try to install the Z-Wave binding.
Therefore I tried to install HABmin using PaperUI–>Addons–>User Interfaces–>HABmin–>Install.

Then I tried to open HABmin using follwing URL:


But the upcoming page just shows ‘Loading…’ - nothing more :-(.

If I look into the browser log there are more than 300 ‘Not Found’ errors:
(Just took a screenshot of the last few errors)

What I am missing here?


I could help myself, at least how to start HABmin.
I just used the wrong URL, the correct one is:


Now I will go ahead and try to install the Z-Wave binding using HABmin.

BTW, I deleted the ‘Z-Wave Serial controller’ using Paper UI–>Things and clicked the trashcan icon. Then I clicked ‘Force uninstall’.

Is that enough? Or do I have to do anything else to uninstall ‘Z-Wave serial controller’?

Any help how to do that would be really appreciated…

1 Like

That should be enough, I believe.


now I installed the Z-Wave binding using HABmin, as suggested here.
First I added the binding using

Configuration–>Extenions–>Bindings–>Z-Wave Binding and clicked Install.

Then under Configuration–>Things–>Z-Wave Serial Controller I set the Port to /dev/ttyACM0

Then the Z-Wave controller gets online.

But still the ZWave serial controller gets uninstalled if I restart my raspi or I restart the openhab service:

2019-12-26 11:56:57.522 [thome.event.ExtensionEvent] - Extension ‘binding-zwave’ has been uninstalled.

This is really annoying because everytime I restart the raspi or I restart the openhab service I have to reinstall the Z-Wave binding.

What please is the problem here?


I still have this problem - is anybody able to help me out here?

I sure wish I had an answer, but I just joined to say that I’m having the same trouble. I couldn’t get anywhere by using HABmin either. One additional thing I noticed is that, as soon as the pi restarts, the Thing shows as online, then it switches to uninitialized, then to the missing handler error. I’m brand new to openHAB, so I don’t know where anything is yet. Maybe I’ll just start over from scratch and see what happens.


I still have this problem. My current version of OpenHAB is 2.5.5-1.

May Chris can help here?