Z-Wave binding offline with OH3

I have a strange problem. My Z-Wave binding was working and I added around 30 z-wave devices. Then today it stopped working and I cannot revive it. It just says it’s online.

At one point I moved the jsondb directory aside and let OH3 create a new and empty configuration. I then added the Z-Wave binding and the bridge and it worked.
So I’m fairly certain the problem is somewhere in the OH3 jsondb directory and not with my stick, O/S, or anything else.

I’m using a Raspi4 with openhab The Z-Wave stick is a GoControl CECOMINOD016164 HUSBZB-1 USB Hub.

I did check the permissions of /dev/ttyUSB0 and /run/lock and they’re wide open:
raspi:/var/lib/openhab>ll /dev/ttyUSB* /run/lock/
crw-rw-rw-. 1 root openhab 188, 0 Oct 16 21:13 /dev/ttyUSB0
crw-rw-rw-. 1 root openhab 188, 1 Oct 16 22:02 /dev/ttyUSB1

total 8
drwxrwxrwx. 7 root root 180 Oct 16 21:50 .
drwxr-xr-x. 52 root root 1480 Oct 16 20:41 …
drwx------. 2 root root 60 Jul 20 00:00 iscsi
-rw-r–r–. 1 openhab openhab 11 Oct 16 21:40 LCK…ttyUSB0
-rw-r–r–. 1 openhab openhab 11 Oct 16 21:16 LCK…ttyUSB1
drwx------. 2 root root 40 Jul 20 00:00 lvm
drwxr-xr-x. 2 root root 40 Jul 20 00:00 mrtg
drwxr-xr-x. 2 root root 40 Jul 20 00:00 ppp
drwxr-xr-x. 2 root root 40 Jul 20 00:00 subsys

I added /dev/ttyUSB0 into the Java Opts:
raspi:/var/lib/openhab>grep USB0 /etc/default/openhab



Any quick help would be greatly appreciated. Some of the lights in my house are now more or less offline since they don’t have a light-switch. So my family is not very happy about this situation right now.


Here’s my openhab log in debug mode:

openhab.log (768.7 KB)

Some more info: I tried to add more z-wave lights and they couldn’t be factory reset or scanned in. So I did put the z-wave controller into exclusion mode for a while hoping that the lights get their exclude signal from this controller instead of SmartThings and I can pair them.
Could that be the problem? The configuration says it’s not in this mode anymore now. And as said, it came online with a new vanilla configuration. So I don’t think it’s stored on the stick itself.

I’ve updated to 3.2.0-M3, no luck either.

Did you restart openHAB at some point in this process?
Is the controller online or offline at this point?

I’m a little confused over what is going on. you said

Added from where?

Ahh… what? Were these lights previously included in another system?

Try running Habmin and excluding the lights from there

OP is on openHAB 3, there is no HABmin ….

There is not much about zwave in the log file but these entries:

2021-10-16 22:03:14.182 [DEBUG] [onfig.core.ConfigDescriptionRegistry] - No config description found for 'thing:zwave:serial_zstick:bf7e2f2fee', using alias 'thing-type:zwave:serial_zstick' instead
2021-10-16 22:03:14.182 [DEBUG] [nfig.core.status.ConfigStatusService] - There is no config status provider for entity zwave:serial_zstick:bf7e2f2fee available.
2021-10-16 22:03:14.184 [DEBUG] [g.zwave.internal.ZWaveConfigProvider] - No bridgeUID found in getConfigDescription thing:zwave:serial_zstick:bf7e2f2fee

Sorry for the confusion. I’m trying to migrate from SmartThings to OH3. I had around 60 to 80 devices on SmartThings and already migrated maybe half of them to OH3. Yesterday I tried to migrate more devices.
Normally this unpairing/pairing is fairly easy, albeit somewhat time consuming. I tried to do three fairly old GE z-wave dimmers and switches and they gave me a real hard time. Either I couldn’t unpair them from ST, they never went into pairing mode, or OH3 didn’t pick them up.

So yes, they were never paired to OH3 but paired to another system.

Yeah. That’s my problem. There is not much to work with.

Here’s another update. After 30 minutes or so the controller decided to come online and then most devices came back. Maybe the upgrade of OH3 to 3.2 M3 did something good.

But now all my ZigBee devices are gone. I guess I cannot have both.

I may have done a mistake by going into the advanced mode at the ZigBee controller and choosing to re-initialize it. Now all ZigBee devices show as Gone. I hope I don’t have to repair them all back in.

Unfortunately, yes, you will likely have to add all devices back into the network if you reinitialise the coordinator.

The description of this parameter states -:

Resets the coordinator, reinitialises the network, and sets the configuration to the configured values

So it has reinitialised the network - so you have a new network now and some security attributes will have been reset that almost certainly will prevent existing devices using the network without re-joining them.