Z-Wave Binding Strange Error Messages

I have installed a Z-Wave system with five nodes - namely the USB stick (on zone 1) plus four Fibaro FGS-223 double switches (on zones 2 thru 5). The system seems to be functioning OK, but I am getting some strange error messages in the OH log file. I am seeing two different types of errors – namely

  1. Errors that refer to existing nodes 1,2,3,4,5 in my system
2019-10-06 15:47:21.200 [ERROR] [class.ZWaveMultiInstanceCommandClass] - NODE 4: Unsupported command class 0x2

2019-10-06 06:36:30.177 [WARN ] [.commandclass.ZWaveMeterCommandClass] - NODE 2: Invalid meter type 9
2019-10-07 13:23:14.305 [WARN ] [.commandclass.ZWaveMeterCommandClass] - NODE 3: Invalid meter scale 0
2019-10-06 18:40:55.614 [WARN ] [.commandclass.ZWaveMeterCommandClass] - NODE 4: Invalid meter type 17

2019-10-07 00:26:28.906 [WARN ] [.commandclass.ZWaveColorCommandClass] - NODE 4: Invalid color 10
2019-10-07 00:26:28.910 [WARN ] [.commandclass.ZWaveColorCommandClass] - NODE 4: Invalid color 14
  1. Errors that relate to “nodes” that are NOT in my system
2019-10-06 17:05:39.842 [WARN ] [nal.protocol.ZWaveTransactionManager] - NODE 7: Not initialized (ie node unknown), ignoring message.
2019-10-07 14:40:29.502 [WARN ] [nal.protocol.ZWaveTransactionManager] - NODE 19: Not initialized (ie node unknown), ignoring message.
2019-10-06 18:20:33.151 [WARN ] [nal.protocol.ZWaveTransactionManager] - NODE 21: Not initialized (ie node unknown), ignoring message.
2019-10-07 14:29:56.294 [WARN ] [nal.protocol.ZWaveTransactionManager] - NODE 28: Not initialized (ie node unknown), ignoring message.
2019-10-07 00:02:22.758 [WARN ] [nal.protocol.ZWaveTransactionManager] - NODE 36: Not initialized (ie node unknown), ignoring message.
2019-10-07 14:27:09.294 [WARN ] [nal.protocol.ZWaveTransactionManager] - NODE 68: Not initialized (ie node unknown), ignoring message.

I wonder if anyone can shed any light on what might be causing these errors?

post items file in question please
also what is the stick, did you buy it new, never used with another system?

also platform os and OpenHAB version please

Apparently your stick has old nodes that can cause Z-Wave network instability/ I believe you should be able to discover those Things and mark as failed in HABmin. You can then delete those things.

That does not work for some controllers though. I needed to use Zensys Tools to remove mine.

If this is not a new installation, you should delete & re-discover your node Things to get new binding information. The thingids stay the same so your Items are not broken.

I’m not sure about the invalid meter and color warnings.

Regarding issue #2, given the small size of the network, I’d suggest excluding nodes 2-5, then do a hard reset on the stick, then include the FGS-223 devices back into the network. That will assure a known good and clean starting point.

They may need Zensys Tools to do that.

Possibly. But, I’d suggest trying HABmin first, then resorting to Zensys if there’s an issue.

Please provide a debug log showing what is being received from the controller.

It’s easy enough to do that in HABmin or PaperUI.

1 Like

I’ve just realised that these errors are only appearing a few times per day, so my guess is that this is simply some corruption - either over the air (ZWave error detection is pretty poor) or over the serial port.

  • The items file is below…
  • The stick is a ZME E UZB which I purchased new.
  • The OS is OpenHabian on a Raspberry Pi v3
  • The OpenHAB version is v2.5
// Zwave Items
Switch Under_Floor_Heating_System_Enabled "Under Floor Heating System Enabled [%s]" <switch> {channel="zwave:device:g24:node2:switch_binary1"}
Switch Under_Floor_Heating_Valve_Open "Under Floor Heating Valve Open [%s]" <fire> {channel="zwave:device:g24:node2:switch_binary2"}
Switch Domestic_Hotwater_System_Enabled "Domestic Hotwater System Enabled [%s]" <switch> {channel="zwave:device:g24:node3:switch_binary1"}
Switch Domestic_Hotwater_Valve_Open "Domestic Hotwater Valve Open [%s]" <fire> {channel="zwave:device:g24:node3:switch_binary2"}
Switch Radiator_Heating_System_Enabled "Radiator Heating System Enabled [%s]" <switch> {channel="zwave:device:g24:node4:switch_binary1"}
Switch Radiator_Heating_Valve_Open "Radiator Heating Valve Open [%s]" <fire> {channel="zwave:device:g24:node4:switch_binary2"}
Switch Towel_Rail_Heating_System_Enabled "Towel Rail Heating System Enabled [%s]" <switch> {channel="zwave:device:g24:node5:switch_binary1"}
Switch Towel_Rail_Heating_Valve_Open "Towel Rail Heating Valve Open [%s]" <fire> {channel="zwave:device:g24:node5:switch_binary1"}
Switch Boiler_System_Enabled "Boiler System Enabled [%s]" <fire> {channel="zwave:device:g24:node5:switch_binary2"}

I have tried this, both on HabMin and PaperUI, and there are no more Things than the nodes 1 thru 5 which I am actively using. i.e. there is nothing else discovered or already existing.

Yes it is true, the errors are only appearing 5 or 6 times a day. I do have other non Z-Wave devices in the house (namely Luxaflex blinds, Tado and Heatmiser thermostats, Philips Hue hub) so I wonder if those devices could be interfering in some way?

2.5 has not yet been released but there are 3 Milestone testing builds.

The unused nodes would be stored in the Z-Wave network configuration on your controller. In my experience they are not always discovered by OH. Perhaps @chris has more ideas on how to clear the zombies from the controller.

Correct. That is what I am using.

2.5M1, 2.5M2, or 2.5M3 ? :wink:

openHAB 2.5.0~S1706-1 (Build #1706)

I think that is an unstable snapshot build. Perhaps that would explain the strange error messages. Do you get the same error messages running the testing version 2.5M3?
The unstable snapshots are mainly designed for developers to verify all the various parts of OH work together. Strange errors are to be expected until very close to release.

No - it shouldn’t. ZigBee uses a totally different frequency for starters…

No - this will definately not be the issue. There is no real change from 2.5M3 to the current snapshot, and absolutely no change in the processing of incoming messages. This is something that is not totally uncommon, and is highly likely to be simply corrupt messages due to the very poor error detection used in ZWave.

1 Like

Hmm. I replaced the Z-Wave.Me USB stick with an AeoTec Gen 5 stick. And all of the error log reports seem to have gone away. I’m not sure why that would be the case from a technical standpoint; but the AeoTec certainly gives the visual impression of being a more solid product…

1 Like

Correct. I’m using the zwave.me since five years without any problems.
Your vendor should probably replace that stick.