Z-wave binding with z-stick S2 on OS X

Hi, I’m new here and a beginner to openHAB.

I’m trying to get set up the z-wave binding with my z-stick S2 and it’s not going well :blush:

This is the z-wave part of the openhab.cfg file
zwave:port=/dev/tty.SLAB_USBtoUART

(/dev/tty.SLAB_USBtoUART it the port I found using ls /dev/tty* )

For the port I’ve also tried:
/dev/tty.PL2303-0000103D /dev/cu.SLAB_USBtoUART
(I’ve tried some others I’ve seen but I can’t remember them)

When I run openHAB in debug mode I get:
22:31:55.881 [DEBUG] [.zwave.internal.ZWaveActivator:36 ] - Z-Wave binding started. Version 1.8.0 22:31:55.893 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ] - ConverterHandler not initialised. Polling disabled. 22:31:55.894 [INFO ] [.z.internal.ZWaveActiveBinding:325 ] - Update config, port = /dev/tty.SLAB_USBtoUART 22:31:55.895 [INFO ] [.z.internal.ZWaveActiveBinding:330 ] - Update config, healtime = 2 22:31:55.895 [DEBUG] [.z.internal.ZWaveActiveBinding:282 ] - Initialising zwave binding 22:31:55.905 [INFO ] [.service.AbstractActiveService:169 ] - ZWave Refresh Service has been started

Also I’ve tried habmin:



The error message appears when I click ‘heal’, ‘include’ or ‘exclude’.

Any help, would be greatly appreciated. :slightly_smiling:
Thanks.

UPDATE:

I’ve tried on a Windows PC and the binding connected to the ZStick at port COM3

I also tried on a Mac Mini (OS X Lion) and it doesn’t work on there

It runs ok on a Macbook Pro - what are you using to test (other than the Mac Mini)? I assume the serial driver should work ok on most computers, but I’m not 100% sure of that…

I first tried to use it on a Macbook Pro (Early 2011, Yosemite)

Are you sure there’s no exception being thrown? If you are using a separate zwave debug log, then I suspect exceptions will go into the main log… Basically, a few lines after the “Initialising ZWave binding” there should be another message saying “Starting Z-Wave controller” and this doesn’t appear to be in your list - this is all before the com port is even opened…

err…

I don’t have a separate log for z-wave

When I run start_debug the only mentions of zwave are:

16:36:17.925 [DEBUG] [.zwave.internal.ZWaveActivator:36 ] - Z-Wave binding started. Version 1.8.0 16:36:17.936 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ] - ConverterHandler not initialised. Polling disabled. 16:36:17.937 [INFO ] [.z.internal.ZWaveActiveBinding:325 ] - Update config, port = /dev/tty.SLAB_USBtoUART 16:36:17.937 [INFO ] [.z.internal.ZWaveActiveBinding:330 ] - Update config, healtime = 2 16:36:17.937 [DEBUG] [.z.internal.ZWaveActiveBinding:282 ] - Initialising zwave binding 16:36:17.938 [INFO ] [.service.AbstractActiveService:169 ] - ZWave Refresh Service has been started