Z Wave controller offline after reboot

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
    • OS: what OS is used and which version
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Running openHAB2 on Ubuntu Server with help from openHABian.

Intel NUC

I found the correct serial port and installed my Aeon 5 Z wave device. It show online and find my outlets.

I turned my NUC off and moved it to the place I want it to be (in the closet without a screen, just power and ethernet).

Now when I connect to it, it says Offline all the time. The only thing that works is if i remove the controller in openHAB and re-add it. But if I do so every connection to my outlets is gone forever…

Please help

Hi @emil1,

  1. Check what serial port of Aeon 5 Z wave device before you turn off NUC
  2. When you turn off and turn on NUC again, check serial port of Aeon 5 Z wave device at this time.
    If the serial port before and after is different, it’ll make Z Wave controller offline

Thanks for the reply.

It´s the same port and I know it because if I remove the Z Wave controller in openHAB and re-add it with the same port, it works…

Z-Wave Binding version ? openHAB version ?
Try lastest version of Z-Wave Binding.
Good luck :slight_smile:

I tried reboot my openHAB and Z-Wave Controller still online.
I run openHAB 2.2.0 and Z-Wave Binding 2.3.0 SNAPSHOT ( I also use Aeon Z-Stick Gen 5 )
Try with these steps:

  1. Uninstall old Z-Wave Binding
  2. First, use this command in karaf console : feature:install openhab-transport-serial
  3. Download lasted version Z-Wave Binding and copy it to /usr/share/openhab2/addons/
  4. Add Z-Wave Controller Things and check.
    Good luck :slight_smile: