Z-Wave ConverterHandler not initialised

I had my Z-Wave binding working well. Was able to control a simple wall outlet. Started trying to add a Kwikset 910 and failed miserably. However, during my attempts to resolve I broke something and now i can’t see the devices in habmin and my log simply says the following. I have restarted several times and tried to revert my .items file to just having the section for the wall outlet. But remains the same.

2016-03-17 22:56:15.766 [DEBUG] [.zwave.internal.ZWaveActivator:36 ]- Z-Wave binding started. Version 1.8.1
2016-03-17 22:56:17.603 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.
2016-03-17 22:57:40.866 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.
2016-03-17 22:57:41.026 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.

here is my zwave section from openhab.cfg:
zwave:port = /dev/ttyUSB1
zwave:healtime = 2
zwave:softReset = true
zwave:masterController = true

and my one line from .items file:
Switch Wall_Plug “Wall Plug” ( FF_Office) {zwave=“2:command=switch_binary” }

I lowered the log level to trace and then re-included the wall plug manually with stick not habmin and got the following. The last line showed up when i attempted to turn on the outlet using the UI.

2016-03-17 23:15:35.933 [TRACE] [.z.internal.ZWaveActiveBinding:135 ]- bindingChanged Wall_Plug
2016-03-17 23:15:35.958 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.
2016-03-17 23:15:36.197 [TRACE] [.i.ZWaveGenericBindingProvider:48 ]- validateItemType(Wall_Plug, 2:command=switch_binary)
2016-03-17 23:15:36.210 [TRACE] [.i.ZWaveGenericBindingProvider:57 ]- processBindingConfiguration(Wall_Plug, 2:command=switch_binary)
2016-03-17 23:15:36.232 [TRACE] [.z.internal.ZWaveActiveBinding:135 ]- bindingChanged Wall_Plug
2016-03-17 23:15:36.257 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.
2016-03-17 23:16:27.228 [DEBUG] [.z.internal.ZWaveActiveBinding:222 ]- internalReceiveCommand Called, But Not Properly Configure yet, returning.

What else is logged when the binding starts? Do you see messages like “Update config, port=xxxx”?

No, I don’t you see messages like “Update config, port=xxxx”. I deleted zwave.log, stopped the openhab service, and restarted it. Zwave.log looks like this after start up:

2016-03-18 19:51:37.365 [DEBUG] [.zwave.internal.ZWaveActivator:36  ]- Z-Wave binding started. Version 1.8.1
2016-03-18 19:51:41.542 [TRACE] [.i.ZWaveGenericBindingProvider:48  ]- validateItemType(Wall_Plug, 2:command=switch_binary)
2016-03-18 19:51:41.573 [TRACE] [.i.ZWaveGenericBindingProvider:57  ]- processBindingConfiguration(Wall_Plug, 2:command=switch_binary)
2016-03-18 19:51:44.572 [TRACE] [.z.internal.ZWaveActiveBinding:157 ]- allBindingsChanged
2016-03-18 19:51:44.612 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.

Btw, I’m not sure if this would have made a difference,but during my attempts to get the Kwikset lock working I tried this zwave addon file:
1133742 Feb 26 08:06 org.openhab.binding.zwave-1.8.0-SNAPSHOT.jar

Now I am back to using this one (meaning it is the only zwave file in my addons directory):
1202283 Feb 1 11:05 org.openhab.binding.zwave-1.8.1.jar

Well, it looks like your configuration file isn’t being read if yo’re not seeing these messages. Are you running under OH1 or OH2? I know the binding is the OH1 binding, but what about the runtime.

OH 1. I have setup OH 2 on the same DPi in /opt/openhab2. But OH 1 is still where i’m experiencing this issue.

Are you also having problems with other bindings, or is Z-Wave the only one you’re running? It looks to me like your config file is not being read…

The only other binding I use is a serial binding for a MySensors serial gateway. It is working fine. However, that is defined in my .items file. Which config file do you think is not being read? openhab.cfg since that is where the zwave binding is deifned?

Yep. The binding reads this, and then it should print some messages about updating the COM port, and then it initialises the port, the converter system, and some other things. This is called from the method that reads the config settings though, so this is why I think it’s not reading this information.

Thanks for your help Chris, but I managed to get everything working quicker in OH 2 than resolving this, so I am going to stop working in OH 1 and stick with OH 2 for now.