Z-Wave copying configurations

I’m just getting started using my Aeon Labs Z-Stick to get my z-wave devices going. I’ve used the stick in the past to update the firmware on many Aeotec devices (which are all attached to my Vera Plus, and controlled there via the mios binding). The Vera leaves a bit to be desired, so I’m hoping to switch to using the zwave binding instead.

I’m leveraging the latest snapshot available (, and I’m trying to add my first device, a “WO15Z Single Wall Outlet.” However, where my OpenHAB server resides and where the outlet resides are somewhat far apart. So I’ve installed the same version of OpenHAB on a laptop, connected my Z-Stick to it, and added it successfully there. I shutdown OpenHAB, grabbed the relevant stanzas from the jsondb files, and then added them to the server system in hopes that it would get past the initialization phase.

I’m attaching debug level logs; however, what’s the best way to handle adding a device that is farther away? I thought my method would work, but it seems no matter what I do I keep getting “Is currently marked as failed by the controller” in the logs for my server system.

Debug logs here: https://paste.fedoraproject.org/paste/AR6OFAj-b53alrqwSFgFbQ

Any thoughts?

Three thoughts:

  1. the device supports network-wide inclusion - are you sure you can’t just include it from its location?

  2. why not temporarily wire the device to a mains plug and bring it near the openHAB server for inclusion?

  3. Alternatively, put zensys tools on the laptop (assuming it runs Windows) and then take the laptop over to the device


Thanks for the response - sorry I’ve only just seen it now.

  1. This is the first device in my network, so there’s no other repeaters or anything to amplify the signal. I’d like to think it would work where it is (only about 25m away), but this is consistently happening.
  2. I’m trying to bring the openHAB server to the device (a wired wall outlet) for inclusion, and after it’s stable for a few hours, I’ll move it back and update this thread.
  3. I’m using an Aeotec Z-Wave Stick, so I’ve been able to include and remove the outlet without any software successfully. But once the stick and the outlet are associated and I start openHAB back up, I get what you see in the logs I shared.

So I’ve tried as I described above, placing the openHAB server physically next to the outlet. It worked great for about an hour, totally stable connection. So I gracefully shut everything down and moved the openHAB server back. I’m getting the same problems as outlined in my log, even using @chris’s latest snapshot. Quite baffling. Any other thoughts?

Put a mains powered zwave device between the controller and that device, this should create a meshed network (not possible with battery operated devices) which will act as a repeater.

Or get an actual zwave repeater - better range than most other devices.

So even though this zwave device is mains powered, I need to get another one (or a repeater) to go between them? I fear that I’ll have the same problem as the distance and obstructions are quite minimal already.

Is it possible that the other Z-Wave network in my home (upstairs, based on Vera) is interfering?

As I remember the Aeon Labs Z-Stick can include devices without any PC. Just power via USB-bus from somewhere. Press the button of the stick and then the neded button of the device. Bring the USB stick back to OH PC and it should work.

@HomeAutomation This is exactly what I did, but then when I returned the stick back to the openHAB server, I continually get “NODE 26: Is currently marked as failed by the controller!” With a long enough cable I could probably find the point at which it happens, but it’s certainly well within the range of what should work for Z-Wave. Thus far, the only way I’ve gotten it to remain stable (and not receive those messages) is to have the openHAB server plugged into the same Z-wave device (which happens to be a controlled outlet on mains power).

Ok, “NODE 26: Is currently marked as failed by the controller!” this is normal because of a batterie powered device. Go to the device and manually wake it up more times. Look at the OH log and see if you get any communication via z-wave.

If the device is in range it should report something.

This is not a battery powered device though - it’s on mains. This is a “WO15Z Single Wall Outlet” according to the Z-Wave binding’s database. I’ll keep waking it up and see what logging reveals (I have the logs turned up to DEBUG right now in hopes of catching everything).

Hm, if it is main powered, then it should communicate with the controller all time.

Try to start a new including but do nothing just wait, sometimes this triggers the device to talk.

Zwave max range is about 30m inside a house, so depending on your obstacles you already could be on an edge …

I’ve put a Jasco 45604 wired plug inbetween my openHAB and the WO15Z wall outlet device in hopes of improving its stability. Hopefully this works. That should reduce the distance from 25m to 15m or less…