Z-wave: could not resolve to a thingType! (Aeotec ZW111)

I just got my Aeotec ZW111 (eu version), but habmin only sees it as an unknown device? Can it be added?

2017-06-24 15:09:16.908 [ZWaveDiscoveryService ] - NODE 76: Device discovery could not resolve to a thingType! 0086:0003:006F::1.2

I’m using 2.1.0-SNAPSHOT Build #964 / Z-wave:

node76.xml (10.2 KB)

That device type and id is already in the database.
If it is a battery powered device, wake it up several times.

If that does not help update your zwave binding, it is more than three months old.

1 Like

This is already in the database. I expect that you are using too old a version of the binding and it probably doesn’t include this device as it’s quite new.

1 Like

Ah yes of course, thanks!. I thought the zwave binding was updated aswell through the apt-get update (snapshot)…

Tried updating with bundle:update but that didn’t work, removed the binding and tried manually downloading a version but that failed when I installed it (Could not resolve module: org.openhab.binding.zwave) …

What’s the proper way to get the latest binding snapshot installed? :confused:

EDIT: Figured it out! had to uninstall the binding, remove any org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar files found on the filesystem. And then reinstall it in paperui to force a new download…

1 Like

Uninstall through PaperUI, wait a minute, install through PaperUI, check version in karaf