Z-wave device Error after update openhabian to Version 2.5.4_01

Tags: #<Tag:0x00007f4333d150b0> #<Tag:0x00007f4333d14fe8>
  1. There were a multitude of changes between 1.8.2 & OH2.
  2. There were major structural changes between 2.4 & 2,5.
  3. OH 2.5 is no longer is active development except for bindings.
  4. The install script linked in this thread may help install a snapshot binding.
  5. The next release with a binding update is likely 2.5.5
  6. Development has shifted to OH 3 but it is not yet usable.

You are free to stay ion 1.8.3, of course, but you are just delaying an inevitable upgrade when you get a device not supported bu those bindings.

Never. Please remember that released versions are exactly that - released. They can never change, so 2.5.4 will always be exactly the same and you will need to wait until 2.5.5.

1 Like

Staying back on 1.8.3 is not going to help much though. Any upgrade from that old will be painful.

Thank you, Chris. I will wait for 2.5.5. Any idea when it is likely?

Possibly 2 or 3 weeks. The releases are done approximately monthly.

1 Like

…which is why I was hoping to upgrade to 2.5.4 but I got immediately smacked down with the broken ZWave binding—as per the rest of this thread. For clarity: I did not even attempt an upgrade. All I did was a clean install, nothing migrated, put in my Aotec Gen5 stick, install ZWave, and this error. Seeing a variety of UIs all disagreeing with each other and Karaf about it did not help. As I said, I chose the wrong weekend.

Put the stick back into 1.8.3 and it runs beautifully again: 30+ zwave devices, 40 or so Hue, Sonos, Harmony, RFXCOM, Homekit/Siri and ca 1500 lines of rules. Never really breaks, but requires an occasional reboot. I suppose part of the problem with OH2 is that it is still being developed, so things will break and change. I much prefer stability, and that usually means older software. I suppose once OH 3 becomes the thing, OH 2 will be just fine. :slightly_smiling_face:

Development has stopped on openHAB2, except for bindings. They are working on openHAB3.

1 Like

I have this device error during startup of OH: Could not register ThingType: zwave:aeotec_zw141_03_000. Since this problem exists I wouldn’s say that the zwave network is instable, but it has strange stops. I have 100+ devices in the network. Here is a log aboud binding restarts when controller become offline:
zwave_faliure.log (37.6 KB)
I have tried to update binding to snapshot, but I had to turn on Zigbee what caused other issues, so I turned off. Then I tried to update with

bundle:update org.openhab.binding.zwave 'https://openhab.jfrog.io/openhab/libs-snapshot-local/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.5-SNAPSHOT/org.openhab.binding.zwave-2.5.5-20200427.172229-4.jar'

order with several versions but it would became worse. So I mereged back to my actual version: openHAB 2.5.5 Build #100. I had #104 before and behaviour was the same.

This issue will not impact the binding at all. It is solely an issue with one of the XML files being incorrectly formatted.

I see the following error in your log -:

2020-05-02 19:21:02.033 [WARN ] [ing.zwave.handler.ZWaveSerialHandler] - Got I/O exception Input/output error in writeArray during sending. exiting thread.

I think this comes from your OS - it means there was some sort of exception in the serial driver, but I don’t think it’s related directly to the binding, and it’s certainly not related to the XML error.

I use windows 10 pro and java:
java version “1.8.0_231”
Java™ SE Runtime Environment (build 1.8.0_231-b11)
Java HotSpot™ 64-Bit Server VM (build 25.231-b11, mixed mode)
Aeotec Z USB Stick on COM2 port

Ok - thanks. I’m not sure how that makes any difference though :confused: ?

Would it help if I reinstall Java? I have tried several version before and it was the most updated what was good for OH. If somebody can recommend a different one I can try.

I can confirm I saw the same error with the same configuration except “Java Hotspot”, on a fresh openhab for windows 10 a couple of weeks back. The error Input/output error in writeArray during sending. exiting thread. would appear randomly and OH or computer restart was the (temporary) remedy if I remember correctly.
The COM ports were troublesome too as a consequence.
The errors disappeared as I switched to rpi4/openhabian, so I didn’t worry too much then.

Can it source of the problem?

2020-05-02 20:22:30.308 [WARN ] [org.apache.karaf.shell.ssh.Activator] - Error starting activator
java.lang.IllegalStateException: Service not tracked for class interface org.osgi.service.cm.ConfigurationAdmin
	at org.apache.karaf.util.tracker.BaseActivator.getTrackedService(BaseActivator.java:369) ~[bundleFile:?]
	at org.apache.karaf.util.tracker.BaseActivator.ensureStartupConfiguration(BaseActivator.java:154) ~[bundleFile:?]
	at org.apache.karaf.shell.ssh.Activator.doStart(Activator.java:96) ~[bundleFile:?]
	at org.apache.karaf.util.tracker.BaseActivator.run(BaseActivator.java:312) [bundleFile:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_231]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_231]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_231]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_231]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_231]

After reboot these are first lines in openhab.log

No - that is related to Karaf and ssh - not serial ports.

Hi all,

I have downloade the latest SNAPSHOT, yesterday and the problem is still present:

2020-05-10 18:18:15.330 [ERROR] [ng.xml.internal.ThingTypeXmlProvider] - Could not register ThingType: zwave:aeotec_zw141_03_000
java.lang.IllegalArgumentException: ID segment ' switch_dimmer' contains invalid characters. Each segment of the ID must match the pattern [A-Za-z0-9_-]*.
    at org.eclipse.smarthome.core.common.AbstractUID.validateSegment(AbstractUID.java:97) ~[bundleFile:?]
    at org.eclipse.smarthome.core.common.AbstractUID.<init>(AbstractUID.java:75) ~[bundleFile:?]
    at org.eclipse.smarthome.core.common.AbstractUID.<init>(AbstractUID.java:49) ~[bundleFile:?]
    at org.eclipse.smarthome.core.thing.UID.<init>(UID.java:48) ~[bundleFile:?]
    at org.eclipse.smarthome.core.thing.type.ChannelTypeUID.<init>(ChannelTypeUID.java:40) ~[bundleFile:?]
    at org.eclipse.smarthome.core.thing.xml.internal.ChannelXmlResult.toChannelDefinition(ChannelXmlResult.java:135) ~[bundleFile:?]
    at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.toChannelDefinitions(ThingTypeXmlResult.java:98) ~[bundleFile:?]
    at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.getBuilder(ThingTypeXmlResult.java:148) ~[bundleFile:?]
    at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.toThingType(ThingTypeXmlResult.java:156) ~[bundleFile:?]
    at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlProvider.addingFinished(ThingTypeXmlProvider.java:148) [bundleFile:?]
    at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.addingFinished(XmlDocumentBundleTracker.java:265) [bundleFile:?]
    at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.parseDocuments(XmlDocumentBundleTracker.java:424) [bundleFile:?]
    at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.processBundle(XmlDocumentBundleTracker.java:398) [bundleFile:?]
    at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.access$6(XmlDocumentBundleTracker.java:393) [bundleFile:?]
    at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker$2.run(XmlDocumentBundleTracker.java:363) [bundleFile:?]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) [?:?]
    at java.util.concurrent.FutureTask.run(FutureTask.java:264) [?:?]
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) [?:?]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
    at java.lang.Thread.run(Thread.java:834) [?:?]

Bye

It is complaining about an added space before the name switch_dimmer. Looks like a database issue.

This issue is definitely fixed - my guess is that your system is still running the old version - please log on to the Karaf console and list the running bundles to see what is actually running.

Yes - this was fixed a few weeks ago.

1 Like

You are right, in karaf console I see versione 2.5.4 while in PaperUI (as previous posted) I have 2.5.5SNAPSHOT.

How can I installa the snapshot correctly ?

The install script usually helps.
Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community