Z-wave device Online when plugged out

Hi all,

The z-wave device I am using is the Aeotec smart plug model ZW096-C07. The device works fine with openHAB and i have all the items linked turing on/off switch and reading voltage etc.

However I am testing what happens if the device is plugged out or loses connection. I have plugged the device out completely removing the power source yet it still says the device is online. There is no Thing Status change in the log viewer, no status change in the paper UI and when I look at the thing status using the rest API I get " ‘status’: ‘ONLINE’, ‘statusDetail’: ‘NONE’ ". I waited 10 minutes and still no change.

I then tried restarting the raspberry pi and not having power supplied to the smart plug from boot. This was the log message that resulted

The node which is plugged out is zwave:aeon_zw096_00_000:controller:node3. This is worrying as I am checking the status of the node from an external python script and it will tell me everything is fine because openHAB believes everything is fine. I can even change the smart plugs state from on/off in the paper UI and the REST UI with the log viewer saying the state change was successful.

Has anyone else experienced this before?

One thing I have changed in my setup which may help some people is to increase the polling period of the z-wave devices. There is documentation on the polling period here but I could not find an actual example of it being implemented in the documentation.

The following has worked for me however you do have to set the polling period for each Thing configured with the z-wave binding it seems. The bridge I am using is a ZW090 Z‐Stick Gen5 USB Controller and the two smart plugs I am configuring are ZW096 Smart Switch 6.

The binding_pollperiod=10 sets a polling period of 10 seconds. The location of the following code is in my .things file, I am using a RaspberryPi 3 with openHAB 2.5.2

Bridge zwave:serial_zstick:controller "Z-Wave Controller" [port="/dev/ttyACM0", controller_softreset="false", controller_master="true", heal_enable="true", heal_time=3, security_networkkey="0E 21 AB E3 AE 76 44 C3 A1 5C ED 87 44 12 DD C0"  ] {
    //Node 2
    Thing zwave:aeon_zw096_00_000:controller:node2 "ZWave Node 2: aeon_plug"(zwave:serial_zstick:controller) [ node_id=2, binding_pollperiod=10 ]

    //Node 3
    Thing zwave:aeon_zw096_00_000:controller:node3 "ZWave Node 3: aeon_plug"(zwave:serial_zstick:controller) [ node_id=3, binding_pollperiod=10 ]

Why are you setting Things manually in text files? That can be error prone and the binding does an excellent job, in my opinion. It is also recommended by the developer to have OH create the Things/

Is that not what the .things files are for? I don’t really like the paperUI to be honest I’m bit more comfortable working with the text files instead and get to learn a bit more using them I think compared to the GUI modes. Configuring what bindings, items, things and channels just a bit quicker with the text files and have a bit more control I feel. Just my preference I guess is the answer, what approach would you recommend though instead of the text files?

I use the recommended HABmin when I have OH create Things. Some bindings need manual files but not zwave. HABmin is recommended fir admining zwave devices.

I’ll have a look into it, I haven’t used HABmin yet so be good to try something new, is it just that it reduces the need for manual text files?

I still use text files for other parts of the configuration. Although HABmin has a rules section I do not think it is functional.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.