Z-Wave device to OH database

Hi i have bought a cheap siren on Ali. But Openhab do not have it in the database.
I have found my way to https://github.com/openhab/org.openhab.ui.habmin/wiki/Z-Wave-Product-Database
But that is written by someone who thinks everyone knows what he knows.

I have a product sheet with all the commands and functions. Can anyone help me add it to the database?

it is a Shenzhen NEO Coolcam. Ali link

This is the Z-wave Siren Alarm Sensor, Compatible with z-wave 300 series and 500 series.
Our Sensors Compatible With following brand alarm horst:Fibaro/Smarthings/Vera/Zipato/Iris/Wink.can’t work alone.need work with their alarm host.Thanks.

Assuming you are using openHAB2, you may add your device to the database through this instructions:


You will need your node.xml file for that or you have to insert all data manually …

That got me way further along. Thanks.

In this device list the unit is suppose to be supported. But my device is not identified correctly. I believe it is because i am running a 6-7-8 months old offline version and the page say “Last updated by Super User on 2017-02-05 11:38:23 (3 months ago). Approved on 2017-02-05 11:38:27, and last exported on 2017-04-15 12:09:23.”

Is there anyway to easily update the system without resetting again?

It depends on how “old” your installation is.
There have been several breaking changes to the runtime which make it necessary to do an new install (but you don’t have to exclude your zwave devices from the controller!!!):


The most important one is:

But first I would check if your device is just uninitialized! Wake it up several times (triple click the code button) and see if it is working after that …

Edit: if you already have an installation with the new JsonDB, you could try to just update the zwave binding: uninstall it through PaperUI, wait a minute or two and reinstall it again …

Hmm. i don’t understand. I updated z-wave and i have tried to add it while awake 30 times now.
I have another z-wave device that have problems connecting to OH2 so i know what to do.

The funny thing is that it is finding the correct device. My other device with problems do not do that.
Z-Wave Node 13 (0258:0003:1088:2.80) That indicates a old database correct?

Actually from your statements I don’t know what exact problem you have. Could you just summarize what is not working?
Do you have node.xml files created for your devices?
What is the status of your devices in HABmin? For example:

means the device is still initializing and it needs to be waked up or wake up by its own depending on the wake up settings


means (no message at the bottom) that device should work fine and is fully initialized.

It is simply not finding the device correctly. Waking the device have been tried again and again.

Usually when I encounter errors like that I do:

delete the thing, add it again (don’t remove/exclude the device from the controller)

If that does not help update to the latest zwave snapshot binding and see what happens …

I would suggest to check what version of the binding you are using. Log on to the Karaf console and use the ‘list | grep ZWave’ command to get the version. If it’s 2.0.0 then this won’t work with the device you have and you should change to the snapshot version as @sihui suggested (maybe you already did that, but it would be good to check).

Updating the addons kar to 2.1.0 did the trick.

Thanks guys. Much love :slight_smile: