Z-Wave devices not working: No event found with name 'eventON'

After OpenHAB 2.5 was released, I decided to install my OpenHAB fresh from scratch. My configuration:

  • Computer: Intel NUC with Ubuntu Server 18.x LTS
  • Z-wave controller: aeotec ZWave stick gen5
  • Some PIR sensors and a ZWave Siren

After installing the Z-Wave binding, all my ZWave devices are correctly discovered and corresponding things are added to OpenHAB. The status of all devices are ‘online’ and it looks like everything is configured fine in PaperUI. The problem is that the linked Items are not correctly talking to the things (and vice versa). There are no error messages in the default tail log.

I enabled the DEBUG logging in the openhab console:

log:set debug org.openhab.binding.zwave

When I for example try to turn on the ZWave siren, the following error messages appear:

21:19:15.006 [INFO ] [smarthome.event.ItemCommandEvent     ] - Item 'Sirene' received command ON
21:19:15.009 [INFO ] [arthome.event.ItemStatePredictedEvent] - Sirene predicted to become ON
21:19:15.010 [INFO ] [smarthome.event.ItemStateChangedEvent] - Sirene changed from OFF to ON
21:19:15.011 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 3: Command received zwave:device:d8ae6d66:node3:alarm_general --> ON [OnOffType]
21:19:15.011 [DEBUG] [nternal.converter.ZWaveAlarmConverter] - NODE 3: No event found with name 'eventON'
21:19:15.012 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 3: No messages returned from converter

and nothing happens furthermore :frowning:

As you can see, the Z-Wave binding is communicating with my PIR motion sensor (Node 4), but there are no incomming events.

21:13:06.899 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 4: Application Command Request (ALIVE:STATIC_VALUES)
21:13:06.899 [DEBUG] [ing.zwave.internal.protocol.ZWaveNode] - NODE 4: Incoming command class COMMAND_CLASS_SENSOR_MULTILEVEL, endpoint 0
21:13:06.899 [DEBUG] [ing.zwave.internal.protocol.ZWaveNode] - NODE 4: SECURITY not supported
21:13:06.900 [DEBUG] [otocol.commandclass.ZWaveCommandClass] - NODE 4: Received COMMAND_CLASS_SENSOR_MULTILEVEL V7 SENSOR_MULTILEVEL_REPORT
21:13:06.900 [DEBUG] [ass.ZWaveMultiLevelSensorCommandClass] - NODE 4: Sensor Type = Temperature(1), Scale = 0
21:13:06.900 [DEBUG] [ass.ZWaveMultiLevelSensorCommandClass] - NODE 4: Sensor Value = 19
21:13:06.900 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Got an event from Z-Wave network: ZWaveMultiLevelSensorValueEvent
21:13:06.900 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Got a value event from Z-Wave network, endpoint=0, command class=COMMAND_CLASS_SENSOR_MULTILEVEL, value=19
21:13:06.900 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Updating channel state zwave:device:d8ae6d66:node4:sensor_temperature to 19 °C [QuantityType]
21:13:06.901 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 4: Commands processed 1.
21:13:06.901 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 4: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@4fa7296a.
21:13:06.901 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction completed - outstandingTransactions 0
21:13:06.901 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction completed - outstandingTransactions 0
21:13:06.901 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
21:13:06.901 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

All components worked fine in OpenHAB 2.4 and all ZWave devices are reset to factory defaults. I also re-installed the Z-Wave binding, but this didn’t solve my problem.

Is there anyone who can help me?

Have you deleted and rediscovered your Things? I’m not meaning exclude, just delete.

Yes, multiple times…
I also deleted them from my ZWave network.

alarm_general is maybe a tamper alarm, which you won’t be able to command. Depends on mystery device.

I understand what you mean but none of my ZWave devices are working. And in addition all devices worked fine in OH 2.4.

Please provide a debug log so we can see what is happening.

Of course, help would be great!

ZWave devices:

z-wave controller: aeotec gen5
Z-Wave Node 002: ZW117 Range Extender 6
Z-Wave Node 003: NAS-AB01Z Siren Alarm
Z-Wave Node 004: Coolcam PIR Sensor


Version: 2.5
OS: Ubuntu 18.04 LTS
Hardware: Intel NUC x86 

network_c414fe4e__node_1.xml (1.8 KB) network_c414fe4e__node_2.xml (10.7 KB) network_c414fe4e__node_3.xml (11.9 KB) openhab.log (182.2 KB)

Strangely the log doesn’t really show a lot. The binding is neither sending nor receiving anything after 10 or 20 seconds, but it’s unclear why. There are no exceptions or errors in the log :confused:

But when I change the linked to my zwave siren from ‘off’ to ‘on’, the following message appears:

==> /var/log/openhab2/events.log <==
2020-03-05 18:11:32.322 [ome.event.ItemCommandEvent] - Item 'Sirene' received command ON

==> /var/log/openhab2/openhab.log <==
2020-03-05 18:11:32.325 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Command received zwave:device:d8ae6d66:node3:alarm_general --> ON [OnOffType]
2020-03-05 18:11:32.326 [DEBUG] [ternal.converter.ZWaveAlarmConverter] - NODE 3: No event found with name 'eventON'
2020-03-05 18:11:32.326 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: No messages returned from converter

==> /var/log/openhab2/events.log <==
2020-03-05 18:11:32.329 [vent.ItemStateChangedEvent] - Sirene changed from OFF to ON

I have the same problem with an Aeotec Trisensor, openhab 2.5.3 and the z-wave binding on a RaspberryPi 3 with a RaZberry module.

Did you find a solution?

Yes, but the solution was a little bit… strange.

  1. exclude sensor

  2. factory reset the sensor

  3. open events.log so you can watch what is happening.

  4. include sensor

  5. click button next to battery like crazy and watch log for zwave communication with your node.

See also: Neo Coolcam Pir motion sensor

Now it works fine for about two month.

You could have replaced steps 1, 3, & 4 with deleting the device from OH and re-including. There is no need top exclude & re-include from the network. Device discovery is separate from network inclusion. In fact your process, at times can leave zombie nodes on the network, causing other issues.


You are right.