Z-Wave dimmers jumping back to ~50%

  • Platform information:
    • Hardware: i7 4790k, 16 GB RAM, plenty of storage
    • OS: Windows 10
    • Java Runtime Environment: Java 8 - 201
    • openHAB version: 2.4 Release

I have done my best troubleshooting this issue, but I am new to OpenHAB (not new to Z-Wave though, previous Vera Edge user).

What is happening is that if I use any of the UI’s to change a slider assigned to a dimmer from 100% to 0%, the physical dimmer does what it is supposed to do (IE: turn off). However, the UI will go to 0, then a second or so later, jump to 50% (sometimes it is 49%). I can sometimes get other values if I am not going from 100 to 0. It also does the same thing if I am going from 0 to 100%. I have GE, Zooz, and one other brand of dimmer. They all seem to do it (actually, I don’t think I have tried the Zooz yet).

Here is the interesting part. I created a Switch in my items file, and linked it to the dimmer. That did not change anything, however, when I deleted the switch from the items file, and then unlinked the item from the dimmer, then everything worked as expected. I thought I had solved it, but once I restart OpenHAB, the problem returns.

I have researched this online, and found a few people that had similar problems, but no real solutions.

Any help would bee hugely appreciated! I did manage to get Google Home working, and a few other things, so I believe I have conquered the basics of how this system works, but I can’t seem to get this fixed!

If I posted this in the wrong forum area, I apologize.

EDIT: I just discovered that I can add links from the console. Is there any way to automate this from a batch file or similar? That may solve my immediate issue. I would still like to know why it’s happening, but I will settle for ‘It works’!!

EDIT2: Yep…if I paste this into the console after starting, then everything works as expected:
smarthome:links addChannelLink Kitchen_Recessed_Lights_On_Off zwave:device:xxxxxxc:node7:switch_dimmer
smarthome:links removeChannelLink Kitchen_Recessed_Lights_On_Off zwave:device:xxxxxxxc:node7:switch_dimmer

smarthome:links addChannelLink Recessed_Lights_On_Off zwave:device:xxxxxxc:node6:switch_dimmer
smarthome:links removeChannelLink Recessed_Lights_On_Off zwave:device:xxxxxxxxc:node6:switch_dimmer

smarthome:links addChannelLink Entryway_Lights_On_Off zwave:device:xxxxxxc:node10:switch_dimmer
smarthome:links removeChannelLink Entryway_Lights_On_Off zwave:device:xxxxxxxc:node10:switch_dimmer

Thanks rossko57, I did read that in another thread, however, it doesn’t appear I can change that setting. It is set to 1500 no matter what I do. Either that, or I am looking at the wrong thing!

OK, finally found someone else who said that you should configure those settings in HABmin, so I did it there and it took. Seems to have fixed the issue too. Thanks!

I’m not z-wavey but I think the “use HABmin for zwave settings” is generally recommended.

1 Like