Z-wave ERROR:500 - Internal Server Error since OH2 upgrade to 2.5.8 from 2.5.7, and other issues

I upgraded (part of Ubuntu apt upgrade) from OH2 2.5.7 to 2.5.8, and all hell broke loose. To be more specific I have listed everything that has happened below:

  1. Updated through APT from 2.5.7 to 2.5.8
  2. Rebooted system.
  3. Z-Wave binding was no longer installed.
  4. Installed Z-wave binding.
  5. Z-Wave controller kept going offline & online in a loop, Error 500 in PaperUI only when trying to edit Z-Wave things. Editing all other things ok.
  6. Uninstalled Z-Wave.
  7. Stopped OH2.
  8. cleared cache.
  9. rebooted machine.
  10. Installed Z-Wave binding.
  11. Z-Wave more stable, but not totally.
  12. Now still get ERROR 500 when trying to edit Z-Wave things only.

Any suggestions?

I’ve been looking at the logs:

tail -f /var/log/openhab2/openhab.log -f /var/log/openhab2/events.log

but I don’t see the errors as suggested by another post where they get browser errors being reported.

P.S. I’m reasonably green.

The other issue I forgot to mention is when I readd, enable, reboot, whatever. Sometimes one or two of the zwave things show up as ‘OFFLINE - BRIDGE_OFFLINE’, while all the rest are ‘ONLINE’. Sometime a restart or unplug of the stick, or two, will fix it.

In the OH console, check to be sure you only have one zwave binding running with…

list -s | grep zwave

If you see more than one, you either have multiple jars copied to the $OPENHAB_HOME directory, or copied a jar there and also installed through Paper UI, addons.cfg, or the console.



This may sound stupid, and may well actually be stupid, but have you tried another reboot?

My own RPi4 openHABian install update worked well, but after the first reboot there were a whole load of odd behaviours and bad log messages. Given a major code rework is incoming, I didn’t spend much effort saving logs for analysis (and the errors were bad enough to wake me up at 04:00 as restarting my rules generated speech messages!).

A second reboot fixed all issues, and 2.5.8 has been working fine.

My vague recollection is openHAB sometimes has to download new code after an upgrade (seemingly not via apt), or services don’t start in a clean order leading to problems.

It may be also worth trying Zwave changes using HABmin rather than PaperUI as it had more features (although finding them under Tools -> Advanced Settings can be more challenging).

Hi Scott,

Nice catch. This is what I get:

openhab> list -s |grep zwave
203 x Active x  80 x      x org.openhab.binding.zwave
236 x Active x  80 x 2.5.8                   x org.openhab.binding.zwave

I’ve worked out how to remove it.

I uninstalled zwave through PaperUI.
Then did the following:

openhab> bundle:list

Then get the bundle number that is still installed, in my case 203, then:

openhab> bundle:uninstall 203

Then found a manual jar in the addons folder, which I thought was deleted, but must have been redetected when the update went through.

Thanks 5iver!


Hi FloatingBoater.

Not stupid at all. I had a previous issue, and after 3 reboots it worked. I also cleared the cache the first two times, but only after the three reboots did it work.

However, not the fix in this situation.

If you do not get a 500 error your problem is not starting a new thread.

true , thanks for the info