Z-wave Exception during HTTP PUT request

zwave
Tags: #<Tag:0x00007fe054292e08>

(mhspohr) #1
  • Platform information:
    • Hardware: Pi2
    • OS: OpenHABianPi 201706161358
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2? (where can I see this?)
  • Issue of the topic:
    I have successfully added two Aeon Labs Energy Readers and a Aeoh MicroSwitch G2 and they have been very reliable.
    I am trying to add another Energy Reader. It is “discovered” and show up but indicate "Offline - Communication Error"
    I can communicate with them if I reset the power meter:
    2018-03-05 09:04:15.375 [ItemCommandEvent ] - Item ‘Node5HeatPumpPower_ResetMeter’ received command ON

2018-03-05 09:04:15.395 [ItemStateChangedEvent ] - Node5HeatPumpPower_ResetMeter changed from OFF to ON

2018-03-05 09:04:18.301 [ItemCommandEvent ] - Item ‘Node5HeatPumpPower_ResetMeter’ received command OFF

2018-03-05 09:04:18.321 [ItemStateChangedEvent ] - Node5HeatPumpPower_ResetMeter changed from ON to OFF

However, they are not reporting any power readings.
Also, I went to change some of the properties and got this message:

2018-03-05 09:25:56.135 [ERROR] [ome.io.rest.core.thing.ThingResource] - Exception during HTTP PUT request for update config at ‘things/zwave:device:5ae66b1c:node5/config’ for thing ‘zwave:device:5ae66b1c:node5’: null

So… kind of working but not really working.

Other nodes have been working well for months:
2018-03-05 09:34:49.931 [ItemStateChangedEvent ] - ZWaveNode4DSB09HomeEnergyMeter_ElectricMeterKWh changed from 1964.76 to 1966.893

2018-03-05 09:34:49.994 [ItemStateChangedEvent ] - ZWaveNode4DSB09HomeEnergyMeter_ElectricMeterWatts changed from 4259.64 to 4269.98

2018-03-05 09:35:08.144 [ItemStateChangedEvent ] - ZWaveNode3DSB09HomeEnergyMeter_ElectricMeterKWh changed from 170.784 to 170.796

2018-03-05 09:35:08.205 [ItemStateChangedEvent ] - ZWaveNode3DSB09HomeEnergyMeter_ElectricMeterWatts changed from 23.54 to 22.55


(mhspohr) #2

I’ve been fiddling with this some more and it seems this is a problem with the new node being too far away from the Z-wave stick. I’ve switched the new and old nodes and the problem remains with the new further location. The new node works fine when it is close to the Z-wave stick.
I’m looking at getting the Aeotec Z-wave extender 6 which hopefully will cure the problem.


(Scott Rushworth) #3

The easiest place is on the dashboard, but maybe that was added in a version newer than yours.

You can also find it in the Karaf console.

image

But more importantly, which version of the zwave binding are you using, and how did you do the inclusion? If you’re not using the development version, then your mesh is not doing a nightly heal. And if you included the device close to the controller and then moved it, you will need to do a heal to get the routes straightened out. So it might not be just the distance. It also sounds like you are moving the devices around… mains powered devices should not be moved or it can make a mess of your mesh. It’s best to include them in their final location. If it really is a range issue, don’t waste your money on a repeater. Spend the same amount on a mains powered device that actually has some functionality. There’s a recent discussion here.

This is likely related to this, so an upgrade may resolve it.

PS, please use code fences!


(Rob Kamp) #4

Do use Habmin for managing zwave devices and not Paper UI.


(mhspohr) #5

Thanks for all of this information. Seems to be a bit complicated and I’m doing some things wrong.
Found the version I have installed at the SSH login:
2.1.0-1 (Release Build)
I can’t find a version for the Z-wave binding. Habmin just lists Chris Jackson and a description of the capabilities and says it supports a mesh network.

I am moving things around to get them set up and tested so I guess I am confusing the mesh. I like the idea of having it do a “nightly heal”. Do I need to install the development version? Can I just install the development version of the Z-wave binding or do I need to install the whole thing? Can I somehow force a heal?

My Habmin Z-wave network viewer show 5 devices. #1 is my controller and it has a solid green line to #2 which is a DSC26 Micro Switch G2 which I have been testing and moving around probably confusing things. The viewer also shows nodes 3, 4, and 5 as islands unconnected to anything (although node 3 and 4 seem to be working fine).

I guess if I can get the new Z-wave binding working, it should take care of the problems.

Thanks very much.


(Scott Rushworth) #6

Sorry, I meant to add this too. In the Karaf console, type bundle:list|grep -i zwave.

Yes, yes (correction… you will probably need to upgrade to at least 2.2 release), and not unless you’re using the dev binding or use another software, like Zensys Tools or openZwave (included in Domoticz). There’s a jar to download in the first post. But there is a lot of good info in there, so read through it a bit. Reportedly, it will be merged soon.

With so few devices, you may want to consider just excluding/reincluding them. But do it through OH and when the mains powered devices are in their final locations.

You are very welcome!


Exception during HTTP PUT request for update config at 'things/zwave:device:XXXXXXXXXXX:nodeXX/config'
(mhspohr) #7

Looks like Chris has been very busy with the new binding.
I’ll see if I can install it, although I’m a bit leary of installing the development version.
The option of excluding/reincluding might be a good interim solution.


(Scott Rushworth) #8

It has less issues and more features than the 2.1 and 2.2 release versions. The only reason not to install it is that it could be tricky to get going the first time if you are not familiar with adding custom bindings. If you remove your old binding though PaperUI, restart OH and confirm it is removed, and then drop the jar into your addons folder, everything should be happy. :sunny: