Z-wave fails to Initialize (SOLVED)

I’m just sharing this so that others might use this info to solve a similar issue.

I just switched out a JASCO / GE Z-Wave Fan Switch that had gone bad on me, Z-Wave database.

Jasco Products ZW4002 In-Wall Smart Fan Control All SPECIFIC_TYPE_POWER_SWITCH_MULTILEVEL
Jasco Products WZ4002 Jasco 3 Speed Fan Control All SPECIFIC_TYPE_FAN_SWITCH

The original was the 12730, and I was replacing it with the newer 14287. I don’t know if this was part of the problem, but here is what I experienced.

I Excluded my original switch and then physically removed it all together. I made sure that my OH2 Thing (node 18) was deleted as well. Then I installed and Included the new switch, it was found and added to OH2 at node 26. It was reported ONLINE, but no Initialization was taking place. I tried to remove it from the system and re-add it. I used Heal in HABmin. I switched the device off and on several times to make sure it wasn’t asleep. Each of these things got me no further into an initialization process. I checked for a new node26.xml file, but none existed. I rm’d the old node18.xml file. I tried restarts. I tried reboots. Nothing would get the switch to initialize.

In the end I had to clear tmp and cache, to get the switch to initialize. Once I did, it was include in seconds and I was on my way again.

So I make this post to point out that there may be items in cache/tmp that are not getting cleaned up, or will block new similar items from initializing correctly when added.

I hope this helps someone in the future.



Can you explain how you cleared tmp and cache? Can you share the command?

HI Chad, I was just reading your post. I’m going to grab my logs and review what is in them when I was having this issue.

Clearing cache and tmp is simply deleting the contents of those directories. On my RPi installed to /etc/openhab2 and /var/lib/openhab2, they are in /var/lib/openhab2.

rm -r /var/lib/openhab2/tmp/*
rm -r /var/lib/openhab2/cache/*

I’ll keep an eye on your efforts and help if I can.


One of the errors that I saw repeatedly while I was having difficulties was…

2017-08-25 00:11:59.611 [ERROR] [ome.io.rest.core.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:device:f5a78b33:node26/config' for thing 'zwave:device:f5a78b33:node26': java.math.BigDecimal cannot be cast to java.lang.Integer