Z Wave Fibaro FGSD-002 Unkown Device [solved]

Hi Community,

i try to integrate since 12 hour (testing hours :frowning:) to get my Raspberry3+Razberry2 in comination with the FGSD-002 V3.3 Smoke sensor up and running.

I have read also the block post with the topic unknown device, it don’t intialize when i push the b button 3 times (to wake it up)

ATM i find my zwave node twice? is that normal?

Thanx for your input

Z-Wave Node 33
Unknown Device

Z-Wave Node 29
Unknown Device

2018-03-31 09:58:37.909 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 33: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0
2018-03-31 09:58:37.934 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 34: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0
2018-03-31 09:58:37.951 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 29: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0
2018-03-31 09:58:37.959 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:162781cb352:node29’ to inbox.
2018-03-31 09:59:07.075 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 33: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0
2018-03-31 09:59:07.083 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:162781cb352:node33’ to inbox.
2018-03-31 09:59:07.097 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 34: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0
2018-03-31 09:59:07.109 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:162781cb352:node34’ to inbox.
2018-03-31 09:59:07.128 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 29: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0

Could it be that my sensor is cached in the Razberry und because of this it’s shown twice?

How could i reset the Razberry2? (Reset Button don’t work)

LG Patrick

Basically, yes. The controller remembers all the devices that it has included into the network - if you include the same device twice without excluding it from the controller, then the controller has no way to know if you added two different devices, or the same device twice.

In HABmin, in the controller configuration, there is an option to hard reset the controller.

Hi Chris,

Thanks for your fast response - so i understand that i see one point twice.
I have installed
habmin version 2.0
Z-Wave Binding 2.2

When i go to Configuration - Thinks - Zwave controller (is online)
and i want to open tools (there isn’t any options)
When i look at this manual the tool window at excluding is missing?

Also when i look at the controller at Proberties the field for manufacture and type is empty?

Do i have a problem at the controller side?

It might be in the advanced menu (ie you might have to select advanced mode). Or do you mean there really are NO options at all in this menu?

This is normal - the controller is treated different to other devices.

I have update my system to 2.3 unstable and now i have the tool set opions

Now i check it again :slight_smile:

Now all thinks are running as the should.

I have battery powered FDSG-002 Fibaro Smoke Detector and they are detected as unkown and i think i will wait for a day and look if the are known tomorow :slight_smile:

Thanks chris for your patience.

LG Patrick

So it unkown till now

I have woked it up about 20 times with a triple klick and its beside 30 cm the controller.

Could it be thats the smoke detector is not in the database with this version??

FGSD-002 ZW5 V.3.3

I will create a log in the afternoon.

bg Patrick

Possibly - what do the properties show? Is there a type and id number shown?

here is a screenshot of habmin

This is my smoke detector - thank you for your patience

Ok, so from here I think we probably need to see a log. This shows that the device is alive and waking up, but it’s not completed initialisation and we need to find out why.

I suggest the following -:

  • enable debug logging (log:set debug org.openhab.binding.zwave) in the karaf console
  • stop openhab (or at least the binding)
  • delete or rename the openhab log file
  • restart the binding
  • wait a minute or so, then wake up the device a few times - let’s say 10 times, pressing the button every 10 second.

If the above doesn’t result in the Type / ID above showing some numbers, then send me the log and I’ll take a look.

2018-04-01 13:39:06.276 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port ‘/dev/ttyAMA0’
2018-04-01 13:39:06.307 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2018-04-01 13:39:06.311 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - Update networkKey
2018-04-01 13:39:06.325 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2018-04-01 13:39:06.329 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2018-04-01 13:39:09.741 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
2018-04-01 13:39:09.745 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 2: Node found
2018-04-01 13:39:09.749 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2018-04-01 13:39:09.752 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2018-04-01 13:39:09.755 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2018-04-01 13:39:09.758 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 2
2018-04-01 13:39:09.761 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------
2018-04-01 13:39:10.307 [WARN ] [rialmessage.IsFailedNodeMessageClass] - NODE 2: Is currently marked as failed by the controller!
2018-04-01 13:41:28.837 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: setupNetworkKey useSchemeZero=false

Sorry - but I’m not sure why you’ve posted this?

Please follow the steps I outlined above.

Hi Chris,

Haven’t understand the karaf konsol before and now i am a little bit more clever :smiley:

Download Link for Log

My device is unknown like before.

Thank you for your help


The problem is that the device doesn’t appear to be responding to the ping requests that the binding sends to see if it’s alive during the initialisation sequence -:

I’m not sure why it doesn’t respond - it’s a standard requirement for devices to respond to these pings.

I would suggest to exclude it, and re-include it. This will perform a reset on the device which might help if it’s in some strange mode. If that doesn’t help, then we’ll have to look at other options, which probably means you changing to the development binding…

I have started after including also the log


My Habi don’t want to know my Zwave device :slight_smile:

I’m not sure what you mean by this? The device still has the same node number, so it’s not been excluded and re-included.

However, in this log, it has got past the initial request, and it’s now requesting other information from the device - all requests time-out though and there are no responses at all from the device.

Please try again to exclude the device. There is an option in the controller options to set the controller into exclude mode. When you then include it again, it should have a new node id. If the inclusion works, then I’m not sure why the binding wouldn’t get responses to the messages the controller is sending as well.

I have done this (also Hardreset @ controller and so he has taken Node 2 again).

Have also excluded the device now and have Node 3 -> the log look like the same.

Hmmm, well I think I’m out of ideas :frowning: . I would have said it was a hardware problem - either the controller isn’t transmitting well, or the sensor isn’t receiving well, but given that inclusion works, this probably isn’t the case. However, the controller is receiving the wakeup messages, so it is transmitting ok, but there are no acks or responses to any messages the binding is sending - just the timeouts from the controller which mean the controller sent the message, but the device did not respond.

How close together are the two devices?

the devices are 30cm to each other. I’organize a other component to test