Z-wave: Leviton Dimmer DZPD3-2 - Unknown device

HeIlo, I am hoping someone can help me out with this. I am running the latest openhabian, and I dont think this device got added to the database. It shows up just fine in the Things list, but it shows up as a unknown device with no channels. In habmin I found a binding for DZPD3, but I verified that this has a different typeid. I was able to find DZPD3-2 in the database at http://www.cd-jackson.com, and it matched up with the one that I have. I also tried adding the latest snapshot addons, and that was also unsuccessful. Before I migrated to openhab2 it worked perfectly in openhab1. I use this dimmer in the baby room and I really hope I can get this working again. Please let me know if I need to include any more information.

I would first try to solve that problem. Verify on the karaf console what zwave binding is active:

ssh openhab@localhost -p 8101
password is habopen (not really sure if that is also the correct password for an openHABian installation!)

bundle:list |grep ZWave should give you the binding version and if it is active:
204 | Active | 80 | | ZWave Binding

If the DZPD3 is a battery powered device, wake it up several times (there should be a button to do this), sometimes it needs several wake ups for a device to get recognized.

I believe I got it working now. The DZPD3-2 is the AC powered model and it does not seem to be in the database in the stable version. I downloaded the latest snapshot add-ons but they were not showing up in the paper ui. There is a setting under the system menu where you can uncheck where it says “access remote repository”. Once I did that all the snapshot addons appeared along side all the other addons. I then uninstalled the zwave 2.0 binding and installed the snapshot 2.1 binding. The device was recognized right away and everything started working. Thank You.

1 Like