Z-Wave Lock is only working one-way

I have an issue where my lock is only sending updates to the controller, but not responding to any commands. I’m not sure what I can do to fix it. I’m afraid to remove it and re-add it, given the recent issues I’ve had doing so with a lightbulb.
I’m starting to think my z-stick might be dying.
Looking at the network map, all the links to my lock are unidirectional from the lock. It seems like nothing wants to make a bidirectional link.

What devices are its neighbour? Are they reasonably new devices (do they support FLiRS is the background behind this question). If not, they may not be able to signal to the lock to wake it up.

The other thing I’d check is that your system is really sending commands - check the debug logs to make sure this is really working.

It was 3 mains powered devices, now it’s 2. This all started when a lightbulb wouldn’t respond, so I reset it and re-added it. But it kept adding as a generic device and wouldn’t be able to communicate with it.

I wasn’t really getting at how many devices - more what are the devices? Do they support FLiRS?

Not sure what that means. Is that something that I can check for each of its neighbors?
If I manually lock and unlock it, it comes online. But as soon as I send a command, it goes offline as not responding. My other devices appear to be working fine.
This is what the network map looks like:

Locks sleep most of the time - they wake up once a second and check to see if there’s any messages. This uses a special signaling system that needs to be supported by the neighbours.

Normally this will be in the docs - this is why I keep asking what the devices are.

So you have other locks that are working ok? Then it’s more likely to be an issue with the system not sending the commands. As mentioned above, I would strongly suggest to check the debug logging to make sure that commands are being sent.

No, I don’t have any other locks.

The neighbors are:
3 - Aeotec ZW096 Smart Switch
6 - Leviton VRMX1
7 - Aeotec DSC27 Micro Dimmer G2
9 - Leviton VRPD3 dimmer
14 - Zooz ZEN07 Mini switch
16 - Linear LB60Z-1 Dimmable Bulb
17 - Jasco 45604 Ourdoor Plug
28 - This node is removed but it still shows as a neighbor
29 - Leviton VRPD3 dimmer

This is from the debug log:

I should note that this lock has been working flawlessly for years. The only change is that a lightbulb stopped responding, so I tried to reset it and re-add the bulb several times.

So this indicates that the device is not responding to the commands. When you say it sends updates to the controller - what updates exactly. Can you also provide the log for this.

From the info you listed the controller is probably trying to use 28 as a repeater to send commands to the lock and this might have always been the only route to the lock. It is still in the controllers tables or it would show as not on controller in openHAB… You need to remove 28 from the controller. Try using the removed failed node menu item to get rid of it.

Then it might work again if there is a working route to the lock. From the symptoms and the difficulty re-adding it may not start working immediately but from the behaviour you probably have a route as the lock is managing to send reports to the controller.

If I manually lock/unlock the door, the node comes online and those events are received.

@robmac Node 28 has been removed from the controller. It doesn’t show up anywhere except on the lock’s list of neighbors.

Have you repaired the network because it should not show anywhere if it is removed from the controller?

Thanks. What I wanted to check here is that it was secure transfers that were coming through and that is the case. So I would agree with Rob - probably your network is screwed up and the routes need repairing.

I’ve tried repairing and healing. But since commands don’t get to the lock, I guess it won’t get the heal command? Any suggestions?

A zniffer would show what is going wrong but if you don’t want to make one you can try a bit of cross your fingers messing.

First and simplest is try temporarily move your controller close to the lock and healing the lock and light that caused the original issues only.

Do not do the full network with your controller out of position.

If you are lucky the controller will record a route via the light and direct. Move the controller back and heal the full network and hopefully the lock will still be able to communicate via the light.

I would not suggest this for a larger network as it could break a lot more than it fixes.

I’ve already completely removed the non-functioning light from my network, and powered it off.

You may need a beaming capable routing slave in the light’s position or a similar position for the lock to work.

Chris asked about what nodes you had and it sounds like the light was the only suitable one.

Node 16 is the exact same bulb.

In the exact same position?