Z-Wave: MCO Home MH-S411 switch not recognised


I’ve recently installed a MCO Home MH-S411 and MH-S412 switch. The MH-S412 switch was correctly recognised in openHAB (v2.5.10), but the MH-S411 was not. It is displayed with the following ID: ‘015F:4111:5102:5.10’.

The MH-S411 device apparently already exists in the Z-Wave database, but it has a different device type and device ID (4102:0201). However, I have also found another device in the database TPS411 that does have a device type and device ID that corresponds with my device, but it has a firmware limitation <5.5 (which is probably the reason why my device is still not recognised).

I’m quite new at this, so I wonder if anyone could help in correctly adding my device to the database?

Here is the xml file for my device: network_d456e2a4__node_3.xml (17.4 KB)

The manual for the device can be found on this page of the MCO Home website (it is the same manual for all the MH-S4xx switches).

Let me know if there is any additional information I need to provide.


I have removed the firmware restriction. The binding snapshot after the next database export will have the changes.

Thanks a lot for your help. I was initially going to wait for the 2.5.11 version to see if the problem is indeed fixed, but I just switched to OH3 milestone 5. Is it normal that the device still isn’t recognised correctly in that version? I tried deleting the thing and rediscovering it, but it still doesn’t recognise the device type.

Yes, because the database is manually exported for both versions at the same time. This complexity is partially why this is still a manual process.