Z wave. No neighbors to Node 1, the controller


I am using OpenHAB 1.7, Habmin 1.7, Aeon Z-Stick 2E.

When I first started testing z-wave, I added one WallPlug that became Node 2.
Then I added some more devices (at the time I was using openremote).

Now I have switched to OpenHAB, and discovered using Habmin, that the only neighbor Node 1 (Z-stick) had was Node 2. And then all other nodes including Node 2, talked to each other in a big mesh network.

My problem is, that I didn’t want Node 2, acting like a gateway, so I tried Network Heal, but no difference. Also, becouse Node 2 is a Wallplug, maybe it will be moved or be unplugged.

I didn’t know what to do, so I excluded Node 2, and now, my problem is even bigger. I can send commands, and the lights come on, but nothing reports back to the controller. Also OpenHAB and HABmin reports ALL devices as dead (except Node 1).

I would like the network look like this: https://github.com/cdjackson/HABmin/wiki/Z-Wave-Configuration#network-diagram

Any ideas?

I had a similar situation that also resulted in node1 to have no neighbors :frowning:

And I have the “feeling” that it resulted in a network that doesn’t work as well as it did before.
I can’t really pinpoint it, but assoiciations with the controller don’t seem to work reliable anymore, but only for some nodes.

A possible fix is to hard reset the stick and to start adding all nodes again, but since half of them are hard to reach and I’m not sure if it works, I haven’t tried that yet.

I have exactly the same problem. Thought it was due to bad reception as the controller was in the cellar and all devices where one floor above. I moved the main controller to the living room now but the issue remains. I am mentally preparing for a hard reset to solve this, which really is some tedious work.

I am using the Vision Z-Wave USB Stick ZU 1401 EU stick.

Ok, good to know I am not alone on this. Well I solved it by doing a hard reset… I hope this can help someone =)

Yesterday I tried to exclude and include all of my devices, to see if anyone would connect directly to the controller, but none of them did.

How do I do a hard reset? First I tried firmware upgrade, as someone says the stick will be reset by that, but that doesn’t do it.

The manual says “Factory reset on the Z-Stick: This must be done through the host software which takes control of the Z-Stick USB adapter while the Z-Stick is in SerialAPI-Mode.”
I googled and found this: https://groups.google.com/forum/#!topic/openhab/2CO61_kj5xE
And downloaded this great little program: http://www.moonlitzwave.com/zensys-tools.zip

I don’t understand why I haven’t seen zensys-tools earlier, it would have saved me a lot of trouble. Anyway, I did a hard reset and included each device with the controller, and now 6 of 8 devices connects directly to the controller. 2 devices are a bit futher away, so that is understandable.

Also, some of the nodes didn’t wan’t to be included, on them I needed to do a exclude first.

Edit: wrong link

I still did not have the time to do the controller reset. But I felt lucky and just checked habmin again and voila - My main controller has neighbors again! So it does seem to fix itself after improving the controller location, it just takes some time. With time being several weeks.
Notably, i disabled SUC mode the last time I checked, so the controller is not meant to be static anymore. Perhaps this helped, too.

Facing the same here as well.
As it also gains to node that are really short by, I have the strong feeling it its not a matter of connectivity between the devices.
In my setup the single connecting node is actually one of the most far away one.

Would be good to better understand what caused this condition. The good news that for me, I left it for a year this way, no true negative things.

At some point I will do the hard reset, re-inclusion cycle, but I’m bit afraid of the confusion stuff in oh again (as the node id’s change) and most devices reset themselves to default, so would need to somehow make dumps of all settings and manually restore them.