Z-Wave: No xml for The OCTAN Remote (NodOn)

The device was created in the database a year ago, so I guess with your snapshot version you are good to go.
Also the post above from successful inclusion is from Feb 17. Not sure what is going on at your system :joy:

Hm? What do you mean ‘from Feb 17’? Which one?
And yeah, I’m not sure either :wink:
Well at least it’s only the remote that doesn’t work, everything else works more or less like a charm.

Ah yeah, now I understand :smiley:

1 Like

Was this ever resolved? I am testing openhabian and remote is not recognized…



Waking up the remote during the startup of the z-wave binding helped. I could reproduce this and also include another Octan remote. Just had to wake it up during startup…

1 Like


How did you wake it up, and how can you time it to the startup of the binding? I have no screen on the RPI, so i cannot monitor the boot process.

You don’t need to worry about the binding startup - just the waking up of the device. The binding is always listening for the wakeup messages, so this is not something to worry about.

Ok, because i am struggling :stuck_out_tongue:

I have been randomly pressing the button, as the manual states “wakeup” is done by pressing a button.

Are there any logs i could check, to see what fails?

Well, yeah, the binding is listening, but a wakeup didn’t realy help.
After the inclusion a wakeup of the remote leads to nothing (at least not with my system).
I removed the thing, started up the binding and tried to wake up the device during start up. That worked for me (only that worked…) for both remotes.

The manual that is on the database site doesn’t seem to say much about wakeup - do you have another manual?

There’s the debug log - at least it will tell you if there are wakeup messages being received.

Do a ctrl-f for “wake” and you will find it on the bottom right-ish side, in very small print.

I will try to get some debug info, just need to find out how to run debug-mode.

When you say started the binding, do you mean scanning for new devices? Also, you are on openhab2?



You don’t need to scan for new devices either. You just need to wake up the device.

If you haven’t checked the debug log, then I would suggest to do so - otherwise you can continue to guess what is happening :wink: . Check the debug log to see if the device is sending the wakeup messages.

No, I’m talking about starting the binding over the karaf console.

After you connect with SSH to your system, enter:

ssh -p 8101 openhab@localhost

The password is: habopen


and find the z-wave binding.

bundle:restart <number of binding>

and it will restart.

In this console, you also can set the debug level for the z-wave binding:

log:set debug org.openhab.binding.zwave

don’t forget to set it back to info, after you’re done debugging:

log:set info org.openhab.binding.zwave

I would not recommend restarting the binding - it will generate a lot of network traffic and is totally unnecessary.

Tried this, did not help as far as i can see. Also, debug creates a wall of text, impossible to follow, or look at afterwards, unless one knows what to look for.

It is node 6, is it some keywords i could look for to get going, inside the logfile?


Please run the Karaf console as described here.

First let’s find out which version of the binding is running. Please report what version you’re on.

list -s | grep zwave

Now let’s put the zwave binding in debug mode.

log:set DEBUG org.openhab.binding.zwave

Now, let’s look at the log while you wake up the device.

Assuming you’re on a Linux variant… At the shell prompt in the logs directory type the following

tail -f openhab.log  | grep "NODE 6:"

Now wake up the device and report back what you see.


I first did an exclusion of the device, and then i did a hard reset of the zstick (aotec).

Did a new inclusion, and i put the remote very close to the stick. For the first time the remote gave an ack by blinking green. I can now press a button and there is some reaction. Looks like the system is queueing up some requests, and as far as i can interpret it is talking to the device.

I just kept pressing the button when the log indicated device was sleeping. Then, after a while, there was possible to set an wakeup time/interval in habmin. It was “0”, i set 10 seconds, hoping this would mean it would stay awake long enough to exchange some information.

Kept pressing a button from time to time, and suddenly something “came loose” and the system looked like it was creating the device, i think it had enough info to detect it, and create it.

The main thing i did was reset the zstick, so it forgot what it had seen of the remote, and also forgot the fibaro dimmer2. Then i did a new scan, initiating the inclusion mode on the remote a couple of times, close to the stick, until it acked with a green blink.

I dont know what and if something was wrong, log was too fast for me to recognize something obvius.

This probably was not necessary.

This is a very short wakeup interval. It likely will drain your battery rapidly. :frowning: Generally, a “good” wakeup interval is 3600 to 14400 seconds, depending on how much you want to conserve battery life.

if you post your openhab.log, we can take a look at what actually happened. The log likely is too big to post on the forum, so you would need to post to a sharing service like Dropbox, Google Drive, etc.

Edit: If you’d rather not post the log, you can use @chris log viewer to better see what was happening.