Z-wave not discovering things

I recently purchased a usb stick Aeotec Z-Stick Gen5 Z-Wave Hub Z-Wave Plus USB to use it with my Schlage locks
Plugged in the USB stick, checked on linux the tty port which is present
Adding the /dev/tty/ACM0 in serial port field, selected Wide network inclusion, the security key is also present there and binding seems to be online, im getting no errors in logs

When i try to discover my locks , openhab shows nothing, I even have some other z-wave devices like sensors that are not showing at all in the inbox.

I have tried every possible way and yet no success. can you guys tell me what am I missing here? thank you
I am running OH 2.5 @ Ubuntu 20.4 LTS with the Z-wave binding from OH addons

The lock needs to be put into include mode. To include securely, the lock needs to be factory reset first though.

Hello Bruce and thanks for your reply. well, i have tried all the combinations possible but reseting the locks to factory settings were not one of them … I will try resetting a lock and see if i get any lucky. thanks a lot. will let you know if it’s working or not

Secure Z-Wave Items always need to be factory reset before secure inclusion. I have found that sometimes it helps other devices to reset before placing into include mode.

Secure inclusion is fussy on timing and sometimes people have had to move the lock closer to the controller for the initial inclustion.

Exclude the lock and then reset it. There are LOTS of posts about getting Schlage lock setup in OH. Which model do you have? Depending on the model, the lock and controller will need to be touching. But it may take a few tries, excluding and resetting between attempts. Also depending on the model, you may need to setup some rules to actually get the state of the locks.

Hello @5iver
I did reset my lock and unfortunately Openhab was still not able to detect it.
I have 2 august locks and 3 Schlage ones
I am trying to set the Schlage first , the model number is BE468ZP , I saw it’s listed in supported devices but no matter what I do , it does not discover nothing in the inbox. I saw other posts from various users stating that some devices are showing in inbox as node or a non-responsive device or anything else but it’s still showing, from my end the log looks fine, the stick seems to have the serial port working but can’t discover things. I will try uninstalling this binding as i got it directly from addons page and try instead of using a local .jar file , hopefully that will work. if you have any suggestions, please let me know, thank you

If it’s not in the inbox at all, then probably the controller is not detecting it.

I thought these devices were only available in the USA (although I might be wrong?) - are you also in the USA, and you have the right controller for this device?

Hey @chris I am from Romania but I am helping a friend remotely to automate his home.
You’re right about controller not detecting things, after replying, I started searching for solutions on other posts.

Instead of working with PaperUI, i tried to configure under Habmin
When I created the Z-wave serial controller thing, i get random statuses as Online or Offline - Serial error: Port/dev/ttyACM0 does not exist. these statuses changes every few minutes.

Now, I tried adding openhab to tty and dialout but openhab is already a part of these groups.

I also tried checking to see if the port and everything are correct
lsusb detects the dongle: Bus 003 Device 002: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB

After checking the serial port command $ ls -l /dev/ttyACM0
crw-rw---- 1 root dialout 166, 0 Dec 4 05:25 /dev/ttyACM0

I noticed that root is the part of dialout which is strange as here’s the command output for adding user to that group

The user openhab' is already a member of dialout’. - same happens for tty

I also checked the OMPS entry in /etc/default/openhab2 to make sure it includes the string from OH documentation section.

This is really strange

It shouldn’t really matter if you use HABmin or PaperUI - the binding reads the devices from the controller, and the controller does the inclusion. If the controller isn’t including the device, then one possibility is that there’s an issue with the region.

Are you sure that the BE468ZP is usable in Europe? Or is your friend in the USA? I’m just trying to ensure that the controller and the device are compatible since this is one of the main reasons that the device would not be included.

On the other hand, if the USB stick is not connecting at all, then you need to resolve this first :wink:

Chris, thanks for replying back to me . it seems i made it work

This friend of mine lives in Florida, US, he just woke up , i told him to follow schlage instructions to put that device into enrollment mode - inclusion - and somehow that lock showed in my inbox.

I guess updating the /etc/default/openhab2 config with
EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0" did the trick
I also went to console and triggered feature:install openhab-transport-serial

Now the lock is working perfectly.

Thank you very much for your help and hopefully if someone will have the same issue, i hope they’ll get it fixed by following some of the steps i did to make it work

1 Like

If your friend is interested in other Z-Wave devices, Zooz has been very helpful to the openHAB binding and has top notch support.

Their online store is at thesmartesthouse.com