Z-Wave Not Finding My Devices

My home has a security system including a Z-Wave door lock and thermostat.
I have had OpenHAB running for weeks on my RPi doing other things. I just got my Aeotec stick today. I followed the video:

I can follow the video up to the 4:50 point but then, when I go to inbox and “Search”, it finds nothing. I tried Add Manually and all I get is the Z-Wave stick setup page again.
I used to be able to go to the control panel of the security system and it reported the two Z-Wave devices. It no longer does that. They just are not there.
So what did I get myself into and how do I get out of it?

Why use some random video instead of the official documentation and then ask for help?
Do the video producers have more knowledge than those writing the official documentation??

Well, part of it has to do with what is the official documentation? I did a lot of searching OpenHAB documentation and got a lot of different results that I couldn’t date or determine what is the latest.
There must be 10 different methods.
This video showed very simple steps and it worked for him.

Do you have any idea why the docs would be better or which version I should use for a RPI 3-B running openhabian?

Start with official docs from the main website.



and from the developer himself

Thanks for the info. I have been through the Intro and openHAB thoroughly. For example, . I have openHABian running with mqtt and other things.

As for the Z-Wave doc, I get right to the step that says, “Once the binding is authorized, and an adapter is added, it automatically reads all devices that are included into the network.” But nothing happens. No automatic reads.
I am certain the video took me exactly to this step.
I guess you could say I’m asking, “What do I do now?”

Oh, while I was waiting for the stick I came across CD-Jackson’s method but I don’t have HABmin installed and I wasn’t about to introduce another unknown.

He is the developer and recommends HABmin. He actually wrote both and I see some Z-Wave information in HABmin that is not in the PaperUI.

if you haven’t been using OpenHAB for long, you may not realize installing Habmin, which is just another user interface, is no big deal and it works great for zwave stuff. It requires no set up or fiddling to start using it. Try it!
Now, I’m not 100% clear on how far along you are getting. Is your zwave stick showing as online?

1 Like

HABmin is just the admin interface that predates the Paper UI
It has more Z-Wave specific features though.

Well after a lot of trashing around I somehow have my Z-Wave thermostat channels showing. But don’t ask me how I did it and I hope I never have to go through it again.

I have been using OpenHAB for a few months and my biggest frustration is that everybody has their own way of doing things. I have so many steps that I have done so many different ways (items created with PaperUI, others typed into home.items directly, others I am not sure where they came from) I don’t know how I will ever achieve any uniformity. That is why I resist using HABmin. It seems just another way to do what should be possible with things I am familiar with.

Right now I think I am nearly out of the woods on this Z-Wave thermostat. Then I have to beat on a door lock.
Thanks Bruce, Andrew.

It can be quite confusing fir historical reasons. My current method is to automatically creste Things in PaperUI or HABmin - both put data directly into the JsonDb - and use files for the remainder. V1 bindings and perhaps a few others require a manual Thing file.

I’ll say confusion. For the longest time I ran with just 1 sitemap and one items file. It had 14 items I just typed into the home.items file. No bindings, no things.
Then, using PaperUI, I installed the mqtt binding and used it for weeks.
Then, again using PaperUI, I installed the GPIO binding and 2 items, and a rule to go with them.

Yesterday, using PaperUI, I installed the Z-Wave Binding and noticed that the mqtt binding was not listed. But everything that uses mqtt works fine. If I go to addons it will allow me to uninstall the mqtt binding…WTF?

But now PaperUI shows two things having to do with Z-Wave. But of course the home.things is MT. I have seen stuff like that before. For the longest time PaperUI showed only the 2 GPIO items not the 14 others I typed into home.items. But at some point it started to display them.

No need to explain this. I have seen others in this forum reporting similar examples.

Thanks Again.