Z-Wave / OH 2.4: Roller Shutter PAN08-1a not invertible

After upgrading to OH2.4 and re-adding all the things according to the instructions I also had to reconfigure inversion settings for some roller shutters. This worked for all other roller shutters except for the PAN08-1a type, which does not provide a blinds_control channel but a switch_dimmer instead. For this channel, no inversion settings are available, so this shutter opens fully at 100% and closes at 0%. Is there any other way to invert percentages and control as for blinds_control channels?

Strangely, I had a working blinds_control channel for one of my two PAN08-1a in my .items file before the update. The other one (which is mounted in the “right” orientation and does not need to be inverted) already was a switch_dimmer. Maybe they have been initialized with different XML definition files.



The invert option is only available for rollershutter type items.
But your device should show up as one and not as a dimmer.
Check with the database to see if it’s correct in there and eventually correct it.
If that’s right you should try to delete the device’s .xml file and re-initialise it (= make OH/the ZWave controller regenerate the file).

Thanks. It was indeed wrong in the database (https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/609). I added a comment because I have no edit rights.

Anyways, I “fixed” it the hard way by swapping the cables on the switch :wink:

As @mstormi correctly pointed out, the database entry was faulty. I’ve corrected the entry now and asked for review.
I assume, this will bring back the option to stop the rollershutter inbetween its endpoints via the ZWave binding as well. In OH1 that worked ok, but the option was lost with the update to OH2.

Just to let interested people know:
I run the latest Z-Wave Binding (2.5.0 Snapshot available here: https://ci.openhab.org/job/openHAB2-Bundles/lastStableBuild/org.openhab.binding%24org.openhab.binding.zwave/artifact/org.openhab.binding/org.openhab.binding.zwave/) now, which includes the change mentioned above and it works as expected.

As a side effect, I have a lot less “noise” in the log files. Obviously the cleanup and changes done by @chris helped a lot. Many thanks for that, Chris! :slight_smile:

1 Like