Z-Wave: Philio Multisensor 4 (PST02A) won't work after battery replacement

Dear all,

I’m running oH 2.5 on Raspi3 … since the battery of my Multisensor 4 was empty, I’ve replaced it with a new one. Unfortunately, it seems that the device configuration has gone.
Everything worked fine until the battery change. Now I don’t get motion / reed / temperature data.

I already found out that configuration of z-wave devices - if one uses .things files - isn’t possible. So I’ve deleted the sensor in my .things file and added it via habmin.

The thing shows up in HabMin like this:

This is the parameter configuration:

As far as I know, in OH2.3 one should set “7. Customer Function” to 20 (instead of 4). But now there are completely different values.

Log viewer output (after rebooting OH) - but since then there is no motion/reed detection:

2020-04-26 23:22:40.862 [vent.ItemStateChangedEvent] - EG_flur_s_ms4_reed changed from NULL to CLOSED

2020-04-26 23:22:41.734 [vent.ItemStateChangedEvent] - EG_flur_s_ms4_batt changed from NULL to 100

2020-04-26 23:22:41.908 [vent.ItemStateChangedEvent] - EG_flur_s_ms4_lum changed from NULL to 49

2020-04-26 23:22:44.917 [vent.ItemStateChangedEvent] - EG_flur_s_ms4_tamper changed from NULL to OFF

2020-04-26 23:22:47.567 [vent.ItemStateChangedEvent] - EG_flur_s_ms4_temp changed from NULL to 19.5

2020-04-26 23:22:47.821 [vent.ItemStateChangedEvent] - EG_flur_s_ms4_motion changed from NULL to OFF

It would be very nice if someone could help me.

Parameter 7 is shown bitwise, so it still is on 20.

It rather seems that something with your items definition is wrong, not with your sensor because habmin shows no linked items to the sensor.
Yet in your log something seems to be set.

Thanks for your response.

The device is in Request_NIF mode for about 10 hours …


How can one fix this? Opening the door in order to trigger the reed doesn’t work. There is also no red flashlight as it used to be when a motion was detected.

I think you probably need to address these issues. The fact that the binding is in the REQUEST_NIF state is another indicator that the device is not communicating. If the LED on the device doesn’t flash either, then it seems there’s likely something wrong with the device.

1 Like

Battery installed backwards?

1 Like

Yesterday I replaced the battery again - deleted it in Habmin and added it with .things file.

The device was in “Request_NIF” mode during the night. Now it appears as online and the motion sensor works even in oH log viewer - despite there is no red flash as it was before the battery change.
So the device itself seems to work fine …

But the reed contact still doesn’t work. There must be something missing in oH / device configuration.

Same thing here!
Everything is linked, and there is also a logfile entry for PIR in the openhab.log:

2020-12-08 19:42:31.804 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 19: Updating channel state zwave:device:95603ab1:node19:alarm_motion to ON [OnOffType]

But its not tracked in the event.log!
All other sensor activities are tracked and displayed well, but not this one and I can´t find the difference.

I then grepped within the event.log and found some entries in the last days for this.

2020-12-08 11:37:33.374 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 19: Updating channel state zwave:device:95603ab1:node19:alarm_motion to ON [OnOffType]


2020-12-08 11:37:33.378 [vent.ItemStateChangedEvent] - Haupttuer_PIR changed from NULL to ON

So, in general this works, but why not all the time, just sometimes?

Any idea or solution so far?

Remove the battery and insert it after a couple of seconds (~30).
That’s what helped for me. I also pushed the button a couple of times.

removed battery for one minute, placed it back again, pressed on the tamper key different times…
the motion is reported one time exactly and afterwards it doesn´t appear in the event.log anymore (although it tracked in the main openhab.log)
I don´t see a pattern why it works sometimes…
Because everything else from this sensor (luminance, temperature, door open/closed) works fine and is tracked in both logs: openhab and event

BTW: same issue with the red light: it doesn´t flash any more since upgrade from OH 2.4 to 2.5.10

Also checked ConfigParameter 7: it´s set to 20

Did you manually install the binding at all and forget to remove it before upgrading? Just a thought.

no, just upgraded via Karaf console without removing anything manually

I had to try it a couple of times. Also make sure that the tamper switch on the back is properly pressed.

Thanks, I´ve tried it three times, and now the LED is flashing and the event is tracked in the opehab.log as before, but still not in the event.log!


    2020-12-10 09:41:28.049 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 19: Received COMMAND_CLASS_SENSOR_BINARY V2 SENSOR_BINARY_REPORT
    2020-12-10 09:41:28.049 [DEBUG] [dclass.ZWaveBinarySensorCommandClass] - Processing Sensor Type 12
    2020-12-10 09:41:28.050 [DEBUG] [dclass.ZWaveBinarySensorCommandClass] - Sensor Type is MOTION
    2020-12-10 09:41:28.050 [DEBUG] [dclass.ZWaveBinarySensorCommandClass] - NODE 19: Sensor Binary report, type=Motion, value=255
    2020-12-10 09:41:28.050 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 19: Got an event from Z-Wave network: ZWaveBinarySensorValueEvent
    2020-12-10 09:41:28.051 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 19: Got a value event from Z-Wave network, endpoint=0, command class=COMMAND_CLASS_SENSOR_BINARY, value=255
    2020-12-10 09:41:28.052 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 19: Updating channel state zwave:device:95603ab1:node19:alarm_motion to ON [OnOffType]

Luminance, Temperature, Door State… everything works fine apart from this motion event. I don´t understand as is also tracked after replacing the battery and pressing the tamper key, but still once. No movements are recognized later in the events.log

I´ve also ex- and reincluded the item (with same node ID), but it didnt help.
so there seems to be an issue between “openhab” and “events”.

Update: interesting thing. When I update the item in the config, the first movement event is also tracked in the events.log

2020-12-10 10:13:10.722 [vent.ItemStateChangedEvent] - Haupttuer_Motion changed from NULL to ON

…and the LED is not flashing when sensor is installed and the tamper button is pressed.

tried with logging level “TRACE”…didn´t help.
The motion is still tracked within the openhab.log, but not in the events.log

I give up :frowning:

Can you remove the battery, reinitialize the device in habmin and then insert the battery again and hit the button 3 - 5 times with 2 secs delay in between?

1 Like

Tried everything. Removed battery, reinitialized, etc.
Same behaviour as before:

  1. Motion is tracked once from NONE to ON in the openhab.log (OnOff Type) and in the events.log after battery replacement
  2. Motion is tracked each time correctly in the openhab.log, but not in the events.log
  3. all other sensors (Temp, Luminance, Battery) are tracked in openhab and events.log
  4. no LED flashing on motion when tamper key on the back is pressed

If there would be an issue with the motion sensor itself, there wouldn´t be any entry in the openhab.log, right? so my assumption: it´s getting lost somewhere between.

Just to let you know - I didn’t manage to get this device working properly anymore.
I’ve sold it …

I’ve been using seven devices without any issues for four years, bought even more and only now I’ve experienced some problems with the door state for the first time. :thinking:

It still looks like the device has not completed initialization in openhab. That’s why you have to press the internal button. You can check in habmin if the initialization is complete.

How to check this?
REQUEST_INF ist not displaying when you mean this?

Yes, it should show nothing below the thing.