Z-Wave problem with new modules

Hi,

I’ve included two new fibaro fgm-222 roller shutter (Nodes 34 and 35) module but it keeps on staying unknown devices. I already have 4 modules of same type and they are working great. Any idea on how i could troubleshoot this ?
i also have Fibaro door sensor that aren’t recognized.
2018-01-08 19:43:06.971 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 34: Device discovery could not resolve to a thingType! 010F:0302:1000::25.25
2018-01-08 19:43:06.973 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 21: Device discovery could not resolve to a thingType! 010F:0302:1000::25.25
2018-01-08 19:43:06.981 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 14: Device discovery could not resolve to a thingType! 010F:0302:1000::25.25
2018-01-08 19:43:06.990 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 33: Device discovery could not resolve to a thingType! 010F:0302:1000::25.25
2018-01-08 19:43:06.995 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 9: Device discovery could not resolve to a thingType! 010F:0600:1000::25.25
2018-01-08 19:43:06.986 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 12: Device discovery could not resolve to a thingType! 010F:0600:1000::25.25
2018-01-08 19:43:07.002 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 23: Device discovery could not resolve to a thingType! 010F:0302:1000::25.25
2018-01-08 19:43:07.007 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 7: Device discovery could not resolve to a thingType! 010F:0600:1000::24.24

Not sure why this is happening. I’m using openhab 2.3.0 snapshot with zwave 2.3.0 snapshot.

I have the same problem with Openhab 2.2.0 and zwave-2.2.0-SNAPSHOT. My device is a Fibaro Wall Plug that used to work a week ago but does not get recognized anymore by the binding.

2018-01-08 22:25:44.601 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 38: Device discovery could not resolve to a thingType! 010F:0600:1000::22.22

2018-01-08 22:25:44.787 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 39: Device discovery could not resolve to a thingType! 010F:0600:1000::22.22

Note: When I manually add this thing using a textual .things file I can get it to work - I just cannot receive any reports (e.g. power usage) - I tried setting the association of group 3 to my controller node, but it doesn’t take…

Thing zwave:fibaro_fgwp102_02_001:node38    "SF_Hallway_Switch_Switch1"         (zwave:serial_zstick:controller)    @ "Second floor"    [ node_id=38, config_1_1=1, config_40_1=50, config_42_1=5, config_47_2=30, config_61_1=2, config_70_2=31950 ]
Thing zwave:fibaro_fgwp102_02_001:node39    "SF_Hallway_Switch_Switch2"         (zwave:serial_zstick:controller)    @ "Second floor"    [ node_id=39, config_1_1=1, config_40_1=50, config_42_1=5, config_47_2=30, config_61_1=2, config_70_2=31950 ]

The very strange thing is that my other fgm-222 are still working fine, but can’t retrieve configuration for the new ones.
After updating to the last snapshot, i still got the same problem.

The thing id has changed to match the correct device version: FGRM222 old device type, FGR222 new device type.
Delete the things and readd them …
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/116
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/413

I have deleted the two new devices in PaperUI, then they were automatically
rediscovered and added back. Same problem, the new device are still
unknown. I also have the same problem with some other fibaro modules like
the door sensors. Is there another way to proceed ?

Sylvain
+33652764060

That means you need to check your openHAB setup:
Which openHAB version are you using?
Which zwave binding version are you using (stable, snapshot, development)
Is your zwave controller properly connected? (Online and green)
Check via karaf console which version of the binding is active …

All other ZWave modules are working great as I said, so I don’t think it’s
a controler problem.
I have 4 other fibaro FGM222 that are working perfectly so I can’t
understand why those two new ones aren’t recognized.
My openhab is openHAB 2.3.0 Build #1173 (SNAPSHOT), Zwave binding 2.3.0
SNAPSHOT. My binding is online, ZWave controler is online and all my other
zwave modules except those unknown new fibaro modules are working fine (I
have 23 modules). Even those two new fibaro roller shutter modules are
shown as online, but still unknown.
I can’t connect anymore to karaf console since openhab 2.2.0,
authentication is denied even if i allready reseted karaf password and
that’s another problem, but I’ll discuss it in another topic.

Sorry, from this part

I understood none of your zwave devices are working :sunglasses:

Could you point to the database entry? I am not able to find a FGM222 … There is either a FGRM222 or a FGR222

Also make sure you have the correct thing and device id and firmware number matching the database entry.
Sometimes there are newer firmware versions which need to be added to the database …

My bad, you’re correct,they are FGR222. Firmware is 25.25 for those ones.

Same here:

I’ve again upgraded to last snapshot but my problem is still there. I’ll try to exclude and re-include those modules, but not sure of what I can do.

Your version is exactly the same as @sihui showed in the image above (ie 0302:1000::25.25) and I also checked the database and it looks fine and also the github repository -:

I think that’s extremely unlikely to make any difference - it will still get the same information from the device.

Unfortunately there’s no way to debug this further - I will add some trace level logging into the binding so you can see what is happening.

I’m also pretty sure this won’t change anything. But I don’t have ideas anymore. If you can had some traces, that would be great. Let me know, thanks

If you want to include it again reset the device first to default.
I have another Fibaro (the FGS223) which I could only get to work after a factory reset …

I would suggest to enable trace logging with the latest version - not to reset the device. From what I see above, the issue is not related to the device at all - the binding has downloaded the information from the device and has the manufacturer information just fine and it should be detected by the binding. So either the binding version is wrong, or there’s a bug in the binding.

OK, I won’t reset or re-include it. Now my question is how do I install this version of the binding ? And how do I get the traces ?

Can anyone explain me how to install this version and activate traces ? I’m new to Openhab and some docs are a bit confusing to me.

Because you are on a snapshot runtime

it is easy: just uninstall the binding, wait a couple of seconds and install it again.

Go to the karaf console and type

log:set TRACE org.openhab.binding.zwave

Btw, it’s all in the docs if you haven’t found them yet:

https://docs.openhab.org/administration/logging.html

Thanks for helping me. As said before, I’ll have to solve my problem with karaf console in a first time, as I’m unable to logon to my console. I’ve created a topic for that Unable to connect to Karaf console