Z-wave PST02 sensor Operation Mode issue

zwave
Tags: #<Tag:0x00007f1e5ff01368>
(Tom Natkanski) #1

Hi,
I have reinstalled openhabian 2.4 on my raspi and am running into issue of temperarure being displayed in Celsius by setting the value Operation Mode in the zwave binding config.

The PST02 sensor out of the box displays temperatue in Fahrenheit, so a change in a specific bit needs to be done so that the temperature can be displayed in Celsius. I have done that before a number of times in the 1.x, 2.2 and 2.4-SNAPSHOT versions of zwave.

However, now I am having a number of issues with setting the bits (Celsius being one of them).
a) The only value selectable from a dropdown in habmin and paperui is “Preset: Celsius and LED on = Bits: 00001010 = 10”. Changing to that value did not change F to C after the wakeup (I have two sensors, by the way - sam ebad luck with both).

b) it should be possible to make the change to the bits in the Op Mode parameter as described in the PST02 manual table - operation mode 5: https://doc.eedomus.com/files/PST02_Manual-2014-09-17.pdf

For example if I want to have a number of parameters changed, like switching to Celsius and having Led turned off, and more, I would need to change the Op mode vale to 140

Bit:    7   6   5   4   3   2   1   0
ON(1)   1   0   0   0   1   1   0   0 
Value 128  64  32  16   8   4   2   1
-------------------------------------
        128 + 0 + 0 +0 + 8 + 4 + 0 + 0 = 140

However, it seems that there is no way of changing the operation mode value to 140:

  • in habmin, I can change the value and save successfully, but upon refresh the value is gone.
  • in paperui, I cannot change the value. When saving I get ERROR 400 - bad request.

Any idea, guys of what to do, i tried to revert to the old z-wave 2.4 snapshot, but get an error

"Error starting bundle 234: Could not resolve module: org.openhab.binding.zwave [234]
  Another singleton bundle selected: osgi.identity; type="osgi.bundle"; version:Version="2.4.0"; 
 osgi.identity="org.openhab.binding.zwave"; singleton:="true""

Thanks,
Tom

0 Likes

(Chris Jackson) #2

Note that even if you change the device configuration, it probably won’t actually change what you see in OH. OH has a UoM (Units of Measure) system where the binding tells the core what the units are, and the core will change them to whatever you have configured in your settings.

You should therefore check the localisation configuration to resolve this.

The error means you have 2 bindings loaded. Check your list of loaded bundles and remove the one you don’t want.

0 Likes

(Tom Natkanski) #3

Thank you Chris, Adding the UoM Dimension of Temperature converted the number in Fharenheit into a string in Celsus, however now I am not sure how to truncate the result to 2 decimal places. The documentation is pretty sparse when it comes to UoM it seems. Will keep digging though.

By the way, do you foresee the functionality of being able to set the different Operation Mode bits being implemented anytime soon?

0 Likes

(Nick Gray) #4

I have the PST02 (Zipato brand but it appears as Philio as I believe it’s just a rebrand) but I am able to set my Operation Mode as any number. I changed to Celcius OK - (although that was my only change so my decimal value is 8) as I prefer it set on the device rather than rely on UOM (have run in to issues before). I think I have encountered vales not persisting before, just make sure to wake the device after saving.

I believe your decimals are controlled here (value before f in this case 1):

Number Living_Temperature "Temperature [%.1f °C]" <Temperature> (gPersist1) {channel="zwave:device:6c269b9b:node4:sensor_temperature"}
0 Likes

(Nick Gray) #5

Oh - should have mentioned I am on Openhab version 2.5M1

0 Likes