Z-Wave – Qubino Mini Dimmer ZMNHHD configuration problem


I’ve been using Openhab for 2-3 years now, and thanks to the fantastic advice and support on the forums I’ve never needed to post before (so I count myself as a bit of a forum noob, and I apologise in advance if I fail to observe some protocols) but I’ve hit my first wall.

I’ve been trying to install a Qubino Mini Dimmer ZMNHHD through the Paper UI on a RPi running Openhab2 (2.5.1-2). It is recognised, but is missing its association groups and channels.

I can see others have had problems, and have tried to understand the discussions.

It appears there are two entries in the Z-wave database (#1100 and #1188). #1188 is incomplete and has been marked as deleted, but my install absolutely insists on installing #1188 rather than #1100.

I’ve tried using switching between the release, testing and snapshot builds using openhabian-config to no avail.

I’m assuming that the version of the database in my install needs to be updated. Is there a way I can do this manually or force the discovery to #1100?

Will a manual install of the ZWave binding using the following solve it? Having used the Paper UI mostly for setting up bindings and devices I’ve not been brave enough to try yet and I don’t want to proceed down that route without knowing it is necessary.

@ThatchyP no problem. It’s great to hear you are using openHAB 2-3 years reading and using this great community support.
What I did was download a nightly snapshot of the zwave binding through https://ci.openhab.org/view/Integration%20Builds%20(2.5.x)/job/openHAB2.5.x-ZWave/ and add this to The addons directory https://www.openhab.org/docs/configuration/addons.html (last paragraph ) . This should get you run on the latest version of the zwave binding which fixed this issue .

1 Like

@struvusmaximus - fabulous - I took the SNAPSHOT.jar and dropped it in the addons directory (openhab2-addons on my machine) et voila - thank you so much for your help :partying_face:

1 Like

@ThatchyP, which channels do you have now?

I’m using OH 2.5.10-1, the Qubino Mini dimmer works fine and reliable :+1:
However, I miss an on/off switch. The Qubino is able to do that, as it has a command class COMMAND_CLASS_SWITCH_BINARY.

Of course, I can always use the dimmer value to put the lights on, but I cannot put the light in the previous level (minor issue, I know).

In the openhab cli, when I run the command:

smarthome:things show zwave:device:[myzwaveid]:node7

I get the response: (abreviated for clearity):

 ID: switch_dimmer
 Label: Dimmer
 Type: zwave:switch_dimmer
 Description: The brightness channel allows to control the brightness of a light. It is also possible to switch the light on and off.

 ID: meter_kwh
 Label: Electric meter (kWh)
 Type: zwave:meter_kwh
 Description: Indicates the energy consumption (kWh)

 ID: meter_watts
 Label: Electric meter (watts)
 Type: zwave:meter_watts
 Description: Indicates the instantaneous power consumption

 ID: alarm_power
 Label: Alarm (power)
 Type: zwave:alarm_power
 Description: Indicates if a power alarm is triggered

I assume the on/off switch is not implemented… ?
@chris was this a design issue?


p.s. Haven’t tried this is nice new 3.0 version.

No. We don’t normally provide a switch channel - if you have a dimmer channel you can use this and another channel is normally of no additional use. This is the way OH is meant to work (ie a dimmer extends a switch).

1 Like

Wow, that is a fast respons! :grinning: :+1:

But what about my use case? Put the dimmer on at the last dimmed level?
The physical switch has this behavior.

Sorry - I didn’t read through the detail and was answering in general (hence the quick answer :slight_smile: ).

I will take a look at this later - probably we can change the binding easily to make this work.