Z-wave refresh rate and TKB unknow device

Hi All,

I have two questions, I hope you can help me :slight_smile:
First one,
How can I edit the refresh rate between the openhab and the z-wave devices, in the OH1.8 I could set it in .items, but in 2.0 I cant find it…
Second one,
I have a TKB double pad switch, TKBETZ35-D (http://www.tkbhome.com/?cn-p-d-286.html), but the OH say its unknow device. I already check this device in database(http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list) and I did’t find, but I cant upload the generated xml based on Guide. Anybody tried to upload xml to database?
Thanks for any help!

BR,
O.

Unless this device doesn’t support associations, I would leave this alone - it’s generally not recommended to use polling.

Presumably you missed the part about emailing me so I can give you edit access? It should work now.

Hi,

First of all, thank you for your fast reply!

Do I have any chance to edit the 30minutes to 30 sec? After I switch on the lamp in kitchen, I have to wait 30 minutes to update it in OH?

You are right, I didn’t send, Sorry!

I already uploaded the xml, but I got warning, hope I will can handle these :slight_smile:

BR,

O.

Does the device support associations? If it does, then you should use associations to update the binding and not use polling. If you use associations, then you will not wait 30 seconds - it will happen instantly and you will not congest the network by polling.

If you really want to use polling, then it can be reduced, but as I’ve said, I don’t recommend it.

It looks like the device you have is already in the database? Is it this one?

Almost, the References (Type:Id) not 0004:0003 but 0003:0004 as I see
and name not tkb65d, tkb35d

uploaded xml

BR,
O.

Sorry - I think I’ve got the right one now?

The type and ID corrent based my xml, but why you change the name from 35 to 55?
Sorry, this is my first time to add new device :smiley:

BR,

O.

I didn’t change the name - this device is already in the database and it should match your device.

O I see, But my OH didn’t recognize it, I use 2.1.0 snapshot 2017.02.18…

I will try it with newest snapshot, but based on your site “log” the last update for that device is 2017-02-03 so it should have already in, right?

BR,
O.

Yes, it should (I think) be in the binding you have, but it’s worth grabbing the lastest to be sure. If it’s not working, then please provide a full debug log during startup and I’ll tke a look.

Didnt work, I send a mail, via attached log

BR,

O.

I would say the device is faulty as it’s not returning a valid manufacturer ID -:

:frowning: should I update that code, or I have to send it back?!

Now I can control it, after I edit the zwave xml manufacture part, 0x118
Now he think its a tz55d, and works as expected :slight_smile:

What do you recommend? send it back, or just happy with it? :smiley:

BR,
O.

I don’t think that’s possible.

Personally, I would send it back otherwise you will continually have problems with it not being recognised.

Hi, I asked a replacement, and he send me a new one, but that still has FFFF manufacture ID.
So I guess they all have this FFFF manufacture ID :’(

O.

Hi.
I got the TKB TZ35S , wich is the single pad switch version of TZ35D. It has the same References (Type:Id) 0003:0004 like the TZ55D in the database.

I have the same Problem of the Manufacturer ID not being read correctly. It reads 0xffff wich seems to be a general problem with these devices.

If I change the Manufacturer ID to 0x118 in the node xml file it shows the correct manufacturer in HABmin but it still says the device is not in the database and initialisation is not complete.

What can I do next? Thank you.

EDIT:
Ok, maybe the problem is that my z-wave binding is too old, so I don’t have the TZ55 in my systems database. Problem is I am using openhab2 on a qnap NAS, so I am using a prepackaged qpkg of offline version openhab 2.0. Any Idea how I can use my device without having to wait for a new release?

EDIT2:
I installed latest zwave binding snapshot and edited the manufacture ID manually in the node xml --> its working

Hi Folks,

I have a TKB TZ35D, have exactly the same problem - Manufacturer ID is shown as 65535 and I tried editing the node.xml file after discovering the device in Paper UI - still doesn’t update the device after adding it to Things.

21:50:56.378 [INFO ] [smarthome.event.ThingAddedEvent ] - Thing ‘zwave:device:6f53e4ba:node5’ has been added.
21:50:56.394 [DEBUG] [org.openhab.binding.zwave ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.core.status.ConfigStatusProvider}={service.id=1072, service.bundleid=191, service.scope=singleton} - org.openhab.binding.zwave
21:50:56.410 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler.
21:50:56.412 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘zwave:device:6f53e4ba:node5’ changed from UNINITIALIZED to INITIALIZING
21:50:56.426 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘zwave:device:6f53e4ba:node5’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
21:50:56.476 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Controller status changed to ONLINE.
21:50:56.479 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Controller is ONLINE. Starting device initialisation.
21:50:56.484 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Updating node properties.
21:50:56.487 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘zwave:device:6f53e4ba:node5’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
21:50:56.489 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Updating node properties. MAN=65535
21:50:56.493 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Updating node properties. MAN=65535. SET. Was 65535
21:50:56.497 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Properties synchronised
21:50:56.504 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Property to update: group_org.openhab.binding.zwave.internal.protocol.ZWaveAssociationGroup@103dd5, [], null
21:50:56.507 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Properties synchronised
21:51:01.414 [WARN ] [ome.core.thing.internal.ThingManager] - Initializing handler for thing ‘zwave:device:6f53e4ba:node5’ takes more than 5000ms.
21:51:01.422 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Initialising Thing Node…
21:51:01.424 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘zwave:device:6f53e4ba:node5’ has been updated.
21:51:01.426 [INFO ] [marthome.event.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
21:51:01.426 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 5: Polling intialised at 1800 seconds - start in 1800000 milliseconds.

Note I have latest snapshot version:
191 | Active | 80 | 2.2.0.201708091334 | ZWave Binding | org.openhab.binding.zwave

I have another TKB dimmer device (TZ65D) which works fine.

Any hints would be great as this is driving me nuts!

Cheers!

I have the same problem with a TKB Power plug. Device manufacterer id is 65535, i edited the node7.xml, restarted openhab2, but it overwrites the xml again. What todo?

Hi if anyone has some ideas I’m all ears - just tried it again, i’m running openhabian latest version :frowning:

Make sure that the device is initialising. The device is mains powered so it shouldn’t have an issue, but check that the manufacturer information is being correctly returned by the device. If the device is sending FFFF as the manufacturer ID, then I would say it is broken as this is invalid…