Z-Wave Secure Inclusion

zwave
doorlock
Tags: #<Tag:0x00007f6ce642b148> #<Tag:0x00007f6ce642af90>

(Chris Jackson) #43

Update looks fine - thanks.


(Danny Cohn) #44

Awesome, thanks. I’m still working to get my IDE set up. Any chance you are planning to post a new binding JAR with the latest DB anytime soon?


(Chris Jackson) #45

Yes - I will do one tonight.


(Danny Cohn) #46

Hi Chris, really sorry to pester you, I was just wondering if you were still planning to do this some time soon. If not, I’m happy to get my IDE set up and figure out how to compile with the latest DB myself.

Thanks, Danny


(Chris Jackson) #47

Probably not now until next weekend. What are you after? It was updated last, on the night I said I would (ie 4 days ago now).

You can always find the latest version in following thread -:


(Danny Cohn) #48

Oh, I didn’t realize. I guess I was expecting a post in this thread. I was just after the update that I made to YRD210 to expose the alarm_raw value.

I’ll download the latest JAR and try it out.


(flashbac) #49

Hello everyone,

Another newbie here. So I’ve read and I’ve read all these posts regarding secure inclusion and I cannot get my smart lock to work with OH2. I have a Nortek/GoControl HUSBZB-1 stick and a Schlage Connect BE469WK.

So far I’ve tried a fresh new install and all the snapshots mentioned in this post. I also installed the serial transport in karaf console. Right now I’m using:
230 │ Active │ 80 │ 2.3.0.201802082157 │ ZWave Binding

I tried using low power, high power and network wide inclusion. No matter how many times I exclude the darn lock, it refuses to pair securely.

I also tried using the zensys tool. Factory reset the smart lock, hardware reset the stick, stand on one leg and crossed my fingers and nothing has worked.

The error that I get in the logs is:
2018-02-12 23:33:25.746 [INFO ] [alization.ZWaveNodeInitStageAdvancer] - NODE 4: SECURITY_INC State=FAILED, Reason=GET_SCHEME

Any help would be appreciated.

Thanks.


(Håvard) #50

I had this get_scheme error thing at some point.
Finally I tried with my receiver under a meter away, high power, secure inclusion mode set to all devices, firmware reset on the lock, exclude and include in habmin.
The first time it didn’t work with this either, but I tried changing network security key and did it again and then it worked.

Also I thought I would set the secure inclusion mode back to entry control devices, but then it stopped working so I guess I’ll leave it alone.


(flashbac) #51

Blahbla,

We shouldn’t have to jump thru so many hoops to get the lock to pair with the stick, so there must be a bug somewhere in the code. The lock pairs fine with other zwave hubs (ST Hub), so we should aim for OH to have the same quality.

If the developers want, I’m willing to help to root cause the issue, by testing and providing whatever information they need. Just tell me what to try and what info logs to provide.


(Chris Jackson) #52

I thought you said earlier that you also tried using the Zensys software and that didnt work?

-:

If what you have written here is really the case, then I think the issue is not with openHAB?

Of course, help is always greatly received. It’s not a simple issue to resolve as by nature security issues devices may simply not reply. However you can use the log viewer to help debug the problem


(flashbac) #53

Hi Chris,

I tried the zensys tool and it pairs fine with the lock, at least it looks like it. I even tried pairing it with zensys first, then moving the stick to OH and did the inclusion in OH and it still did not pair. But like I said, I’m new to this so maybe I did the zensys thing wrong.

So I guess there are three things to rule out here:

  1. The stick
  2. The lock
  3. OH

Hopefully we can use Zensys to rule out the stick and/or the lock, but i really dont know how to use Zensys all that well. Is there a set of instructions that I should follow or a tutorial somewhere that explains how I should pair with Zensys first? and maybe then move the stick to OH to see if it works that way?


(Chris Jackson) #54

What do you mean by this? It sounds like you are doing the inclusion twice? If you do the key exchange with the Zensys tool, then you do not need to include it again on OH. You must only try and include it once.

I have never used the Zensys tool so I can’t comment on this - sorry.

To be honest, I’m still not really sure what you are doing. The secure inclusion is VERY particular about what you have to do, and how quickly it needs to be done. If it’s not performed correctly, then it will fail (welcome to the world of security :wink: ).

Please can you clearly state step by step what you have done when including the lock. Sorry to sound like I’m being difficult, but secure inclusion can be difficult.

Also, please check the logs, or if not, please provide the logs so they can be checked to see what is going on.


(paulfaure) #55

How can I go about adding tonnes of debugging to the zwave module for inclusion/exclusion?
When I use Habmin, it doesnt seem to do anything except say this in the logs:

2018-02-17 14:58:28.503 [arthome.event.BindingEvent] - org.openhab.binding.zwave.event.BindingEvent@43326675

My yale lock YRD240 didnt have any impact when I tried to add or remove the device.


(Chris Jackson) #56

I guess you’d need to compile the binding yourself if you want to add debug. There is information on setting up the IDE in the documentation.

If you just want to see the existing debug, then just enable debug level logging with the set:log debug org.openhab.binding.zwave command (as in the documentation :wink: ).


(Scott Rushworth) #57

It looks like this may be from the event.log file, with a default setup. Set the zwave binding to debug log:set DEBUG org.openhab.binding.zwave) and tail the openhab.log file. There are lots of posts about this (sorry… on phone).

Also, when you used Zensys, did you set a security key or use the one provided. If the latter, make sure to be using the same key in OH.