Z-wave stat value changed but very slow response in RULE?

Hello.
I`m having some problem whit a z-wave power meter ( NEO Coolcam. NAS-WR01ZE Wall Plug Switch )
It all works fine BUT VERY VERY SLOW 30sec. - 1min…
If i push the switch i sitemap the z-wave response instantly.
On state change in logs i see in the logs the value changes fine ,but openhab waits too responce ???
Does anybody know how to speed this up so it can be used to something meaning full ?

Sitemap :

Switch item=sonoff_5

Text item=zwave_kontor_watt label=" kontor autuelt forbrug [%.1f W]"

Items :

Switch sonoff_5 "sonoff_5" (BA) ["Switchable"]
  { mqtt=">[broker:cmnd/sonoff_5/power:command:*:default],
          <[broker:stat/sonoff_5/POWER:state:default]" ,autoUpdate="false" }

Number zwave_kontor_watt     "Forbrug [%.2f watt]"   { channel="zwave:device:e6400b2c:node8:meter_watts" }

Rule :

	rule "Office ON "
when
    Item zwave_kontor_watt changed
then
   logInfo("zwave_kontor_watt", "zwave_kontor_watt=" + zwave_kontor_watt.state);
   if(zwave_kontor_watt.state == NULL) return;
   if(zwave_kontor_watt.state >= 10) sonoff_5.sendCommand(ON)
end
	rule "Office OFF"
when
    Item zwave_kontor_watt changed
then
    logInfo("zwave_kontor_watt", "zwave_kontor_watt=" + zwave_kontor_watt.state);
    if(zwave_kontor_watt.state == NULL) return;
    if(zwave_kontor_watt.state <= 10) sonoff_5.sendCommand(OFF)	
end

In paperui :

Udklip
it shows over the 10 watts to but still no responce in rule ,before after 30sec. - 1 min.

The Z-wave controler is : Aeotec Z-Stick - Gen 5 - gateway

z-wave_plus_aeotec_z-stick_usb ntroller

The power meter :

New-EU-US-Outlet-Z-Wave-power.jpg_350x350

Windows 10 machine :

cpu openhab machine

openhab version

A snippet from your events.log should nicely show your problem.
How often does your zwave device report power readings?

More helpful would be to follow the zwave documentation instructions for when things do not go as planned and post some debug logs.
The log viewer is here if you wish to look too.

Mabye you are right ,but i can see the value change in paperui (control)
and nothing happens.( ONLY AFTER SOME TIME AFTER CHANGE ,NOT RIGHT AWAY ?)
pulling time zwave

i can`t set this time under 30sec. ?

in the logs it shows events every 30 sec.

Here we need brand and model numbers, not images. All I can tell is the brand is Fibaro.

What are the capabilities of your mystery zwave device? openHAB can’t make it do things that it cannot do.

Perhaps you need to look into polling it a short time after issuing a command to it.

IT`S a : Z-Wave NAS-WR01ZE Wall Plug Switch NEO Coolcam.

I can see that the time can be set to less secounds but not how ?
openhab minimum 30sec. ?

I think it’s generally recommended to use Habmin to alter settings in zwave devices.

Careful though, do you really want to clag up your zwave network with metering reports every second?

I’ve being trying to prod you to think about the binding’s channel setting for poll after command. If the meter value is returned in a response to that, you might need to alter the time delay. Too quick will give you an old value before the command has taken effect.

i don`t know how to do that ? sorry i dident responded to that before

Clue

  1. That does not agree with your original photo.
  2. You are depending on the Coolcam document with the unit. I have received their devices where the supplied documentation did not match the actual device.

I have some of those plugs, in the US version but do not use the metering. We have 2 entries for that model, depending on the device type & id numbers.One of the entries indeed has a 30 second minimum for meter reporting. These cheap Chinese devices are cheap for a reason :wink:
In HABmin, go to Configuration -> Things -> [device] -> Attributes (all the way at the bottom) and post a screenshot. It will look something like this.
image

I have a lot of this and now i see that i have 2 kinds the one im doing this with i an old one and others i have are a newer and they can be set to report every 1 sec. thanks ,but i will try to look at that pull thing so my logs dont get useless to look at.

ps : i have changed the picture in orginal post , i just thourght it look like that sorry.

I do not know what firmware version our entry was based on but our entry and the attached manual clearly state a 30 second minimum for report in parameter 7. It was last updated 2 months ago. (from our pdf manual)
image

Your manual says parameter 2 and a 0 minimum. If we make an entry for newer firmware we would need a pdf of an updated manual. Can you find one online?

How to do the polling , can you show me please i`m not a coder at all :slight_smile:

That’s as much as I know

I think that is the reporting configuration that is currently limited to 30 seconds minimum in your case based on the manufacturer’s documentation we currently have.

ok thanks a lot for the help ,i gues i will be Using my tuya wifi power plug then i can do the trick via. convert to tasmota and then whit mqtt :slight_smile:

s-l300

this works but is on wifi so my 18ps. z-wave plugs i must use for something
were i can wait for 1 min. befor resolut ( turn lights off auto when no movement i some time )

Nope. “poll after Command” is a function of the binding, not the device. Shortly after a command is sent, a one-time status poll can be sent. “Shortly” is under the control of the zwave binding and is a Thing setting - I think it is named Command Poll Period in PaperUI and is expressed in milliseconds.

If this happens too quickly, you’ll get the old state from the device.
So, you could try extending the time, to see if that gives the device time to update its own sensing.
It might not help if the device only measures its own current sensors every five minutes or something.
It might not help if the device does not include the power measurement in its status response.

1 Like

as i startet the hold thing to tell about the thing that i was woundring about is that the
value changes in my paperui (control )
forbrug watt

but afterwoods wait 30sec. to 1min. to do something after it has changed ???
i belive that openhab then knows the value ,but somthing prevetts it to do something
maby it tryes to comfirm or something ??