Z-Wave Valve Eurotronic Spirit (Database not updated in OH1, Incomplete Parameters in database

Hello Friends and Maintainers of OH,

I have recently installed the Eurotronic Spirit thermostatic valve in my complete home. Unfortunately, I have only checked if it is available in the database and didn’t look at the details.
(http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/710)

I was able to integrate the valve with habmin snapshot 0.1.4, OH1 and Z-wave Binding 1.11.0. However, I have no possibility to change the configuration with habmin. I also tried the latest snapshot from cloudbees but same result. Looking into the workspace at cloudbees it even doens’t appear in the database, only some old devices from this manufacturer. This was surprising - since how I understand - the database is used to maintain the OH1 and OH2 zwave binding at the same time.
image

Furthermore it came out that the database entry of this device is incomplete and some of the paramters and also command classes are not shown.

For example in the command class THERMOSTAT_MODE the parameter (15) for boost mode is not recognized by openhab.
2018-01-04 12:08:20.634 [ERROR] [WaveThermostatModeCommandClass] - NODE 20: Unsupported mode type 15
2018-01-04 12:08:20.636 [WARN ] [c.ZWaveThermostatModeConverter] - NODE 20: Generating message failed for command = THERMOSTAT_MODE, endpoint = 0

Why is it not possible to pass through unknown paramters? It would not be a problem to handle these in the text based configuration.

When using the command PROTECTION I also get a stange converter-error. This class is required because the valves will be locked for local operation when the battery is replaced. I have tried this several times and the only way to get rid of this without the protection command is to exclude and reset to factory defaults and include again. A procedure that is not very convenient to replace the battery.

items.confic
Number Item_Valve_Protection “Safe [%d]” (Arbeitszimmer, Heizung) { zwave=“20:command=protection”}
sitemap.config
Switch item=Item_Valve_Protection label=“Safe [%d]” mappings=[0=‘Aus’, 1=‘Lokal’, 2=‘Remote’]
openhab.log
2018-01-04 12:26:32.289 [WARN ] [.b.z.i.c.ZWaveConverterHandler] - NODE 20: No converter found for item = Item_Valve_Protection, ignoring command.
2018-01-04 12:26:36.256 [WARN ] [.b.z.i.c.ZWaveConverterHandler] - NODE 20: No converter found for item = Item_Valve_Protection, ignoring command.
2018-01-04 12:26:52.744 [WARN ] [.b.z.i.c.ZWaveConverterHandler] - No converter found for item = Item_Valve_Protection, using 0 refresh interval.
2018-01-04 12:26:52.744 [WARN ] [.b.z.i.c.ZWaveConverterHandler] - No converter found for item = Item_Valve_Protection, using 0 refresh interval.

All comments to sort this out are highly appreciated! Thank you!
Gerald

No - the OH1 database is not updated routinely since too many (ie most!) of the database entries in OH1 were manually created and changing everything to the new system when not many people are using this was too high a risk. You can easily export the XML from the database and create a PR in the OH1 repository.

This will need someone to update the database - please feel free to do so :wink:

It’s been a long time since I looked at OH1, but the error indicates that the converter (ie the command class) is not supported so can’t be used.

"You can easily export the XML from the database and create a PR in the OH1 repository."
OK I have added a pull request as proposed.

"This will need someone to update the database - please feel free to do so :wink:"
I can try do so, but are you sure this is only a database issue? since the documentation does not include this paramter, last parameter for THERMOSTAT_MODE is "13 = “Away”

"…but the error indicates that the converter (ie the command class) is not supported so can’t be used."
Any other ideas how to avoid to reset and exclude/include the devices everytime?

Thansk - it’s merged :slight_smile:

No - I’m not sure. I’ve not looked at it at all and am just going on your statement that the database is incomplete…