Zigbee and zwave manual install script

Yep, removing the binding does not delete the Things. Strange that it did not uninstall for you. Were there any errors? Maybe the script couldn’t get into the console to uninstall the existing binding?

I saw some exceptions in the log and the script timed out after 2 minutes. It seemed to me that the running zigbee binding was preventing itself from being installed. Seems like some (un)intended locking mechanism… Anyway, I solved it by uninstalling from PaperUI. Perhaps the easiest thing to do is add that as a trouble shooting suggestion to the documentation of the script.

1 Like

Thanks. Minor nit though.
Your README on Github references zzManualInstall.sh & the script is zzManualInstaller.sh.
The example also references an option --ZWAVE_BRANCH that is no longer valid.

This is a fresh 2.5M1 install & the script timed out & I see these errors continuously in the log.

2019-07-06 07:22:27.798 [WARN ] [ore.internal.binding.BindingResource] - Cannot get config id for binding id 'zwave', probably because binding does not exist.

Any ideas?

Installing & uninstalling zwave through the Paper UI first does not help.

Thank you… I’ll correct those issues in the readme.

The errors you see will occur within a 2 minute loop where the script is checking for the uninstallation and again for the installation of the binding to complete, so this is normal. Actually timing out is not though. I’ve seen this happen when running the script when the CI server is down, a build is being created, or the URLs have changed. The files are downloaded but they are not the binding or even a jar, so the binding never starts. If this is the problem, it usually just takes time for things to clear up. You can confirm that this is the problem by opening the jar up (it’s just a compressed file) and confirming there are files in it. Unfortunately, I never got around to adding much error checking into the script.

I figured out the issue, I think. My openhab user is pi Running this first seems to cure the script timeout.

sudo mkdir /home/archive
sudo chown pi:pi /home/archive

IOW, the script times out if the /home/archive directory does not exist.

That sounds fishy. The script should create that directory in addons, which should be /usr/share/openhab2/addons for a repository installation, and should be where the script is located too.

Hmmm it did that & the /home/archive directory I created is empty.
Strange indeed, but I am working now, thanks.
Each time I ran the script from the /usr/share/openhab2/addons directory where the script is also located.

EDIT: All this was with script version 1.2.1

12 posts were split to a new topic: Problem running ZigBee binding

Using the zzManualInstaller.sh script from https://github.com/openhab-5iver/openHAB-utils/releases I am getting a timeout error:

“It has taken more than two minutes to uninstall the Z-Wave binding, so exiting”.

So in PaperUI I uninstalled the Z-Wave binding (and the uninstall hung there as well). After waiting a while I looked out of the console, and started OH2 with ./start.sh. In PaperUI I removed the Z-Stick controller and that process hung. After waiting a while I again logged out and back in again and PaperUI reflected that the controller was still in “removing” process. I then re-ran zzManualInstaller.sh and again there is a timeout to install the z-wave binding

You can either follow the manual instructions included with the script or tell us what version of OpenHAB you are running so we can help.
I believe the script does not work well on 2.5M2

Did you not have OH running when you ran the script?

1 Like

Yes, I have openhab running and using 2.4.0.

Since this is a new testing install, I ditched the old install and started from scratch. I downloaded version 2.4.0,and initialized using the “Expert” option. I started openhab using the ./shart.sh script. I then moved zzManualInstaller.sh to the new openhab addons directory, and ran ./zzManualInstaller.sh. Same problem. After hanging on “Installing unmanaged Z-wave binding …”, the two minute timeout error occurred and the script quit.

The reason I am focused on this is because I am trying to install a Z-Wave Thing that is supported by openhab, but is not in the 2.4.0 database after a fresh install, and Im sure this won’t be the first time I run into this.

I’ll try to take a look at this tomorrow. If you can’t wait, follow the manual steps from the readme.md in the repo.

In addition, using the zzManualInstaller.sh script populated the addons directory with:

  • archive directory (staging/zwave and zwave directories (empty))
  • org.openhab.binding.zwave–SNAPSHOT.jar
  • org.apache.servicemix.bundles.xstream-1.4.7_1.jar

and using openhab> list -s | grep -i zwave shows no zwave entry
After logout and ./start.sh - still no zwave binding entry

I also hit the 2 minute timeout when trying to install Zigbee bindings with the latest script release. The openhab.log contains multiple (every 5 seconds)
[WARN ] [ore.internal.binding.BindingResource] - Cannot get config id for binding id 'zigbee', probably because binding does not exist.
entries while the script was waiting. I then looked at the .jar files in the addons directory and all org.openhab.binding.zigbee.*.jar files were less than 1 kB in size. Strange. Content:

<meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
<title>Error 403 Trying to access a file outside of the directory, target: org.openhab.addons.bundles/org.openhab.binding.zigbee/2.5.0-SNAPSHOT/org.openhab.binding.zigbee-2.5.0-SNAPSHOT.jar</title>
<body><h2>HTTP ERROR 403</h2>
<p>Problem accessing /job/openHAB2-Bundles/lastSuccessfulBuild/org.openhab.addons.bundles%24org.openhab.binding.zigbee/artifact/org.openhab.addons.bundles/org.openhab.binding.zigbee/2.5.0-SNAPSHOT/org.openhab.binding.zigbee-2.5.0-SNAPSHOT.jar. Reason:
<pre>    Trying to access a file outside of the directory, target: org.openhab.addons.bundles/org.openhab.binding.zigbee/2.5.0-SNAPSHOT/org.openhab.binding.zigbee-2.5.0-SNAPSHOT.jar</pre></p><hr><a href="http://eclipse.org/jetty">Powered by Jetty:// 9.4.z-SNAPSHOT</a><hr/>


It seems I hit a download error which the script doesn’t recognize?

1 Like

I am receiving the same error, but with ZWave.

Cheers! :slight_smile:

p.s. Welcome @Vir :slight_smile:

If the script does not work for you for whatever reason just download the jar file and drop it into your addons folder after you uninstalled your current binding version:


Some openHAB versions require an additional jar file too. The script readme file documents how to install everything manually.

1 Like

Wasn’t a matter of the script not working, the system was returning an error which curl saved as a .jar file. :slight_smile:

That URL was what I needed, thank you. Could not find it anywhere.

Cheers! :slight_smile:

Yup, it is very well documented. Now that I have a working URL for the jar file, I have a working zwave again. :slight_smile:

Cheers! :slight_smile:

1 Like