Zigbee binding and CC2531

i have successfully flashed a CC2531 stick, with the firmware which is mentioned here:

When i install the Zigbee-Binding, i see that the binding is installed. But i guess under Configuration->Bindings i should see the CC2531 with the Address and so one … ?? But i see just the installed Binding.

In the console i can see that the CC2531 is identified by the system:
ls -l /dev/ttyACM0

i see


why is the CC2531 not recognised by the Binding?
In the openhab.log is nothing concerning zigbee. I have activated the zigbee loging, like mentioned in the documentation.

1 Like

Have a look at your permissions and verify that openhab has proper access rights to USB port.

which permissions should it have??

ls -l /dev/ttyACM0
crw-rw---- 1 root dialout 166, 0 Aug  9 23:25 /dev/ttyACM0

should i just add the openhab user to the dialout group?

Yes, openhab user needs to be a member of dialout group and tty.
What platform are your running openhab on?

its Openhab 2.3 on a Mint 18 system

Check if java knows about serial device (do a ps and see if -Dgnu.io.rxtx.SerialPorts=… contains /dev/ttyACM0).
It’s usually injected by setting EXTRA_JAVA_OPTS= in /etc/default/openhab2, not sure if that applies to your Mint setup.

Also may need to delete the contents of /var/lib/openhab2/cache and /var/lib/openhab2/tmp. Not sure the this is the correct path to your Miint cache and tmp files, check the doc’s to verify. Then restart openhab.

in the /etc/default/openhab2

where do i find Dgnu.io.rxtx.SerialPorts= ??

sudo nano /etc/default/openhab2


Then clear the files I mentioned above and restart openhab.

I gotta run, but one other thing to check is your Java version, make sure its correct per the doc’s and your install.

ok, it is done. I have edited the /etc/default/openhab2 , cleard the cache and restart OH.

But i still don’t see the CC2531-Adress in the Configuration / Bindings

java version “1.8.0_181”

Try sudo chmod 777 /dev/ttyACM0 to make sure there is no permission hang up.

Getting yelled at, gotta go, best of luck.

it does still not work.
I still can not see the CC2531 at Configuration->Bindings

Correct. This is not the place to install devices - this just gives binding level information and configuration and the ZigBee binding has none.

To add a new device, go to the inbox, click the + button, then you can manually install the coordinator.

do you mean with “device” the Zigbee-master-Stick or the Zigbee-slaves??

I thought, when i have the stick pluged in and install the binding, i can use the Zigbee-master-stick without configuration? And i just have to connect the slaves to the master-stick?

Did i have to configure the Zigbee-Stick manualy??

No. The system needs to somehow know that you have a CC2531, what port, speed, etc it is on, chant ZigBee channel, PAN, EPAN, key… This information needs to be provided once you add the coordinator.

A good source of information is the documentation -:

Yes. As per the documentation at the link above -:

Coordinators need to be installed manually and the serial port and baud rate must be set. These are set to match the configuration that the dongle is in.

thanks for the hint, i overlooked the part with the config.
Now at least the CC2531 is shown in the config.

But how i enable the discover manually to find the zigbee slaves?

It’s done in exactly the same way as any other binding. Go to the Inbox page and start a scan.

Once you start discovery, you also need to put the device into join mode, or reset it.

i have allready tried it.

I have 2 aqara-window-sensors and i’am put them next to the cc2531 and pushed the buttons for about 10 seconds, but it was not discovered?