Zigbee binding and CC2531

zigbee
cc2531
Tags: #<Tag:0x00007f15e80bf4f0> #<Tag:0x00007f15e80bf2e8>

(alex) #5

its Openhab 2.3 on a Mint 18 system


(CM6.5 H102) #6

Check if java knows about serial device (do a ps and see if -Dgnu.io.rxtx.SerialPorts=… contains /dev/ttyACM0).
It’s usually injected by setting EXTRA_JAVA_OPTS= in /etc/default/openhab2, not sure if that applies to your Mint setup.


(CM6.5 H102) #7

Also may need to delete the contents of /var/lib/openhab2/cache and /var/lib/openhab2/tmp. Not sure the this is the correct path to your Miint cache and tmp files, check the doc’s to verify. Then restart openhab.


(alex) #8

in the /etc/default/openhab2
is EXTRA_JAVA_OPTS=""

where do i find Dgnu.io.rxtx.SerialPorts= ??


(CM6.5 H102) #9
sudo nano /etc/default/openhab2

EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0"

Then clear the files I mentioned above and restart openhab.


(CM6.5 H102) #10

I gotta run, but one other thing to check is your Java version, make sure its correct per the doc’s and your install.


(alex) #11

ok, it is done. I have edited the /etc/default/openhab2 , cleard the cache and restart OH.

But i still don’t see the CC2531-Adress in the Configuration / Bindings


(alex) #12

java version “1.8.0_181”


(CM6.5 H102) #13

Try sudo chmod 777 /dev/ttyACM0 to make sure there is no permission hang up.

Getting yelled at, gotta go, best of luck.


(alex) #14

it does still not work.
I still can not see the CC2531 at Configuration->Bindings


(Chris Jackson) #15

Correct. This is not the place to install devices - this just gives binding level information and configuration and the ZigBee binding has none.

To add a new device, go to the inbox, click the + button, then you can manually install the coordinator.


(alex) #16

do you mean with “device” the Zigbee-master-Stick or the Zigbee-slaves??

I thought, when i have the stick pluged in and install the binding, i can use the Zigbee-master-stick without configuration? And i just have to connect the slaves to the master-stick?

Did i have to configure the Zigbee-Stick manualy??


(Chris Jackson) #17

No. The system needs to somehow know that you have a CC2531, what port, speed, etc it is on, chant ZigBee channel, PAN, EPAN, key… This information needs to be provided once you add the coordinator.

A good source of information is the documentation -:

Yes. As per the documentation at the link above -:

Coordinators need to be installed manually and the serial port and baud rate must be set. These are set to match the configuration that the dongle is in.


(alex) #18

thanks for the hint, i overlooked the part with the config.
Now at least the CC2531 is shown in the config.

But how i enable the discover manually to find the zigbee slaves?


(Chris Jackson) #19

It’s done in exactly the same way as any other binding. Go to the Inbox page and start a scan.

Once you start discovery, you also need to put the device into join mode, or reset it.


(alex) #20

i have allready tried it.

I have 2 aqara-window-sensors and i’am put them next to the cc2531 and pushed the buttons for about 10 seconds, but it was not discovered?


(Chris Jackson) #21

The Xiaomi devices are problematic to include into the network as they don’t tend to respect the ZigBee polling requirements, and go to sleep immediately. You need to keep pressing the button every few seconds for maybe 30 seconds or so - hopefully it will eventually work.


(alex) #22

you mean pressing 5sec, release and press 5sec again for 30sec or longer??


(Chris Jackson) #23

I mean once you put the device into join mode (I forget how that’s done), then every 5 seconds, press the button once quickly - keep doing this for 30sec or a minute. This tries to prevent the device sleeping while the binding discovers the services.


(alex) #24

until now, it does not work.

But one step back, to make sure the stick is working well. When I’m initialising the cc2531, i get the following log:

13-Aug-2018 00:07:19.228 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - null: Configuration received (Coordinator).
13-Aug-2018 00:07:19.231 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_initialise >> false.
13-Aug-2018 00:07:19.233 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_channel >> 11.
13-Aug-2018 00:07:19.234 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_panid >> 24552.
13-Aug-2018 00:07:19.235 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_znp_magicnumber >> 239.
13-Aug-2018 00:07:19.236 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_extendedpanid >> 83B9EF869F07EC2F.
13-Aug-2018 00:07:19.236 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_networkkey >> 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00.
13-Aug-2018 00:07:19.239 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNetworkMeshMonitor ] - Stopping mesh update task
13-Aug-2018 00:07:19.251 [DEBUG] [g.zigbee.internal.ZigBeeNetworkStateSerializerImpl] - Saving ZigBee network state: Start.
13-Aug-2018 00:07:19.258 [DEBUG] [g.zigbee.internal.ZigBeeNetworkStateSerializerImpl] - Saving ZigBee network state: Done.
13-Aug-2018 00:07:19.259 [DEBUG] [artsystems.zigbee.internal.ZigBeeNetworkDiscoverer] - Network discovery task shutdown

especially the line zigbee_initialise >> false. is confusing me.