ZIGBEE Binding installation throws error in log but doesn't stop

Hi there,

Platform: udoo neo (raspberry alike)
openhab2 2.4.0 (I know, not most recent, but it was just running well)

What I did: I bought a cc2531 based zigbee-dongle because I want to expand to the LIDL and IKEA devices that are roaming around ever so cheaply…
So I started the paperUI and tried to install the ZigBee binding because that just worked fine so far.
The animated activity spinner doesn’t stop spinning and the log shows an error every minute:

2021-02-09 13:23:47.363 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-zigbee’: Error:
Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee/1.1.2
Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee.dongle.ember/1.1.2
Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee.dongle.telegesis/1.1.2
Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee.dongle.xbee/1.1.2
Error downloading mvn:com.zsmartsystems.zigbee/com.zsmartsystems.zigbee.dongle.cc2531/1.1.2
Error downloading mvn:org.openhab.binding/org.openhab.binding.zigbee.ember/2.4.0-SNAPSHOT
Error downloading mvn:org.openhab.binding/org.openhab.binding.zigbee/2.4.0-SNAPSHOT
Error downloading mvn:org.openhab.binding/org.openhab.binding.zigbee.telegesis/2.4.0-SNAPSHOT
Error downloading mvn:org.openhab.binding/org.openhab.binding.zigbee.xbee/2.4.0-SNAPSHOT
Error downloading mvn:org.openhab.binding/org.openhab.binding.zigbee.cc2531/2.4.0-SNAPSHOT

I realize that I might upgrade my openhab instance, probably…
Before I do: How do I stop this failing installation?

Did I forget anything to mention that migth be needed to help?
Please let me know!



I tagged this thread as zigbee but I know the developer will say you need to update because that binding is too old to reliably support. I do know there have been major changed since 2.4

I personally do not use Zigbee but work with that developer primarily with his Z-Wave binding.

EDIT I see you are looking at the 2.4.0 SNAPSHOT repo which has probably been deleted SNAPSHOT versions are usually not needed after Milestones have been released and definitely not needed after the stable version has been released.

SNAPSHOT versions are not designed for general production use and are expected to have breakage.

Thanks for the response!
OK, then, I will do the upgrade.
But as I might not be able to dig deeper into “what-where-how to upgrade”, I’m still interested how to stop the installation attempt so that I get rid of the message every minute (and the load on the system)!


Look for the addons.config file somewhere in the userdata tree. Stop OH and edit the file. That is where OH stores addons data.

Thanks a lot!
Will do!

1 Like

Worked like a charm!
Little follow up question: Would you recommend to skip the 2.5.x upgrade for OH3? I have just noticed its existence and watching the youtube movie from the Virtual Meetup and I have to say it’s looking good!
But is it advisable to already use in “production”?

Many people are already using 3.0.1 in production, I have not yet made the switch though.

1 Like