Zigbee binding stuck after updating to 2.5

Pi3B, OH2.5

After I updated to OH 2.5 my Aqara sensor stopped working. The odd thing is that whenever I click discover items, it always finds the sensor as unknown Zigbee device, even more weird is that when I take out the battery from the device it still finds it and even if I disconnect the C2531 dongle it still shows up. Tried to clear cache, reinstall Zigbee binding neither worked, any suggestion?

The binding caches information about devices to make it quicker to discover them later since the dongle doesn’t remember what devices have joined the network. This is why the binding will discover devices when the battery is removed. Also, the may be found even without this for other reasons since battery devices normally sleep and therefore removing the battery doesn’t change anything and devices will potentially be retained in child tables.

Removing the device from the binding’s cache is possible?

It’s possible, but why do you want to do this? Do you not use it any more?

The binding caches this data for a reason - if you remove it, it will all need to be rediscovered.

Yes, but for some reason the thing is unusable atm, and I though rediscovering might fix my issues, sorry for the missing information.
The thing gives me an error: Node has not completed discovery.

If the node hasn’t been discovered, then this needs to complete. Deleting the information that has already been discovered (if any) will very likely make that a slower situation. You should reset the device and re-include it into the network.

I did reset it, and tried to re-include to the system (which as far as I know means pressing the button while discovering thing in openhab) nothing really had any notable effect.

What are the debug logs showing? If you post them here I will have a look.

Sooo… here is a full log (I disabled the other Zigbee devices if that is any help…)
Here is the log it generates when I press the pairing button on the device:

2019-12-17 10:18:01.598 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX ZCL: ZclHeader [frameType=ENTIRE_PROFILE_COMMAND, manufacturerSpecific=false, direction=SERVER_TO_CLIENT, disableDefaultResponse=true, manufacturerCode=0, sequenceNumber=43, commandId=10]

2019-12-17 10:18:01.600 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Unknown node 55008

2019-12-17 10:18:01.602 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Incoming message from node D6E0 did not translate to command

The device mac adress is: 00158D000423D267

…hope I’m doing it right.

Hey Together,

I have the same Problem after updating to 2.5. I deleted all Sensors, cleaned Cache via (console-cli) and then started to reinitegrate the sensors on PaperUI. There is one Sensor which Always appears even if there is no battery in it and Always shown as offline. The whole Setup was working previour the Update. It is an aquara Magnetic door sensor.
Here the Log:

2019-12-17 22:45:53.175 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - 00158D000444680E: Starting ZigBee device discovery

2019-12-17 22:45:53.178 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 00158D000444680E: Creating ZigBee device zigbee:device with bridge zigbee:coordinator_cc2531:bd5fa652

2019-12-17 22:45:53.182 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zigbee:device:bd5fa652:00158d000444680e’ to inbox.

2019-12-17 22:45:53.185 [home.event.InboxAddedEvent] - Discovery Result with UID ‘zigbee:device:bd5fa652:00158d000444680e’ has been added.

2019-12-17 22:45:53.185 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 00158D000444680E: Node discovery not complete

2019-12-17 22:46:00.052 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 00158D000444680E: Discovery: Starting discovery for existing device

2019-12-17 22:46:05.434 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - 00158D000444680E: Starting ZigBee device discovery

2019-12-17 22:46:05.438 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 00158D000444680E: Creating ZigBee device zigbee:device with bridge zigbee:coordinator_cc2531:bd5fa652

2019-12-17 22:46:05.449 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 00158D000444680E: Node discovery not complete

The Thing is, other sensors the same type which are new to my Network work fine, also Humidity and Temperature sensors from Auara did not Show this behaviour.

is there Andy possibility only to delete this one sensor out of the Cache?

Thanks in Advantage and greetings

Can I just delete the zigbee bindings whole cache? Got only a few things added. Tried to find the cache but I’m clueless how to do it.

Okey…I waited without touching it (left it as added thing), 1-2 day later it was marked as “not present in the network”, I deleted the the thing, re-added to the system and everything works fine now.

Hi Mark,
I´ve deleted the Thing in PaperUI and resetted the device.
After that I cleaned Cache via console-cli.
Then I discovered the divice in PaperUI again and it Works.

Greetings Andy

I was not able to add my Aqara devices, even after I’ve deleted it from Paper UI and started the discovery again.
Please see also my post: