Zigbee binding

Hi,

I’m relatieve new to OpenHAB, I’m testing it now for two months and learned a lot by reading and doing. I hope my question i in the good threat.

I have the zigbee bindingwith a CC2531 setup as a coordinator. In my test setup I have a bulb (LED1733G7), switch (E1743) and motion sensor (E1525)connected. All Ikea Tradfri.

I was hoping the motion sensor would show a “occupancy” channel connected via the zigbee binding. Beside the battery channels I only see a switch that looks dead? I can control my bulb with the switch not by motion.

I’m aware that Ikea designed the motion sensor to be grouped to a bulb (or set off). When I look at the zigbee2mqtt description (https://www.zigbee2mqtt.io/devices/E1525.html) it looks it’s possible to use it as a standalone motion detector.

Is there somebody who knows if it possible to use the Tradfri motion sensor directly connected to OpenHAB?

Regards,

King

  • Platform information:
    • Hardware: Raspberry PI 4 4Gb
    • OS: Raspbian 4.19
    • Java Runtime Environment: openjdk 11.0.3 2019-04-16
    • openHAB version: 2.5.0.M3 Milestone Build

Hi King and great first post! Welcome to the OpenHAB community! I’m not sure if I can help much because I don’t have any Tradfri stuff. One thing to try if you are using paper user interface would be to check if the thing page has a ‘show more’ button. There may be more channels available.
Also, this is a huge old thread (2275 posts!) feel free to start a new thread with your issue

1 Like

I’m not 100% sure without searching around, but I think the tradfri remote uses group addressing which the binding doesn’t currently support. This is something I will likely look at in the near future and we can then revisit this (assuming that is the issue of course :wink: ).

Sorry - reading emails on the phone and I misunderstood this… I think that the motion sensor ought to work - I was thinking about the remote control when I read this earlier…

I think the motion sensor has been tested and it is on the list of devices that people have used in the binding documentation.

Thanks.

Tonight at home I will double check the paper UI. I think there were only four channels, three battery related and one switch.

Thanks for your reply. Searching and reading around I couldn’t find a confirmation the Tradfri motion sensor was working with the zigbee binding (though there are a lot of postings).

I could find some issues,



And some “working” (?) options with the deCONZ binding,



and the earlier mentioned zigbee2mqtt.

As I said earlier, it is listed in the binding documentation, so someone has confirmed that it works.

1 Like

I never got the traadfri motionsensor to work.

1 Like

Do you have old or new trådfri motion sensors?
I have new ones (E1745) and those are not working.
Debug show OnWithTimedOffCommand, but channels are not triggering

[DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - RX CMD: OnWithTimedOffCommand [On/Off: 4991/1 -> 0/1, cluster=0006, TID=0C, onOffControl=1, onTime=1800, offWaitTime=0]
[DEBUG] [transaction.ZigBeeTransactionManager] - notifyTransactionCommand: OnWithTimedOffCommand [On/Off: 4991/1 -> 0/1, cluster=0006, TID=0C, onOffControl=1, onTime=1800, offWaitTime=0]

1 Like

E1745 as well.

Please open an issue on github with this information and I’ll take a look at it in future.

1 Like

I’ve no idea if all E1745 devices are the same, or if they have different firmware, or whatever, so it’s kind of hard to know why your device doesn’t work @Kim_Andersen. Really, it’s more useful to provide logs or something so it can be debugged, or at least describe your problem as “I never got the traadfri motionsensor to work” as a description of the problem is unfortunately difficult to work with.

@Vaalar thanks for the very useful information - I’ve now created a PR to hopefully resolve your issue. This will probably be merged early next week.

I know Chris… I just havnt had time to deal with it.
Zigbee has been one of those issues I have spend quite alot of time on, and the result has not been that positive at all. Infact it seems like I´m getting nowhere. (Same symptoms every the time with all my devices stop working after a while, not matter which coordinator I use or which openhab/binding/lib, (I got two different coordinators and two openhab systems running. Same result on both)).

My test with the traadfri motion sensor was a one time (well tried scanning a few times) simple try. When scanning could not find the device, I simply left it. Cause thats an issue I have no influence with, since there are no settings I can change or do anything about. The result left me exactly where all my Zigbee testing and time spending has has left me - I´m getting nowhere.

I will get to it again sooner or later, but atm Zigbee has been abandon. Maybe when I upgrade my second testing system to M3 Milestone, perhaps this weekend, I will give it another try.

@chris
Here you have a debug log when I try to add the Traadfri Motion Sensor.
Zigbee.rar.txt (108.6 KB)

And this is Screendump from PaperUI.

This is the result every time… I dont even know for sure, that this is the Traadfri sensor. But it´s the only device missing.
System running openhab 2.5.0 M3 (just upgraded an hour ago).

Btw… Got my devices up running again, but the Trust sensor didnt survive a battery exchange. It was running fine before the battery exchange… Binding says its Online, but no respons. Maybe you can see something regarding this as well… It´s ID is: 00158d00019533d3

EDIT - Forgot to mention. Binding says Osram plug is online as well. But it´s not even powered atm.

Thanks - I’ll take a look at the log. If possible in future can you not use RAR, and also not name the file TXT as it’s a real pain for me to process. Thanks.

So log doesn’t show any responses from the device at all - this is why it’s not being discovered properly. This is clearly a totally different issue than the other issue discussed above and I’m not sure what the device is doing.

Looking further at the log, it seems the device was already joined before the binding started since the binding had already tried communicating with it. Given it’s a battery device, it is likely sleeping and this might explain why the devie isn’t responding.

I´m not sure I understand. The forum will not let me upload an RAR file. Thats why I rename it to rar.txt. For processing you should just remove the .txt.

Could be a faulty device. I havn´t got a Traadfri hub, so I cant test it elsewhere, (not sure the Hue hub will work).

Its a very very deep sleep then. I´ve even tried yelling at it :laughing:
The sensor is the Trust motion sensor! It´s useless for motion detecting if it cant wake up.

openHAB wants to avoid people uploading large files, hence the restrictions. The best solution is to use a server like dropbox.

Ok, I was confused as I thought we were looking at the Tradfri sensor?

Not really - you only need to wake it up to talk to it. That doesn’t prevent it working as a sensor.

Hmm okay then.

I mentioned the Trust sensor as well (stopped responding after battery change).

It´s in a very deep sleep for sure. I have yelled, as well as throwing my arms in the air several time. It´s pointless for beeing a motion sensor. Binding still says its online, (as usual).

Well, you said -: