Zigbee binding

zigbee
beginners
Tags: #<Tag:0x00007fd322030a00> #<Tag:0x00007fd3220303c0>

(Chris Jackson) #984

For what reason? I don’t really want to make “everything” configurable if it’s not needed. At the moment, the device should report immediately if there are changes, so I’m not sure that it’s a good idea to increase this as it will cause some level of congestion.

Polling is supported already. It will use a high rate if reporting is not used, but if reporting is used, it’s a longer rate (I forget the numbers now).


(Weakfl) #985

Because my devices are not reporting any changes. Neither on/off, nor level changes (see #49).

How can reporting be disabled (ideally per device)?


(Chris Jackson) #986

So they dont report change, but they will report on no change? I recall (vaguely!) the discussion in the past but don’t remember the detail.

At the moment it can’t be disabled. Reporting is the standard way to get updates from a device, so in general it shouldn’t be disabled. I understand here that there might be a device that is non compliant, but until #169 is merged, there’s no way to define things outside of the discovery, and at the moment, you can’t configure this sort of thing directly.

I’m generally of the mind to avoid adding too much configuration as it can easily get out of control and things can get misused which can cause problems. That said, reporting and polling probably could be added at some point, but it’s not high on the list at the moment…


(Weakfl) #987

They do send reports based on the default interval, but not if on/off or level is changed with the wall-mounted switch.

I understand there are more important things atm and I mainly brought this up because I wasn’t aware that the reporting interval had been changed. It was less of a problem when the interval was still 10 minutes.

I’ll wait for #169 and raise the issue with BJ (again). They should be the ones fixing this, but I don’t have much hope they will tbh.


(Sean Morrison) #988

Hoping to get a little help with this:
cc-tool installed and I’m pretty sure working:

sudo /usr/local/bin/cc-tool -t
  Programmer: SmartRF04EB
  Target: CC2531
  Device info: 
   Name: SmartRF04EB
   Debugger ID: 0050
   Version: 0x0400
   Revision: 0x0047

  Target info: 
   Name: CC2531
   Revision: 0x24
   Internal ID: 0xB5
   ID: 0x2531
   Flash size: 256 KB
   Flash page size: 2
   RAM size: 8 KB
   Lock data size: 16 B

I downloaded the linux gateway files from TI, grabbed the binary and on trying to flash it I get this:

sudo /usr/local/bin/cc-tool -log install.log -e -w /home/gundark/Z-Stack_Linux_Gateway-1.0.1-src/Firmware/CC2531-GW-ZNP_38724.hex 
  Programmer: SmartRF04EB
  Target: CC2531
  Error reading lock data: unknown lock qualifyer: og

I’ve done some googleing but nothing comes up related to the CC-tool, the results are really nothing to do with this hardware. Anyone got any ideas?

NOTE: Part of what messed me up was using the linux gateway software from TI, make sure to use the hex file described on the openhab zigbee binding page.


(Sean Morrison) #989

I don’t know what I did that worked, however in case someone else runs into this here’s how it just happened to work:

Plugged the TI-Stick into a usb port while attached to the debugger (only had the debugger at first).
Unplugged the debugger and plugged back in. Then:

cc-tool -e -w /home/gundark/Z-Stack_Linux_Gateway-1.0.1-src/Firmware/CC2531-GW-ZNP_38724.hex 
  Programmer: SmartRF04EB
  Target: CC2531
  Erasing flash...
  Completed       
  Writing flash (242 KB)...
  Completed (8.48 s.)

Hope this helps someone else.


(Sean Morrison) #990

So In the paperui I don’t have the choice of using the port /dev/ttyACM1 which is where my CC2531 is, I don’t know where to go from here?


(Sean Morrison) #991

So I manually edit the json file and at least got the binding looking in the right place, now I get this error:

'zigbee:coordinator_cc2531:8ea88567' changed from UNINITIALIZED to INITIALIZING
16:06:32.732 [DEBUG] [andler.ZigBeeCoordinatorCC2531Handler] - Initializing ZigBee ZNP serial bridge handler.
16:06:32.732 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Initializing ZigBee network [zigbee:coordinator_cc2531:8ea88567].
16:06:32.734 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Channel -1
16:06:32.734 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - PANID 2825
16:06:32.734 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - EPANID 1BD612D527B1F94D
16:06:32.735 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
16:06:32.737 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key String 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
16:06:32.737 [DEBUG] [ocol.serial.MySensorsSerialConnection] - Successfully connected to serial port.
16:06:32.737 [DEBUG] [ocol.serial.MySensorsSerialConnection] - Waiting 3 seconds to allow correct reset trigger on serial connection opening
16:06:32.747 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key initialised CF822F317ED86089C09D2FA62ED97D57
16:06:32.748 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key final array CF822F317ED86089C09D2FA62ED97D57
16:06:32.758 [DEBUG] [andler.ZigBeeCoordinatorCC2531Handler] - ZigBee Coordinator ZNP opening Port:'/dev/ttyACM1' PAN:b09, Channel:-1
16:06:32.773 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zigbee:coordinator_cc2531:8ea88567' changed from INITIALIZING to UNKNOWN
16:06:32.775 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Scheduling ZigBee start
16:06:33.786 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - ZigBee network starting
16:06:33.787 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Initialising ZigBee coordinator
16:06:33.803 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key initialise CF822F317ED86089C09D2FA62ED97D57
16:06:33.809 [DEBUG] [ee.dongle.cc2531.ZigBeeDongleTiCc2531] - CC2531 transport initialize
16:06:33.811 [DEBUG] [ding.zigbee.internal.ZigBeeSerialPort] - Connecting to serial port [/dev/ttyACM1] at 115200 baud, flow control FLOWCONTROL_OUT_NONE.
16:06:33.815 [ERROR] [ding.zigbee.internal.ZigBeeSerialPort] - Serial Error: Port /dev/ttyACM1 does not exist
16:06:33.816 [ERROR] [e.cc2531.network.ZigBeeNetworkManager] - Failed to open the dongle.
16:06:33.818 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zigbee:coordinator_cc2531:8ea88567' changed from UNKNOWN to OFFLINE: Failed to initialize ZigBee transport layer


(Sean Morrison) #992

Okay, I know I am blowing up this thread, however:

sudo adduser openhab tty

fixed, binding up and running!

@chris So I want to use these Halo smoke detectors (https://halosmartlabs.com/) Is there anything (like say purchasing one for you) or providing logs or something to have them added (Like its really that easy :slight_smile:) ?
And as always thank you so much for all the work you do here!


(Chris Jackson) #993

Working from logs can work most of the time - it’s normally a bit slow and requires some trial and error, so not very nice. Getting hands on equipment is always a lot easier, but from what I can tell this is a 120v unit and as I’m in the UK, it’s a bit more difficult to manage. If it can be tested with batteries, and you’re happy to send one then it would certainly be easier.

(actually, I just checked Amazon and I can get a 120v adaptor for not too much, so if you can send one, it is by far the most likely to succeed).


(Sean Morrison) #994

I think I would like to send you one, getting the best shot at getting all the functions working would be fantastic. And sense its the solution my friend (who is paying for allot of my system so that I will make his house all fancy) wants, and hopefully benefit the community as well, it sounds like a win all around. Let me know where to send it to and I will get started on figuring out the details.


(Andrew S) #995

Hey Chris, first off, thank you for all your work on the Zigbee and Zwave bindings. I am 4 months new to OH and I know nothing of coding so bear with me. I have been following this thread closely and learning as much as possible and I come to you with an issue that I dont think has been raised before.

I am running Snapshot version of openhab on Windows and installed the binding in paper UI. I have installed the HUSBZB-1 stick in which I intended to use both Z Wave and Zigbee radios.

The issue: With both bindings installed, I configured 13 Zigbee devices and for over a week, had no issue with performance or stability. The moment I configure the zwave part of the stick, the zigbee binding goes haywire. Either devices wont come online, or, they come online but do not respond to any commands. This also happens when configuring the zwave first and then zigbee. I have tested on 2 different windows machines and two different sticks with similar or same outcome. I’ve enabled debug on the zigbee binding and the log it created within the first few minuted was 2500 lines. I have posted it in pastebin. Let me know if more info is needed.

https://pastebin.com/BMhTTfwY


(Ole Kristian Lona) #996

Hello again!

I am still hoping to optimize my solution by using remote controls. As mentioned before, my Philips Hue remote now works, but the only channel I see is the ON/OFF, so no dimmer channel.

I have tried to add my Ikea Trådfri remote (https://www.ikea.com/no/no/catalog/products/30338849/), but the discovery seems to never complete. ZigBee sees that I add the remote, but before discovery is finished, the device is marked “Offline”.

Are there any ways for us “mere mortals” to debug the discovery process, so we can provide useful information in order to have these things resolved?


(Chris Jackson) #997

I am looking at trying to get these remote controls to work, but it requires some changes to the low level libraries. It is something I’m working on, but at the moment isn’t top priority.


(Ole Kristian Lona) #998

Ok, thanks, Chris! Is this the same for the dimmer function on the Hue remote as well?


(Chris Jackson) #999

Yes. I spent some time looking at this a week or so back. I have some things to try, but it needs some changes to the low level libraries and then some thoughts on how best to integrate that into the library.

While this isn’t exactly top priority, it is “on the radar” as it’s something I’d like to better understand…


(Ole Kristian Lona) #1000

Perfect, thanks! Sounds like you know fairly well why it isn’t working. As I have the Hue on/off working, and also Alexa location/context awareness working now, I am also not in any kind of rush :slight_smile:


(Elelabs Maintainer) #1001

Hello guys,

We have created 2 new products, compatible with OpenHAB ZigBee bindings:

Both of them are compatible and tested with latest OpenHAB and latest Z-Wave Binding.
We have also prepared User Guides on how to set them up.
Hope you find them useful.


(Scott Rushworth) #1002

@chris, with the multiple bindings, what is the proper way to restart just Zigbee? When I restart just the OH Zigbee binding, the coordinator doesn’t come back online.


(dj1) #1003

Sorry, I am trying to enable the new snapshot building, but it fails… is there a correct way to enable those? Can anyone ( Chris? ) publish the correct steps and download location
the kar definitely not working…