Zigbee binding

zigbee
beginners
Tags: #<Tag:0x00007f01456263d8> #<Tag:0x00007f0145626270>

(Pedro Garcia) #1586

Hi @chris,

I just opened an issue (and sent the corresponding PR) in github to add the static thing definition xml and update discovery.txt file for the “Xiaomi Aqara Sensor HT” devices. These are the round devices with only temperature and humidity sensors (not the square ones, which correctly report their clusters and also have a barometric sensor)

Of course, this is tied to your commit for static thing definitions.

BTW, I closed the issue accidentally and reopened it again, so it looks as “closed” in the link, but it is not :slight_smile:

Best Regards,
Pedro


(Scott Rushworth) #1587

@chris, I don’t see an option for it yet… where does Ember coordinator insecure rejoin fall in your backlog? And if you have a stop over in CLE, let me know so I can buy you beer!


(Chris Jackson) #1588

I think this is added to the library (I’ll double check though), and I need to flow this through into the binding (which I’ll look at this weekend hopefully). Once that’s in, then I can add this option to the binding.

I’ve got a direct flight (delayed!) from Austin to London, otherwise that beer would have been good.


(stephan) #1589

Hi Chris,
did you make any changes with the things linked to items?
Since tonight I see all things as before as well as the items, but if I use PaperUI and click on the things, the linked items are not shown any more. I also do not have any objects in the control area of PaperUI.
The same happens in HABmin.
I can’t control the (ubisys) switches and dimmers any more through openhab (zigbee).
Rebooting doesn’t help. All things are reconnected without problems afterwards.
Has anyone else the same problem?


(Chris Jackson) #1590

When you say the items are not showing - how bout the channels? Are the channels showing, and the problem is just with the lined items? If so, this is probably not a binding issue as the binding knows nothing of the items and the links.


(Berry) #1591

Thanks Scott for the example. The behaviour is not exactly how I would like it to be. When the switch is set to ON it should set the level to the last level before it was switched off. Now the switch is setting the level to 100%. Although the level_control channel is not stricktly needed it was kind of handy to prevent a lot of additional coding…

How are others using the dimmer control using the zigbee binding?


(Chris Jackson) #1592

I’ve created a PR for this -:


(stephan) #1593

sorry, I forgot that. The channels are NOT showing.
After clicking on the thing I only see the following:


(Chris Jackson) #1594

I’ve raised an issue on this -:


(Tobias) #1595

Same problem here. Just installed new OpenHAB on a Pi 3B+, Elelabs USB Zigbee adapter. Things can be created, but show no channels…


(Chris Jackson) #1596

I’ve raised an issue on this already -:

https://github.com/openhab/org.openhab.binding.zigbee/issues/320


(Pedro Garcia) #1597

Hi @chris,

I have had a quick look, and provided a PR that fixes the issue (comments in Issue #320)

If the fix implementation approach in the PR is not the right one, at least will point in the right direction.

BTW, this fix seems to be working for me, and channel consolidation is also happening correctly with it.

Pedro


(Chris Jackson) #1598

Thanks - I saw. I’ll take a look when I get a chance - maybe tomorrow, or maybe Tuesday. Or Thomas might otherwise take a look when he gets into the office tomorrow.


(alex) #1599

Hello,

i’m trying since weeks to get an CC2531 dongle to work. But the status in OH is always just on “unknown”

i have flashed the dongle with the “CC2531ZNP-Pro-Secure_LinkKeyJoin.hex” file.
I have edited the openhab configuration with
EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0"

when i add the device , i set the port to /dev/ttyACM0 and the boud rate to 115200

when i add the device, i get the following log:

05-Dez-2018 23:40:33.714 [DEBUG] [ab.binding.zigbee.discovery.ZigBeeDiscoveryService] - Creating ZigBee discovery service for zigbee:coordinator_cc2531:a714652a
05-Dez-2018 23:40:33.718 [DEBUG] [ab.binding.zigbee.discovery.ZigBeeDiscoveryService] - Activating ZigBee discovery service for zigbee:coordinator_cc2531:a714652a
05-Dez-2018 23:40:33.723 [DEBUG] [org.openhab.binding.zigbee.cc2531                 ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.DiscoveryService}={service.id=420, service.bund
leid=273, service.scope=singleton} - org.openhab.binding.zigbee.cc2531
05-Dez-2018 23:40:33.844 [DEBUG] [penhab.binding.zigbee.cc2531.handler.CC2531Handler] - Initializing ZigBee CC2531 serial bridge handler.
05-Dez-2018 23:40:33.846 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Initializing ZigBee network [zigbee:coordinator_cc2531:a714652a].
05-Dez-2018 23:40:33.848 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Channel -1
05-Dez-2018 23:40:33.849 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - PANID 0
05-Dez-2018 23:40:33.851 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - EPANID 0000000000000000
05-Dez-2018 23:40:33.852 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Key 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
05-Dez-2018 23:40:33.853 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Initialising network
05-Dez-2018 23:40:33.854 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Created random ZigBee PAN ID [9D17].
05-Dez-2018 23:40:33.860 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Created random ZigBee extended PAN ID [770C6DEB1A5DCDC2].
05-Dez-2018 23:40:33.867 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Key String 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
05-Dez-2018 23:40:33.869 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Key initialised 1CF2662705E75E034760EDA22803803F
05-Dez-2018 23:40:33.872 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Key final array 1CF2662705E75E034760EDA22803803F
05-Dez-2018 23:40:33.874 [DEBUG] [penhab.binding.zigbee.cc2531.handler.CC2531Handler] - ZigBee CC2531 Coordinator opening Port:'/dev/ttyACM0' PAN:9d17, EPAN:770C6DEB1A5DCDC2, Channel:-1
05-Dez-2018 23:40:33.875 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Scheduling ZigBee start
05-Dez-2018 23:40:34.877 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - ZigBee network starting
05-Dez-2018 23:40:34.878 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Initialising ZigBee coordinator
05-Dez-2018 23:40:34.891 [DEBUG] [ab.binding.zigbee.handler.ZigBeeCoordinatorHandler] - Key initialise 1CF2662705E75E034760EDA22803803F
05-Dez-2018 23:40:34.894 [DEBUG] [tsystems.zigbee.dongle.cc2531.ZigBeeDongleTiCc2531] - CC2531 transport initialize
05-Dez-2018 23:40:34.896 [DEBUG] [rg.openhab.binding.zigbee.handler.ZigBeeSerialPort] - Connecting to serial port [/dev/ttyACM0] at 115200 baud, flow control FLOWCONTROL_OUT_RTSCTS.
05-Dez-2018 23:40:34.907 [DEBUG] [rg.openhab.binding.zigbee.handler.ZigBeeSerialPort] - Serial port [/dev/ttyACM0] is initialized.
05-Dez-2018 23:40:34.908 [DEBUG] [ee.dongle.cc2531.network.impl.CommandInterfaceImpl] - ->  SYS_RESET (Packet: subsystem=null, length=1, apiId=41 00, data=FE 01 41 00 01 41, checksum=41, error=false)
05-Dez-2018 23:40:39.910 [WARN ] [.zigbee.dongle.cc2531.network.ZigBeeNetworkManager] - Dongle reset failed. Assuming bootloader is running and sending magic byte 0xef.
05-Dez-2018 23:40:44.914 [WARN ] [.zigbee.dongle.cc2531.network.ZigBeeNetworkManager] - Attempt to get out from bootloader failed.
05-Dez-2018 23:40:44.976 [DEBUG] [rg.openhab.binding.zigbee.handler.ZigBeeSerialPort] - Serial port '/dev/ttyACM0' closed.

what is going wrong??


(Chris Jackson) #1600

It looks like the dongle is not responding. Maybe it has the wrong firmware programmed, or it had a problem with the programming. It’s hard to say much more though - sorry.


(alex) #1601

i guess the problematic line in the log is:
Dongle reset failed. Assuming bootloader is running and sending magic byte 0xef.

or i’m wrong?


(Chris Jackson) #1602

No - you are correct. The binding has tried to communicate with the dongle, but it has not received the response. It has tried to exit from bootloader, but it still isn’t receiving the response.


(Scott Karns) #1603

Hi, @alex_knx. You haven’t provided any details of the OH system you are running.

  • What version of OH?
  • What type of hardware is OH running on?

There have been a number of improvements @chris as made to the Zigbee binding over the past year, most of which are only present in the 2.4.0 version of OH. On my production system, an RPi3B with a CC2531 Zigbee coordinator, I am currently running openHAB 2.4.0~S1445-1 and the Zigbee binding has been working reliably for me.

With much earlier versions of the Zigbee binding I did have the problem you describe. I sometimes could eliminate the Dongle reset failed. Assuming bootloader is running and sending magic byte 0xef error by stopping the zigbee binding, unplugging the coordinator, replugging the coordinator and finally, restarting the zigbee binding. This may (or not) work for you, but this symptom indicates to me that you are probably not running the most recent release of this binding.


(zolakk) #1604

Doesn’t the baud rate need to be 57600 instead of 115200? I know that’s how I had mine set up when I was still running a CC2531 and also how the Elelabs dongle I bought to replace it needs to be set as well.


(Chris Jackson) #1605

Mine is definately 115200.

The Elelabs dongle uses a Silabs chipset - it is completely different.