Zigbee device stopped working after update from 2.3 to 2.4

I have a HUSBZB-1 Ember stick. I was running OH2.3 and when I came back from a trip, my Zigbee lights would not be controllable anymore. I tried a few things but gave up as I had no time to look into it.

Today, I had finally some time and I rebooted the NIC on which OpenHab runs. Suddenly things were working again. However, I noticed it said I was running OH2.3 and since 2.4 is available, I ran an update with apt (The NIC runs Linux Ubuntu).
After the update, I have again lost control of my Zigbee lights.

The ZWave things were also not working. I did find a thread for the beta of ZWave 2.4 and followed the instructions in there: removing them and reinstalling them fixed the issue.
Following some instructions there, I removed the ZWave binding using Paper UI and re-installed it. I thought that doing the same for the Zigbee binding might help as well but to no avail.

Is there something new I need to to be aware of with the latest Zigbee bindings? @chris you may want to see some logs, though I am not sure what to do to give you more info. So far I can see on the events log, whenever I try to turn on a light, two lines appear:

2019-05-26 13:05:07.605 [ome.event.ItemCommandEvent] - Item ‘LRoom_Stand_light’ received command 85
2019-05-26 13:05:07.608 [nt.ItemStatePredictedEvent] - LRoom_Stand_light predicted to become NULL

Well, 2.4 has seen a lot of improvements, but it’s quite old now (6 months) and I’d recommend using a newer version.

Yes - it’s hard to say anything without seeing the debug logs :wink:

I turned on the logs following the Karaf directions in the zigbee binding help page . The events log does not get anything new. The openhab log has something maybe more useful. The here is the log I got after a minute or so.

There’s not a lot in the logs so I can’t really say what is happening. There is some data being sent and received, but it’s really short so .

I’d suggest to use the latest binding for starters…

The events log is never any use for debugging - everything of use is in the debug log…

@Chris 2.4 is the latest stable version. Are you suggesting I should switch to 2.5.0.M1?
I dread any upgrade of this kind because it always seems to leave me struggling for a few hours to get everything back working :crazy_face:
However, at the end there’s some day when I have to do it. Some of the new features (In particular HABot) are of interest to me. So I guess I can do it…

PS: didn’t uninstalling the Zigbee bindings and re-installing them give me the latest binding? Or they only go into 2.5.xxx ?

Yes - or even something newer.

See this script for updates -:

No - if you have 2.4 installed, then you will always install the same version.

Mystery solved.
I installed 2.5.0.M1 but that’s not what fixed the issue.
When opening in the Paper UI the details of one of the lightbulb, it showed that the channel was not matching any of the items. It seems channels have been renamed. My Zigbee lightbulbs had entries of the type:


Renaming them to:


Gets them back working.
Thanks @chris, always appreciate you work!