Zigbee Devices Going Offline

Tags: #<Tag:0x00007efebf026da8>

That’s interesting. I thought it was a dongle issue. Other than the Aquara temp sensors which gives no response, found out that they work just fine connecting to the dongle directly and not part of a hop. The switches still work and responsive but shows offline…

So the channel I have my Zigbee is set to has no interference. I did a wifi scan and moved everything over to a different channel so make sure there were no overlap.

To get everything back online in PaperUI, I do a zigbee scan from inbox and just reset the devices. I don’t bother with removing the item.

I will reset all my zigbee devices so they are all working, then set my log to debug and attach it.

I appreciate you have had continued issues, and I don’t know why - I’m sorry I’ve not been able to help. This binding and libraries are used commercially by a number of companies - most of which I can’t mention, but I think it’s clear that Qivicon / DT are using this since they were helping with the development for quite some time. It’s just a shame that we’ve never got your system working, but thousands of other systems out there work very well.

Ok, here’s the debug log. Please download the zip file from here. The log is to big to place it here (only because of zigbee entries for one hour - hopefully this is ok for you).

I restarted openhab at the beginning and left it alone for about one hour. This is what i was presented in paperui, when i came back:

001788010337dd9f is really offline (no power intentionally). The others work as required even though shown as offline.

Just had a look at the online logviewer:
at ~18:14 there is “at system start rule” running
near the end 7cb03eaa00acebf6 has been switched by hardwareswitch

So this all looks “ok” to me. By this, I mean it is working as it is designed - there are no reports during this period (30 minutes) so the device is set to OFFLINE. This is how it is meant to work.

The question is why there is no reporting. A device should be configured to report every 15 minute in theory. This log does show the startup of the binding so I can confirm that this is what is happening (see below), and the binding sets the device OFFLINE if it doesn’t send 2 reports, so this all looks correct.

So everything is working correctly, but the device is not sending the reports that are expected.

Maybe I’ll look at changing the logic to send a poll after the reporting period to give it a last chance to stay ONLINE.

Ok, i understand. Thanks for taking your time.

What i changed lately was the setup of the telegesis (19200 to 56700), while investigating these problems. This has been at about the same time i updated openhab and realized what we are writing about here.

My openhab needs some maintenance, some sort of backup/restore and i just received an ups for my rpi. When i implemented these topics, i’ll give an other zigbee controler a chance i think.

I’ve changed the way this works now - after the ONLINE timer times out, it will attempt to poll the device. If there has still not been an update 30 seconds later, then it will set the device OFFLINE.

This should prevent the issue we see here where the device is not reporting for some reason. Please let me know if it helps.


I know you have tried Chris… And I know others out there are using Zigbee without any hassle. That just makes this (my problem) much more strange. Remember, I have been trying for a coupple of years now, with several different openhab setups and two different Zigbee coordinators. The only thing I can think of is some external devices which is messing things up. I have no idea how this should be possible, but I really doubt its a openhab core/dongle issue anymore. For the last year, my Odroid C2 has been used to test Zigbee only, except for running Velbus server. Thats all there is install on that openhab setup.

As for external devices, I´ve got two. One is my Philips Hue brigde and then a Xiaomi hub (v2). They both communicate “almost” the same 2.4ghz , but they havnt got any issue at all.

One of the latest Zigbee binding and lib released wouldnt even connect to my Philps Hue devices. They usually were the devices which only gave problems in the long run. A big surpise was, that I was able to add a Xiaomi motion sensor. This has always failed. But now its the only device running after weeks, and its still running. The rest eventually stopped responding, and after a while went offline, just as they used to, (beside the Hue devices wouldnt even connect).

I really have no idea whats going on… But I have to be honest with you, I doubt I´m the only one with this issue. As you can tell from this thread, there are a few more out there with the same experience… Maybe I have just been more patient than others, how may have given up insted.

I’m late to this party, so you may have already tried this: I’m using a USB CC2531 dongle on a Raspberry Pi 3B+. I’m using zigbee2mqtt rather than the Zigbee binding. I’d find that my device (yeah, I’ve only got one!) would go offline randomly, and the thing that seems to have fixed it is putting the dongle on a USB extender, and then plugging that extender into the Pi - i.e. moving the dongle away from the Pi.

Hmm, so you believe the Rpi is causing the mess? Might be worth a try for sure.

I don’t believe much, to be honest! Could all just be coincidence. See if it works - at least it’s cheap!

This is quite a common problem - we see this a lot with ZWave issues as well where people need to use a powered USB hub with the RPi to get it working reliably.

My first Zigbee coordinator is a Elelabs Zigbee shield which is connected to the PIO of the Rpi.
The other one is the “357 long range” (dont recall its name. Its the one I bought from you for sniffing long time ago). Its connected directly the USB port of my Odroid C2 atm.
My Zwave dongle is connected directly to my main Rpi 3B+. Never had an issue with that.

Anyway - I will ofcouse give it a try soon… I need to reorganize some stuff first to release my active USB hub from “duty”.

I am running mine in a USB 2.0 hub that is connected to a PC connected to USB 2.0 port in computer so I can keep the interference down. USB 3.0 does interfere with 2.4ghz, for example, mini keyboard and wifi dongle, radios connected directly but that can be resolved by just using a small extension cable.

My Aquara temperature sensors drops off constantly, but after reading a lot of threads here I found out it does not like hops, it works great when it is directly connected to coordinator. So I am not too worried about this as of now.

Currently, I reset all my Zwave devices so it shows Online,cleared logs and set Zigbee log to debug so hopefully I can capture relevant information.

After quite a while of not changing anything I updated openHAB to 2.5.7 yesterday. The situation looking at zigbee devices after updating stays the same: when openHAB was restarted, all things were online. Today the usual supects are shown as offline again.
I’ll check, if resetting the things changes the behavior and stay online reliably as they should again.

Please provide a log so I can take a look. If the device doesn’t respond to the poll, then the code I added obviously will not have helped.

I generated a log today. Things have been “online” today when i started the log, because i restarted openHAB yesterday. After starting the log, i did some status changes for every device. Some minutes later the things are marked as “Offline” in paperui.

2020-07-27 zigbee.log (640.6 KB)

I don’t think the last change you applied helped to get rid off this issue.
Next i’m going to reset the things.

If i weren’t exactly the same 5 of 6 things, i would suspect an other potential source of problems: i run a raspi with z-wave circuit board, rfxcom and zigbee Telegesis near a wlan repeater. I’ll move the repeater because of some strange behaviour of my repeater-connecting wlan devices. If this has any effect, i’ll tell you here.

Can you talk me through what this log shows? It’s pretty short, and I don’t see any devices going OFFLINE. That said, I don’t see any logging other than from the ZigBee binding, so maybe this is filtering out stuff that I’d need to see to understand what is happening?

Can you at least please tell me exactly what time the device went OFFLINE?

From what I can tell from the code that tracks the state, there were no devices that triggered the transition to OFFLINE here either, so I’m a bit confused what is being shown?

I spent some more time looking through the log, and really don’t see any problems. All commands seem to be acknowledged and states updated, and this is all pretty fast. There’s no sign of anything going OFFLINE…

I’d really need to know what is happening, or to have a more detailed log that shows the wider view of what is happening in OH.

I’ll attach the events.log, so you can have a look what happend.
2020-07-27 events.log (7.0 KB)

13:34:58.967 switch on power HDi_Wz_Decke3_Dim for device Lam_Wz_Decke3_1*
13:35:33.139 state changes of Lam_Wz_Decke3_1* (Decke1_1 is a typo in items file) 001788010337DD9F
13:36:12.360 state changes of Lam_Wz_Tisch_Dim 00178801045965bb
13:36:22.660 state changes of Lam_Wz_Schrank_EA 7cb03eaa00ad44c7
13:36:36.375 state changes of am_Ku_SchrankRe_EA 7cb03eaa00acebf6
13:36:56.597 state changes of Lam_Sz_BettLi_Farb ccccccfffebb12f0
13:37:13.798 state changes of Lam_Sz_BettRe_Farb ec1bbdfffe271435

I did not filter anything. zigbee log settings:

log:set debug org.openhab.binding.zigbee
log:set debug com.zsmartsystems.zigbee
log:set info com.zsmartsystems.zigbee.dongle.ember.internal.ash

The log does not show anything but what is shown below for some minutes after the version i attached above.

2020-07-27 13:37:21.507 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis queue: 1
2020-07-27 13:37:21.508 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis: TelegesisDisplayNetworkInformationCommand [device=null, channel=null, power=null, panId=null, epanId=null]
2020-07-27 13:37:21.511 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis Data:AT+N?

2020-07-27 13:37:21.525 [DEBUG] [gesis.internal.TelegesisFrameHandler] - RX Telegesis Data:+N=COO,11,-07,A65E,665871B3A8F70766
2020-07-27 13:37:21.527 [DEBUG] [gesis.internal.TelegesisFrameHandler] - RX Telegesis Data:OK
2020-07-27 13:37:21.529 [DEBUG] [gesis.internal.TelegesisFrameHandler] - RX Telegesis: TelegesisDisplayNetworkInformationCommand [device=COO, channel=11, power=-7, panId=42590, epanId=665871B3A8F70766, status=SUCCESS]

I can’t tell when the devices went offline exactly. I just realized, that they were shown “OFFLINE” in paperui after doing the actions shown in events.log.

I had to restart openHAB some minutes ago now, so all zigebee devices are shown online again until tomorrow(?).