Zigbee devices offline/don't work after reboot on pi running OH2

I’m using the Ember USB stick and have successfully added, and had working, the following zigbee devices:
SmartThings Motion (model motionv4 and motionv5)
SmartThings Contact Sensor (model multiv4)
SmartThings Outlet (model 4257050-RZHAC)
Sengled Bulbs (model E11-G13)

At one point I had 3 of my 5 motion sensors, the Contact sensor and the Sengled bulb all working with a mysql persistence. The problem came up (again) last night when I tried to get the final 2 motion sensors working. I rebooted the pi and then all of the devices were Offline.

There are no problems when initially adding the items - they all work as expected. The problem comes when the openhab hub is restarted. Most of the time when it comes back the devices will say Offline. Since they are battery operated I try pushing the button to wake them up, but that never works. On the light I will turn it off and on but doesn’t work.

I feel like I have tried every combination of deleting and then adding back through Paper UI. Sometimes this works and other times it doesn’t. Earlier today I deleted all of the things, since they all showed as offline, and added them back in Paper UI. Now 2 of the 5 motion sensors are working again and the rest show up Online but don’t detect motion. Some of these will show the battery level and temp but no motion, temp and no battery and no motion… I think you get the picture. I’m pretty confident if I did a reboot right now then everything would come back as Offline.

BTW, sometimes the motion sensors are added back as SmartThings Motionv5 and other times they are added as “Unknown ZigBee Device”.

Just checked the Sengled light and it is showing Online but not working any longer. I can move the slider and the logs will show " Command for channel zigbee:device:213bd675:b0ce1814034b2a34:B0CE1814034B2A34_1_switch_level --> " but the light doesn’t change.

I just added the zigbee logging so I can upload logs if that will help. Sorry if I’m leaving stuff out. I’ve been working almost nonstop on this for the past few days and think I may be losing it a little!

1 Like

Same here, using Openhabian. After I performed an update via option#2 (see picture below), zigbee devices went offline and refuse to come back online despite a power cycle of my raspberry pi (a proper shutdown). The same issue has happened to me on 3 other occasions too. I hate having to delete, reset, and re-add my devices repeatedly. Please help with this issue.

A few hours after posting I felt like I got everything to “work” (as in everything was online but I didn’t have the guts to test actually rebooting the pi). To get things going I deleted all the zigbee devices in Paper UI. Then I paired them in Paper UI and instead of rebooting the pi, I just restarted the openhab2 service using the below command

sudo systemctl restart openhab2.service

After less than 24 hours I started losing some devices (they would say Online but I wasn’t getting any data). Sometimes they would come back after restarting the service but last night everything was showing offline after the restart.

As of now, I have only 1 of my motion sensors working and it’s the one in the same room as the pi. The 2nd most reliable motion sensor is in another room not far away, but the remaining 3 that are somewhat far away in the house and are the most inconsistent.

Right now I’m thinking I need to install a newer version of the Zigbee binding so I’m researching the steps to do that.

Perhaps @chris has some input, too. I would love to know why all of my zigbee devices work perfectly for weeks, then suddenly go offline and stay offline.

I turned off debugging after I got things working. Once I get some devices working again I will turn debugging on and post the logs.

Unfortunately in order to work out what is happening, we probably need to see network sniffer logs - binding debugging probably isn’t going to provide anything useful.

It would be really good if you were able to get some sniffer logs so I can pass these to Silabs to see if we can work out what’s happening.

There is some information on the sniffer setup here -:

1 Like

@chris, until I use the sniffer, does this events log lend a clue?
Failed to startup ZigBee transport layer

2018-09-07 16:25:37.256 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:7df175b7' changed from UNINITIALIZED to INITIALIZING
2018-09-07 16:25:37.326 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:7df175b7' changed from INITIALIZING to UNKNOWN
2018-09-07 16:25:39.873 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:7df175b7' changed from UNKNOWN to OFFLINE: Failed to startup ZigBee transport layer
2018-09-07 16:25:49.086 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:7df175b7' changed from OFFLINE: Failed to startup ZigBee transport layer to ONLINE
2018-09-07 16:25:49.120 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - 000D6F000BCCBF17: Starting ZigBee device discovery
2018-09-07 16:25:49.118 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - 000D6F000BA71767: Starting ZigBee device discovery
2018-09-07 16:25:49.143 [nt.FirmwareStatusInfoEvent] - Firmware status of thing zigbee:coordinator_ember:7df175b7 changed to UNKNOWN.
2018-09-07 16:25:50.387 [me.event.ThingUpdatedEvent] - Thing 'zigbee:coordinator_ember:7df175b7' has been updated.
2018-09-07 16:25:52.425 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - 000D6F000BCCBF17: Starting ZigBee device discovery
2018-09-07 16:25:54.151 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - 000D6F000BA71767: Starting ZigBee device discovery

Also, I’ve tried a restore from a known-good backup from 3 days ago, and I’ve just tried a complete new installation of openhabian (a clean slate), and then restored the same backup file. Both have no improvement, and the zigbee things are offline.

I would expect a restore to be able to resume Zigbee devices, too. Is this a known limitation?

Yep getting the same thing in my logs. When viewing Ember in Paper UI Ember it is still saying Online.

2018-09-07 22:43:46.005 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:213bd675' changed from ONLINE to UNINITIALIZED

2018-09-07 22:43:46.592 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:213bd675' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

2018-09-07 22:45:22.839 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:213bd675' changed from UNINITIALIZED to INITIALIZING

2018-09-07 22:45:22.920 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:213bd675' changed from INITIALIZING to UNKNOWN

2018-09-07 22:45:25.870 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:213bd675' changed from UNKNOWN to OFFLINE: Failed to startup ZigBee transport layer

2018-09-07 22:45:36.119 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:213bd675' changed from OFFLINE: Failed to startup ZigBee transport layer to ONLINE

2018-09-07 22:45:36.251 [nt.FirmwareStatusInfoEvent] - Firmware status of thing zigbee:coordinator_ember:213bd675 changed to UNKNOWN.

2018-09-07 22:45:38.223 [me.event.ThingUpdatedEvent] - Thing 'zigbee:coordinator_ember:213bd675' has been updated.

For devices leaving, no, this won’t help.


This is probably a communications issue with the dongle. Please enable debug logging on the binding as described in the docs and I’ll have a look.

Well, if devices leave the network, as I thought was happening, then it won’t help. If you have a problem with the dongle, then it also won’t help. So it can only restore changes within the binding.

Please enable debug logging so we can see what is happening.

Thanks, Chris. Will do.

In the interim, the only way I was able to get my zigbee devices back online was:

  1. use Habmin to remove all Zigbee devices, including the Zigbee coordinator.
  2. remove all items for these devices (both from the .items file and Habmin).
  3. uninstall the Zigbee binding.
  4. restart the OpenHAB service for good measure.
  5. install the Zigbee binding.
  6. manually install the Zigbee coordinator [and optionally specify the previous hex Thing ID for easier .items file insertion].
  7. reset each Zigbee device one at a time and use Paper UI’s Inbox to discover new Zigbee devices.
  8. finally, create the item (.items file or Paper UI).

:sweat: A bit tiresome, but a workaround for the next time Zigbee fall down go boom.

I pretty much did the same thing. I deleted the zigbee devices in Habmin and added all them back in Paper UI. They are now all up and running and I added debug logging. My only issue now is my mysql persistence isn’t working. Once I get that fixed then I’m not going to touch anything!

I have an update. For the past 8 days everything had been running smoothly. I did almost nothing with the system because I wanted to collect data from the zigbee sensors, which I’m storing in a mysql database. I even accidentally rebooted the pi last night and all of the zigbee devices came back as expected.

But this morning I tried adding a new zigbee motion sensor (the same samsung smart things sensor that I already have running on the system). I was able to discover it but it showed Offline in Paper UI. I then tried deleting and adding it back but I couldn’t get it to work. In addition, all of the zigbee motion sensors stopped collected data as of 7:51

Here are the log entries for the sensor I tried to add.

tail -F /var/log/openhab2/openhab.log /var/log/openhab2/events.log
 2018-09-17 07:17:45.856 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 24FD5B00010C78B4: Discovery notification

2018-09-17 07:17:45.872 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - 24FD5B00010C78B4: Starting ZigBee device discovery

2018-09-17 07:17:45.898 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 24FD5B00010C78B4: Creating ZigBee device zigbee:device with bridge zigbee:coordinator_ember:7d24e207

2018-09-17 07:17:45.910 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zigbee:device:7d24e207:24fd5b00010c78b4' to inbox.

2018-09-17 07:17:45.911 [home.event.InboxAddedEvent] - Discovery Result with UID 'zigbee:device:7d24e207:24fd5b00010c78b4' has been added.

2018-09-17 07:17:45.912 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 24FD5B00010C78B4: Node discovery not complete

2018-09-17 07:37:41.922 [me.event.InboxRemovedEvent] - Discovery Result with UID 'zigbee:device:7d24e207:24fd5b00010c78b4' has been removed.

2018-09-17 07:37:41.988 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 24FD5B00010C78B4: Initializing ZigBee thing handler zigbee:device:7d24e207:24fd5b00010c78b4

2018-09-17 07:37:41.991 [hingStatusInfoChangedEvent] - 'zigbee:device:7d24e207:24fd5b00010c78b4' changed from UNINITIALIZED to INITIALIZING

2018-09-17 07:37:41.993 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 24FD5B00010C78B4: Coordinator status changed to ONLINE.

2018-09-17 07:37:41.995 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 24FD5B00010C78B4: Coordinator is ONLINE. Starting device initialisation.

2018-09-17 07:37:42.000 [hingStatusInfoChangedEvent] - 'zigbee:device:7d24e207:24fd5b00010c78b4' changed from INITIALIZING to OFFLINE

2018-09-17 07:37:47.013 [WARN ] [ome.core.thing.internal.ThingManager] - Initializing handler for thing 'zigbee:device:7d24e207:24fd5b00010c78b4' takes more than 5000ms.

2018-09-17 07:37:47.151 [nt.FirmwareStatusInfoEvent] - Firmware status of thing zigbee:device:7d24e207:24fd5b00010c78b4 changed to UNKNOWN.

2018-09-17 07:53:05.718 [hingStatusInfoChangedEvent] - 'zigbee:device:7d24e207:24fd5b00010c78b4' changed from OFFLINE to REMOVING

2018-09-17 08:02:24.874 [hingStatusInfoChangedEvent] - 'zigbee:device:7d24e207:24fd5b00010c78b4' changed from REMOVING to UNINITIALIZED

2018-09-17 08:02:24.901 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 24FD5B00010C78B4: Handler dispose.

2018-09-17 08:02:29.920 [WARN ] [ome.core.thing.internal.ThingManager] - Disposing handler for thing 'zigbee:device:7d24e207:24fd5b00010c78b4' takes more than 5000ms.

2018-09-17 08:02:30.021 [hingStatusInfoChangedEvent] - 'zigbee:device:7d24e207:24fd5b00010c78b4' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

Here is a full log file from 7:11 am until 8:02 am. Sometime within this time frame the zigbee devices stopped working.


Please let me know if there is some other data needed!

Unfortunately the log doesn’t have any useful information in it. You need to enable debug logging for com.zsmartsystems.zigbee for it to be of any use.

darn! I thought I did enable it but now realize I had a typo. Now, zsmartsystems logging in enabled.

Around 12:37 pm and then at 12:40 pm tried to pair 2 new motion sensors in Paper UI. They didn’t show up so I decided not to push my luck since my other zigbee sensors are up and running just fine.

Here are logs that hopefully will be helpful this time.

Log filtered with zsmart

Log filtered with debug

Entire Log starting at 12:38

Thanks so much for all your help!!

12:37 is before the log starts (which is 12:38) and I don’t see anything in the log showing that a scan was started at 12:40 (or in fact any other time).

Some of the debug messages don’t seem to tie together - what version of the binding are you using?

So I decided to try discovery again and this time I was going to watch for it in the logs and then guess what happens? Both new motion sensors show up right away and are now working just fine.

I installed a system at a friends house yesterday and experienced this same erratic behavior when pairing zigbee devices. I didn’t enable debug logging yesterday so I have nothing to show you. Chris do you think this could be something from openhab in general and not your binding?

I’m using the default version in Paper UI:
binding-zigbee - 2.3.0

I’m open to installing the most recent version. I’m only 2 months into Openhab so I need to figure out how to do that. If you can point me in the right direction I would be very grateful!

The easiest thing is to use the snapshot runtime - depending on what install you’re using, you can normally change the reasonably easy (just check the documentation for your installation).

It’s more difficult to run the snapshot version of the binding with the release runtime, so I wouldn’t recommend that.

Hi again. Everything was running smoothly until around 8:30 am this morning. The last motion detection was at 7:30 am, which makes sense because that is when we left for the day, so I know they were still working at that time. I persist the motion and some of the temperature data and the last temp change for one of the sensors came in at 8:35 am. Data is still being written to the db but the value hasn’t changed all day.

Here is a copy of the log tail that only shows about 10 minutes.

Here are a couple minutes of the openhab log around the time things started failing

Please let me know if you need more log info.


This looks very simular to the problems I experience as well. Zigbee runs for severals days, and suddenly no longer.
I can often force it to “breake” when trying to add a new zigbee device, which doesn´t succeed (such as Xiaomi door/window sensor). After this, I´ll need to reboote my Rpi, and hope things starts working again.
From the log I can see, that it´s the coordinator which no longer updates. I guess that may as well be the reason for the devices no longer responding.

I´m running the latest snapshot.