Zigbee problems after update to 2.5 M4

I have today updated my 2.5 M1 installation to 2.5 M4 and ran into troubles with my zigbee devices. Non of my two zigbee humidy nodes turned online. I tried to remove all zigbee devices and tried to re-add them. The coordinator (Ember EM35x NCP) is automatically detected and shown in the inbox. However after adding it it stays offline with a communication error. In the log I can see the following lines:

21:36:40.857 [DEBUG] [.zigbee.dongle.ember.ZigBeeDongleEzsp] - EZSP dongle initialize with protocol ASH2.

21:36:40.858 [DEBUG] [nding.zigbee.handler.ZigBeeSerialPort] - Connecting to serial port [/dev/ttyUSB0] at 57600 baud, flow control FLOWCONTROL_OUT_XONOFF.

21:36:40.860 [ERROR] [nding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyUSB0 does not exist.

21:36:40.861 [ERROR] [.zigbee.dongle.ember.ZigBeeDongleEzsp] - Unable to open Ember serial port

21:36:40.862 [DEBUG] [rtsystems.zigbee.ZigBeeNetworkManager] - Network state is updated to OFFLINE

The port is definitely available. And it was working before. Any ideas?

I am not where I can check but I vaguely recall a warning about the Ember devices when moving from M1 forward.
It may be worth looking at the Warnings generated when upgrading.

I had the exact same problem on my Odroid C2 when it updated to 2.5M4. I have given up trying to fix it.

I just tried with a fresh empty userdata directory and it seems to work… will continue to investigate

I’m not aware of any problems - what is the issue?

Perhaps it was just some changes.
All I see quickly are these 2.

Milestone 4

Milestone 2

These are just additions to the binding - nothing abnormal or any sort of problem, just new features.

OK, thanks. I likely saw them listed as changes then.

Glad to have you back here.

1 Like

Do not know much about Linux and configuration of USB/COM serial ports.

But if IIRC there were many issues with selecting the correct one. (or not shown in pull-down-menu)

Many were solved with something like this:

EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0:/dev/ttyUSB1"

EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0:/dev/ttyUSB1:/dev/ttySlimmeUSB:/dev/ttyTeleUSB -Xms250m -Xmx350m"

EXTRA_JAVA_OPTS="-Xms250m -Xmx350m -Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0"

EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0"

EXTRA_JAVA_OPTS are needed for Linus Serial ports & Zigbee. This is mentioned in the documentation. I recently tested & verified this.

If you are running on Linux, then you probably need to add the user ‘openhab’ to the tty group, and enable EXTRA_JAVA_OPTS for the serial port your coordinator uses (see Linux install guide).

from https://www.openhab.org/addons/bindings/zigbee/

it definitley was not an issue with the serial port not found by Java. Interestingly the coordinator was automatically found and shown in the inbox. Only after accepting it it did not work and I saw the log lines with /dev/ttyUSB0 not found.

After having removed all zigbee started once with a clean userdata directory and then again with my old userdata it is working fine again.
No idea what actually was the problem

1 Like

That is a symptom of needing the JAVA OPTS entry. That issue wil reoccur if you do not add the lines.
The port appears fir selection but does not always work. If you restart the zigbee binding it will likely break after.

Not exactly, Bruce…
The Java opts is there, but “something” happens when you add the Ember dongle.
The USB port is working just fine… It´s something going wrong when you add the coordinator.
I find it very surprising that cleaning (I suspect he mean emptying) the userdata folder will solve this issue. It seems like there is a “rediscovery” of the serialport which fails and hangs from the old previous data… I havn´t tried myself yet. Maybe I´ll give it a short try this weekend.

I tested quite extensively with an Ember controller and even opened a GitHub issue. The conclusion was the line is needed for all recent test versions.

Again - the java opts is there. I already got that line…
(Just come to think… maybe it got swiped during the update progress… I need to investigate that part ofcouse).

I did some investigation last night. It turned out my symlinks were gone probably due the update to 2.5M4.
I created the symlink again. I got the ember dongle online again, and add my devices again, incl the Ikea Tradfri motion sensor…

Two things:

  1. It can not be due to the missing symlinks, that I couldn´t get the ember dongle online. How come it worked after I did the symlinks again, is a mystery to me.
  2. The Ikea Tradfri motion sensor was found during scanning and added just fine - However, It seem to be missing a motion channel. All I´ve got is this:

Isn´t there suppose to be a switch for motion?

This is far better than it has ever been.
Now I´ll let the system run to see for how long it will continue to work. I may try a few restarts/reboots. But not these first coupple of days.

Edit forgot to say, the only channel which has updated, is the BatterLevel. I dont know how to force the others to update.