Zigbee - TI CC2531 firmware question

I’m working on installing the new Zigbee binding.

I have CC-Tool installed on a Raspberry Pi, and have the CC2531 and a debugger. I downloaded the file Z-Stack_Home_1.2.2a.exe from TI’s website (http://www.ti.com/tool/z-stack-archive) as the binding docs page instructs.

My stupid problem is that I can’t expand the EXE to get to the .hex files inside. My household runs on OS X and Raspbian; I’ve tried several solutions for opening EXE archives on both platforms but nothing works. I’ve tried unarchiver, keka, archive utility, unzip (terminal) and simply renaming the exe to a zip on Mac, and tried unzip and p7zip on Raspbian.

Has anyone else figured out a way around this? Or do I need to find a Windows computer to open the archive?


I think someone posted some hex files somewhere in the following thread.

Yes, here it is extracted.

Thanks @elevation and @chris!

However, I have a new problem.


cc-tool -e -w CC2531ZNP-Pro-Secure_Standard.hex -v r

fails with this output:

  Programmer: SmartRF04EB
  Target: CC2531
  Erasing flash...
  Writing flash (241 KB)...
  Completed (8.64 s.)
  Verifying flash...

I used these instructions to install CC-Tool. I also made sure to copy udev/90-cc-debugger.rules to /etc/udev/rules.d.

Any ideas?


I tried flashing my CC2531 clone 3 times (using procedure described in the link you cited) and had the same “Failed” output. I decided to try the dongle anyway and it worked! I’ve been running openhab2 with my new zigbee dongle for about two weeks controlling GE link bulbs without any issues.

Give it a try maybe yours will work too.


I’ve spent some more time tinkering with it. I get the same error every time I flashed… so I decided to try the dongle as is, on the chance that the only error was with the verify itself, and that the flash actually was successful.

I’m able to connect the coordinator device in PaperUI and it registers as online; additionally, I can add my Zigbee devices when put in pairing mode (so far, testing with two SmartThings Centralite power modules). They register as online and I assign them to items; however, any commands sent from my sitemap to the devices don’t update the state of the outlet. Similarly, manual toggles using the physical button are not registered by openHAB in the sitemap or the logs.

Firstly, I’m guessing the dongle has been flashed correctly, as I strongly doubt I’d get this far if there were problems with the firmware. However, I’m confused as to why the devices show as online yet are not controllable.

I’ve probably tinkered enough with this today and will try again tomorrow.

Thanks @momanz11, I think you’re right! I don’t think that my new issues are caused by the unexplained flashing error message. As an aside, I also am using a clone and not a genuine TI device.

cc-tool failed for me when I had the CC2531 in a keyboard USB port and the programmer in the computer. Swapping the two made verification go through (I first received exactly the output you had). I believe the keyboard USB port is non-powered and may have left too little power to the stick.

I did the flashing on macOS though, don’t know if that matters.